DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 3rd January 2017
psypro psypro is offline
Shell Scout
 
Join Date: Mar 2016
Location: Continent:Europe
Posts: 124
Default Font size

I have a 1920*1080 screen. I am writing this from inside cwm.
Still the text on a 15,6 laptop screen is to small to my liking.

I have tried:
Searching this forum with "font" as keyword.
Goggling it, lead me to try wsfontload, but it gives me error
Code:
# wsfontload -h 8 -e ibm /usr/share/misc/pcvtfonts/vt220l.808
"wsfrontload: WSDISPLAY.LDFONT: Invalid agrument"

Code:
xterm -fs 16
No effect I can see.



I want larger font for xterm, it is also oki if normal consol gets larger fonts aswell.
Reply With Quote
  #2   (View Single Post)  
Old 3rd January 2017
jggimi's Avatar
jggimi jggimi is online now
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 5,896
Default

The wsfontload(8) program loads fonts for the console, not for X11 window managers, and it only works with the vga(4) driver, which you do not have. (You reported here that you are using the wsfb(4) driver.)

Try selecting both a different font size and a different font, such as:

$ xterm -fs 16 -fa andale &
Reply With Quote
  #3   (View Single Post)  
Old 3rd January 2017
psypro psypro is offline
Shell Scout
 
Join Date: Mar 2016
Location: Continent:Europe
Posts: 124
Default

Thank you. This works. Where do I put it so it becomes the new default?
Reply With Quote
  #4   (View Single Post)  
Old 3rd January 2017
jggimi's Avatar
jggimi jggimi is online now
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 5,896
Default

In $HOME/.profile as an alias, if you start xterm from a shell, or perhaps in $HOME/.Xdefaults?

I've never used .Xresources or .Xdefaults to set fonts for xterm, but you can find examples on the web, such as here.

My window manager of choice lets me configure xterm options in its configuration file, so that's what I use for xterm options.
Reply With Quote
  #5   (View Single Post)  
Old 3rd January 2017
jggimi's Avatar
jggimi jggimi is online now
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 5,896
Default

Ah, you can also add these options to the xterm strings in your $HOME/.cwmrc file.
Reply With Quote
  #6   (View Single Post)  
Old 3rd January 2017
psypro psypro is offline
Shell Scout
 
Join Date: Mar 2016
Location: Continent:Europe
Posts: 124
Default

I start xterm inside of cwm with Ctrl+alt+return

Inside of my .cwmrc file.


Code:
# customize some bindings (C-control M-alt M1-button1)
bind M-r        exec
bind CM-r       reload
bind CM-l       label
#bind CM-t       "xterm -e \"top -s 0.6\"
bind CM-u 	"xterm -fs 22 -fa andale &"
bind CM-m       menusearch
mousebind M-1   window_move
mousebind CM-1  window_resize

# application menu
command hexchat hexchat
command thunderbird thunderbird
#command silc    "xterm -class silc -e mysilc.sh"
command firefox firefox

# groups predefined, use xprop to get these from each program
autogroup 2     "Navigator,Firefox"
autogroup 3     "hexchat"
autogroup 3     "thunderbird"
#autogroup 3     "xterm,silc"
#autogroup 4     "xterm,mail"

# inherit current selected group
sticky yes
Reply With Quote
  #7   (View Single Post)  
Old 4th January 2017
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 3,275
Default

Quote:
Originally Posted by psypro View Post
Where do I put it so it becomes the new default?
Alternatively, you can put the same information in ~/.Xdefaults. As an example,
I use a different font & size, but the following yields:
Code:
$ grep XTerm ~/.Xdefaults
XTerm*loginShell:true
XTerm*saveLines:32767
XTerm*background:black
XTerm*foreground:white
XTerm*scrollBar:true
XTerm*scrollBar_right:true
XTerm*faceName:Mono
XTerm*faceSize:10
$

Last edited by ocicat; 4th January 2017 at 12:21 AM. Reason: clarity
Reply With Quote
  #8   (View Single Post)  
Old 4th January 2017
psypro psypro is offline
Shell Scout
 
Join Date: Mar 2016
Location: Continent:Europe
Posts: 124
Default

Thank you. This fixed it permanently, and work with my default key for starting xterm (ctrl+alt+return)
Reply With Quote
  #9   (View Single Post)  
Old 3rd March 2017
DannyBoy DannyBoy is offline
New User
 
Join Date: Jul 2016
Posts: 4
Default

Just for the record, with xterm you can also use SHIFT + and SHIFT - to change font size on the fly.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing font size in xterm J65nko Guides 4 4th February 2012 09:05 PM
How to change the font size? atop xterm, aterm, etc jb_daefo General software and network 12 13th July 2010 10:42 AM
font-misc-ethiopic & font-misc-meltho Beastie General software and network 0 27th February 2009 11:21 AM
CLI font size idefix FreeBSD General 3 7th February 2009 11:19 AM
Wrong screen resolution, font size etc. PatrickBaer FreeBSD General 10 14th May 2008 10:00 AM


All times are GMT. The time now is 10:46 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick