DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Packages and Ports

OpenBSD Packages and Ports Installation and upgrading of packages and ports on OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 14th March 2015
Valus Valus is offline
Port Guard
 
Join Date: Feb 2015
Location: EU
Posts: 22
Default roundcubemail-1.1.0p0 - unable to open database file

Hi All,

I have Openbsd snapshot 5.7 and I am trying to configure package roundcubemail-1.1.0p0
Code:
 
$ dmesg | head -10              
OpenBSD 5.7 (GENERIC) #825: Sun Mar  8 10:59:14 MDT 2015
    deraadt@amd64.openbsd.org:/usr/src/sys/arch/amd64/compile/GENERIC
real mem = 520081408 (495MB)
avail mem = 502415360 (479MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.4 @ 0x1ffffec0 (10 entries)
bios0: vendor Seabios version "0.5.1" date 01/01/2007
bios0: Red Hat KVM
During second the step of installer I get error
Code:
 
Check DB config
DSN (write):  NOT OK(SQLSTATE[HY000] [14] unable to open database file)
Make sure that the configured database exists and that the user has write privileges
DSN: sqlite:/var/www/roundcubemail/db/sqlite.db?mode=0660
The database has the following permission:
Code:
 
$ ls -l /var/www/roundcubemail/                                                                     
total 2516
-r--r--r--   1 root  www   122716 Feb  8 13:48 CHANGELOG
-r--r--r--   1 root  www     1290 Feb  8 13:48 Dockerfile
-r--r--r--   1 root  www     9459 Feb  8 13:48 INSTALL
-r--r--r--   1 root  www    35147 Feb  8 13:48 LICENSE
-r--r--r--   1 root  www     3750 Feb  8 13:48 README.md
drwxr-xr-x   6 root  www      512 Mar  9 12:11 SQL
-r--r--r--   1 root  www     2974 Feb  8 13:48 UPGRADING
drwxr-x---   2 root  www      512 Mar  9 12:11 bin
-rw-r--r--   1 root  www     1548 Mar  9 12:11 composer.json
-r--r--r--   1 root  www     1548 Feb  8 13:48 composer.json-dist
-rwx------   1 root  www  1038934 Mar  8 03:58 composer.phar
drwxr-xr-x   2 root  www      512 Mar  9 12:11 config
drwxrwxr-x   2 root  www      512 Mar 12 15:00 db
-r--r--r--   1 root  www    12323 Feb  8 13:48 index.php
drwxr-xr-x   3 root  www      512 Mar  9 12:11 installer
drwxrwx---   2 root  www      512 Mar 12 15:36 logs
drwxr-xr-x  34 root  www     1024 Mar  9 12:11 plugins
drwxr-xr-x   8 root  www      512 Mar  9 12:11 program
-r--r--r--   1 root  www       26 Feb  8 13:48 robots.txt
-r--r--r--   1 root  www      448 Mar  8 03:58 roundcubemail.conf.dist
drwxr-xr-x   4 root  www      512 Mar  9 12:11 skins
drwxrwx---   2 root  www      512 Mar  9 12:11 temp
$ ls -l /var/www/roundcubemail/db
total 92
-rw-rw----  1 root  www  46080 Mar 12 15:00 sqlite.db
Which user does need to write to the database or what could be wrong?

There is one more problem:
Code:
Test filetype detection
Fileinfo/mime_content_type configuration:  OK
Mimetype to file extension mapping:  NOT OK

Please set a valid path to your webserver's mime.types file to the mime_types config option.
If you can't find such a file, download it from svn.apache.org.
I am not running apache, but openbsd httpd.
Thanks for help.

Valus
Reply With Quote
  #2   (View Single Post)  
Old 14th March 2015
TronDD TronDD is offline
Package Pilot
 
Join Date: Sep 2014
Posts: 149
Default

I had the same problem... I *think* I just had to get the path right. If you edit the config.inc.php file directly, this is what I have:
Code:
$config['db_dsnw'] = 'sqlite:////roundcubemail/db/sqlite.db?mode=0646';
Looking at it now, it should be relative to the chroot, so starting it with "/var/www" would be incorrect.

As for the mime-types, I think I still have that error, too. Haven't bothered to look into it.

Tim.

Last edited by ocicat; 14th March 2015 at 11:33 PM. Reason: added [code] & [/code] to add clarity
Reply With Quote
  #3   (View Single Post)  
Old 15th March 2015
Valus Valus is offline
Port Guard
 
Join Date: Feb 2015
Location: EU
Posts: 22
Default

Hi Tim,
I changed the line as you wrote and now it is working.
Code:
$config['db_dsnw'] = 'sqlite:////roundcubemail/db/sqlite.db?mode=0660';
I tried this before,but only with /// insead of ////. This was my mistake.
Thanks.
Valus
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Network Printing, no output or errors from "lpr 'filename' spacebar_permissions OpenBSD General 15 29th January 2016 08:13 PM
ZFS and Database fragmentation J65nko General software and network 2 26th February 2014 07:11 AM
Uploading a file using ftp and/or a .netrc file from the command line J65nko Guides 3 16th February 2013 11:53 AM
unable to get packages/INDEX file from selected media... clovis FreeBSD Installation and Upgrading 5 11th August 2010 07:39 PM
PHP read file contents - Maximum file size cksraj Programming 1 21st September 2009 11:38 AM


All times are GMT. The time now is 11:21 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick