DaemonForums  

Go Back   DaemonForums > NetBSD > NetBSD Package System (pkgsrc)

NetBSD Package System (pkgsrc) Installation and upgrading of packages on NetBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 8th November 2015
darktrym's Avatar
darktrym darktrym is offline
standard-bearer
 
Join Date: Feb 2011
Location: Düsseldorf
Posts: 100
Default Update SciTe package to 3.62

I'm trying to update the package version to the newest(3.62). This required an update to scintilla 3.62. As a reference i used the old files from 3.39 and the OpenBSD port but i'm stuck in the linking phase(compiling looks good).
The current version of scintilla required one more header file Sci_Position.h(easy to update) and should produce two libs scintilla.a and scintilla_lexers.a. But the second isn't generated. Also i can see that pkgsrc patch the makefile under gtk directory but i don't see a patch in the patch directory.
Has some an idea how can i finish this work?
OpenBSD uses also patches for scintilla but the NetBSD directory don't needed that as far i can see.
Reply With Quote
  #2   (View Single Post)  
Old 21st August 2016
darktrym's Avatar
darktrym darktrym is offline
standard-bearer
 
Join Date: Feb 2011
Location: Düsseldorf
Posts: 100
Default

Ok, i think i fixed the most problems so now i can build scintilla in version 3.6.6. I updated the scite version so i can compile but during the build process i get in the last step an error:

Quote:
ld: warning: libfreetype.so.17, needed by /usr/pkgsrc/editors/scite/work/.buildlink/lib/libgtk-x11-2.0.so, may conflict with libfreetype.so.18
/usr/pkg/lib/libfontconfig.so.1: warning: warning: reference to compatibility initstate(); include <stdlib.h> for correct reference
/usr/pkgsrc/editors/work/.buildlink/lib/libpangoft2-1.0.so: undefined reference to 'hb_buffer_set_cluster_level'
/usr/pkgsrc/editors/work/.buildlink/lib/libgtk-x11-2.0.so: undefined reference to 'g_type_check_instance_is_fundamentally_a'
makefile:118: recipe for taget '../bin/SciTE' failed
gmake: *** [../bin/SciTE]] Error 1
*** Error code 2

Stop.
make[1]: stopped in /usr/pkgsrc/editors/scite
*** Error code 1

Stop.
make: stopped in /usr/pkgsrc/editors/scite
Any ideas?
Reply With Quote
  #3   (View Single Post)  
Old 3rd September 2016
darktrym's Avatar
darktrym darktrym is offline
standard-bearer
 
Join Date: Feb 2011
Location: Düsseldorf
Posts: 100
Default

Ok, i found the problem so this message is only for google.
The problem was that pango required harfbuzz. In the source code you can find a line for exporting hb_buffer_set_cluster_level but this is only for version > 1.03. On my system harfbuzz 0.93 was installed. So I build gtk2+, pango, harfbuzz and now i have SciTE 3.66.
__________________
NetBSD 8.99.1(AMD64)@Xiaomi Air 1.Gen
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
doas package Peter_APIIT OpenBSD General 2 1st November 2015 07:45 AM
New Package Format shep OpenBSD Packages and Ports 1 22nd September 2014 03:42 PM
package questions sharris FreeBSD Ports and Packages 4 4th July 2011 10:23 AM
Apache HTTP Server update fixes remote DoS issue - Update J65nko News 0 12th May 2011 07:21 PM
tcpdump package bsdnewbie999 OpenBSD Packages and Ports 6 30th March 2009 05:24 PM


All times are GMT. The time now is 02:03 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick