DaemonForums  

Go Back   DaemonForums > NetBSD > NetBSD Installation and Upgrading

NetBSD Installation and Upgrading Have trouble getting NetBSD on your toaster?

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 28th May 2016
KenJackson KenJackson is offline
Real Name: Ken Jackson
Multi-OS Guy
 
Join Date: Oct 2008
Posts: 6
Default DRM i915 gmch panic installing NetBSD 7.0.1 amd64

I'm trying to install NetBSD 7.0.1 amd64 on a 10-year old Intel DG35EC board with an Intel Core2 Quad Q8200 processor. The installation menu appears normally, I select 1, 2 or 3 to install with or without ACPI and SMP and it starts unwinding some installation files.

Then it panics with green text on black. I can't capture the text, but I wrote some of it down:
Code:
...
agpo: can't find MMIO registers i915drmkms0 at pci0 dev 2 function 0: vendor 0x8086 product 02982 (rev. 0x03)
...
DRM error in i915_gmch_probe: failed to setup gmch
...
panic: extent_free: region not found...
I've run Windows and FreeBSD on this machine and it currently boots a Finnix 111 rescue Linux USB stick OK. I've tried using a different USB drive.

Is there any way to get NetBSD installed on this machine?
Reply With Quote
  #2   (View Single Post)  
Old 29th May 2016
schnoebe schnoebe is offline
Real Name: Eric Schnoebelen
old timer
 
Join Date: Feb 2016
Location: Plano, TX, US
Posts: 31
Default Disable the i915 drivers.

At the boot prompt from the CD, (select 1,2,3,etc), drop to the boot command prompt, and then disable the i915* modules by entering the following:
Code:
userconf disable i915*
(I believe that's the correct, double check with manual pages to be sure.)

Last edited by schnoebe; 29th May 2016 at 12:14 AM. Reason: correcting the quote to a code block
Reply With Quote
  #3   (View Single Post)  
Old 2nd June 2016
KenJackson KenJackson is offline
Real Name: Ken Jackson
Multi-OS Guy
 
Join Date: Oct 2008
Posts: 6
Default

Couldn't get it to work, so I installed OmniOS instead.

I wanted to get back to NetBSD, partly because I liked using a simple UNIX with pkgsrc. But I also wanted to try out one of the illumos Solaris distros.

Even though OmniOS is intended to be a server, not a desktop, I can use Joyent's pkgsrc repo. It's intended for their own illumos Solaris distro, SmartOS, but it works just fine with OmniOS.

I haven't gotten X to work yet (always a problem with everything but Linux), but I've installed lots of pkgsrc packages. Fun.
Reply With Quote
Reply

Tags
agpo, install, mmio, netbsd, panic

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
5.9 amd64 kernel panic after 004_mbuf.patch.sig patch shep OpenBSD General 0 2nd May 2016 04:34 PM
Enabling Adobe flash in NetBSD 7.0 amd64 DaBSD NetBSD Package System (pkgsrc) 5 4th January 2016 04:04 PM
ndis on NetBSD amd64 ? pawaan NetBSD General 0 17th December 2014 04:24 PM
kernel panic (amd64,5.1 release) on Aspire 5750 obsdnewbie OpenBSD Installation and Upgrading 10 5th June 2012 11:17 PM
NetBSD amd64 NVidia Quadro NVS 285 video card morten42 NetBSD General 5 30th July 2008 03:49 PM


All times are GMT. The time now is 01:34 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick