DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Installation and Upgrading

OpenBSD Installation and Upgrading Installing and upgrading OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 4 Weeks Ago
nedry nedry is offline
New User
 
Join Date: Nov 2017
Posts: 7
Default wireless card setup problems

Hi i am trying to setup wifi with ipw0 network card, i have the correct firmware driver installed, a dmesg | grep ipw0 shows the adaptor i can scan for wifi networks and see the network i want to connect to, i can add to /etc/hostname.ipw0 the following config:

dhcp nwid mynetwork wpakey mykey

but when i try and ping my router i get no route to host.

dhclient ipw0 says:

ipw0: no link .... sleeping

when i look at my ifconfig i have:

ipw0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
lladdr 00:04:23:74:f4:ee
index 2 pritority 4 llprio 3
groups:wlan
media: IEEE802.11 autoselect (DS11 mode 11b)
status: active

etc

any help would be great
Reply With Quote
  #2   (View Single Post)  
Old 4 Weeks Ago
jmccue jmccue is offline
Real Name: John McCue
New User
 
Join Date: Aug 2012
Location: here
Posts: 7
Default

Can you do this before dhcpclient ?

Code:
# ifconfig ipw0 nwid "mynetwork" wpakey "PASSWORD"
I never set up any /etc/hostname.* files since I would rather connect when I want to.
Reply With Quote
  #3   (View Single Post)  
Old 4 Weeks Ago
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 5,980
Default

See this section of the FAQ. The "dhcp" statement in your hostname.ipw0 file must be by itself, and follow after setting the nwid and wpakey.

http://www.openbsd.org/faq/faq6.html#Wireless
Reply With Quote
  #4   (View Single Post)  
Old 3 Weeks Ago
LeFrettchen's Avatar
LeFrettchen LeFrettchen is offline
Marveled user
 
Join Date: Aug 2012
Location: Bronvaux, France
Posts: 264
Default

Strange...
My /etc/hostame.iwn0 file contained
Code:
dhcp nwid <mywifi> wpakey <mykey>
and it worked...

Anyway, I changed today the file as recommended...
Quote:
nwid <mywifi>
wpakey <mykey>
dhcp
Of course, it still works
__________________
The secret of wisdom is not wisdom itself, it's the road that leads us there.

Last edited by LeFrettchen; 3 Weeks Ago at 12:28 PM. Reason: Today precision
Reply With Quote
  #5   (View Single Post)  
Old 3 Weeks Ago
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 5,980
Default

I assumed order-of-execution was the issue, due to the ifconfig(8) output shown above. There was no nwid or wpakey assigned.

(The status was "active" which doesn't appear to be possible in that situation.)
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenBSD Router & Wireless AP setup chigurh OpenBSD General 14 7th April 2015 06:56 PM
Wireless Setup With AuthPF Help EverydayDiesel OpenBSD Security 3 2nd July 2014 11:38 PM
HOWTO: Working Intel Graphics Card Setup vermaden FreeBSD Installation and Upgrading 2 3rd July 2009 07:59 PM
Question regarding wireless setup stealintv FreeBSD General 5 19th September 2008 07:36 PM
Wireless Card on T61 disappearedng FreeBSD General 1 13th July 2008 12:54 AM


All times are GMT. The time now is 05:19 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick