DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 28th July 2019
joancatala joancatala is offline
Port Guard
 
Join Date: Jun 2011
Posts: 30
Default I burn an image on a pendrive with dd, but it doesn't boot

Hi all,
I want to have a Linux distribution (Raspbian Desktop) on a USB Pendrive.

I downloaded Raspbian Desktop.
I inserted the USB pendrive.
I did:

Code:
x201$ doas dd if=raspbian-buster-full.img of=/dev/rsd1c bs=32M                                                                                                                                        
191+1 records in
191+1 records out
6434062336 bytes transferred in 1379.547 secs (4663895 bytes/sec)
And after 15 minutes, I tried the USB booting my computer, but I doesn't boot.
(I tried on a Windows with win32imager and works. so the file .img works fine. )

Why I can't boot from the USB when I do 'dd' on OpenBSD? I am doing something wrong?
Reply With Quote
  #2   (View Single Post)  
Old 28th July 2019
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 6,712
Default

The command looks correct. What is reported when you inspect the drive with # fdisk sd1?

Last edited by jggimi; 28th July 2019 at 09:18 PM. Reason: typo
Reply With Quote
  #3   (View Single Post)  
Old 28th July 2019
joancatala joancatala is offline
Port Guard
 
Join Date: Jun 2011
Posts: 30
Default

This:

Code:
x201$ doas fdisk sd1
Disk: sd1       geometry: 15077/255/63 [242221055 Sectors]
Offset: 0       Signature: 0xAA55
            Starting         Ending         LBA Info:
 #: id      C   H   S -      C   H   S [       start:        size ]
-------------------------------------------------------------------------------
 0: 0C      0 130   3 -     33  37   5 [        8192:      524289 ] FAT32L      
 1: 83     33 167   7 -    782  58  44 [      540672:    12025856 ] Linux files*
 2: 00      0   0   0 -      0   0   0 [           0:           0 ] unused      
 3: 00      0   0   0 -      0   0   0 [           0:           0 ] unused
Reply With Quote
  #4   (View Single Post)  
Old 28th July 2019
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 6,712
Default

Interesting. This appears to be a valid MBR in the first sector, but neither of the two defined MBR partitions are flagged as the active, bootable partition.

This is why it does not boot.

Compare the "on disk" MBR with the image's first sector.
Code:
# dd if=/dev/rsd1c count=1 of=on.disk.mbr
$ dd if=raspbian-buster-full.img count=1 of=image.mbr
$ diff image.mbr on.disk.mbr
Reply With Quote
  #5   (View Single Post)  
Old 28th July 2019
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 6,712
Default

If the USB device's MBR differs from the downloaded image file's MBR, you know the problem is in the transfer to the USB device.

If they are the same, then you know the download was likely to be at fault, and can compare a hash of the image with one provided by the distribution.

Last edited by jggimi; 28th July 2019 at 09:35 PM. Reason: another typo
Reply With Quote
  #6   (View Single Post)  
Old 14th August 2019
joancatala joancatala is offline
Port Guard
 
Join Date: Jun 2011
Posts: 30
Default

@jggimi thanks for your answer and your time. Finally I just downloaded a different image (a Ubuntu 19.04) and it worked perfectly. I don't know why the Raspbian-image wasn't working. Mistery.

Thanks and regards.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ln -f at boot doesn't work lordyan OpenBSD General 3 19th February 2009 03:50 PM
NetBSD pre-release 5 doesn`t boot welkin NetBSD Installation and Upgrading 4 6th January 2009 10:13 PM
I can't make FreeBSD floppy/boot image disks under Windows with fdimage Turquoise88 FreeBSD Installation and Upgrading 4 12th November 2008 08:39 PM
After an update stable doesn't boot hamba FreeBSD Installation and Upgrading 18 23rd October 2008 10:58 PM
FreeBSD doesn't boot purak FreeBSD Installation and Upgrading 7 9th October 2008 05:24 PM


All times are GMT. The time now is 04:57 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick