DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
Old 5th August 2019
jonsec jonsec is offline
Port Guard
 
Join Date: Jul 2019
Posts: 24
Smile

Quote:
Originally Posted by jggimi View Post
This is your problem. The fastcgi syntax you are using is from OpenBSD 6.5.

You are using OpenBSD 6.4 but not referring to the OpenBSD httpd.conf(5) man page.

If you are using the OpenBSD man pages at man.openbsd.org, you may not realize these are -current man pages by default, and you must select your release.

Man pages are available locally if you installed the man64.tgz fileset. Try $ man httpd.conf to obtain the man page that matches your release.

You will want to upgrade if you want to set these parameters.
oops yes. your right.

thanks all.
Reply With Quote
Old 5th August 2019
PapaParrot's Avatar
PapaParrot PapaParrot is offline
parrot
 
Join Date: Jul 2015
Location: Durango, Mx.
Posts: 410
Default

Interesting, thanks jggimi, a couple of things learned here, 1. never assume anything. ( I was just assuming the OP is using OpneBsd 6.5 , should have asked about that. Also a lot of the information I linked to is really old, and I did not think it would matter much , but apparently it does,
@jonsec, please do let us know if it works after upgrading. I see on your first post you say it is solved,


Quote:
Originally Posted by jonsec View Post
hi. i cant set fastcgi param and i get syntax error.

httpd.conf
Code:
prefork 10

server "test.example.com" {

    ...

    location match "^.+%.php$" {
        fastcgi socket "/run/php-fpm-example"
        fastcgi param HTTP_HOST "test.example.com" <--- syntax error
    }

    ...   

}

---------------------------------[Solved]

answer : httpd in OpenBSD 6.4 not support fastcgi param syntax.
Did you try it yet on 6.5 ?
Thanks
__________________
My best friends are parrots
Reply With Quote
Old 6th August 2019
jonsec jonsec is offline
Port Guard
 
Join Date: Jul 2019
Posts: 24
Default

Quote:
Originally Posted by PapaParrot View Post
Interesting, thanks jggimi, a couple of things learned here, 1. never assume anything. ( I was just assuming the OP is using OpneBsd 6.5 , should have asked about that. Also a lot of the information I linked to is really old, and I did not think it would matter much , but apparently it does,
@jonsec, please do let us know if it works after upgrading. I see on your first post you say it is solved,

Did you try it yet on 6.5 ?
Thanks
Quote:
I see on your first post you say it is solved,
yes. this edit is for the convenience of users(or guest).

anything is clear in this doc.
https://man.openbsd.org/OpenBSD-6.4/httpd.conf.5
in httpd(OpenBSD 6.4) docs , param feature is not exists. I didn't pay attention to this.
Reply With Quote
Reply

Tags
httpd, httpd fastcgi

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ipsec.conf Syntax error Dr-D OpenBSD Security 8 14th November 2018 11:57 PM
httpd fastcgi configuration and programming hanzer OpenBSD General 11 27th February 2015 01:45 PM
Pf.conf:29 syntax error CyberJet OpenBSD Security 17 3rd May 2013 06:41 PM
Am I blind? syntax error: `(' unexpected guitarscn Programming 1 10th November 2010 08:53 PM
shc unistd.h:239: error: syntax error before '&' token laraaj OpenBSD General 3 11th September 2010 07:21 AM


All times are GMT. The time now is 04:22 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick