DaemonForums  

Go Back   DaemonForums > Other Operating Systems > Other BSD and UNIX/UNIX-like

Other BSD and UNIX/UNIX-like Any other flavour of BSD or UNIX that does not have a section of its own.

Reply
 
Thread Tools Display Modes
Old 4th December 2014
J65nko J65nko is offline
Administrator
 
Join Date: May 2008
Location: Budel - the Netherlands
Posts: 3,496
Default

Re: Toolchain in base.

In OpenBSD the compiler tool chain also is not in baseXX.tgz. You have to install the compXX.tgz file set.

With Bitrig the compiler is also not in their baseXX.tgz. But for reasons explained in https://github.com/bitrig/bitrig/wik...-on-first-boot it is a set of packages.
I don't see a big difference
__________________
You don't need to be a genius to debug a pf.conf firewall ruleset, you just need the guts to run tcpdump
Reply With Quote
Old 4th December 2014
Oko's Avatar
Oko Oko is offline
Rc.conf Instructor
 
Join Date: May 2008
Location: Kosovo, Serbia
Posts: 1,087
Default

Quote:
Originally Posted by J65nko View Post
Re: Toolchain in base.

In OpenBSD the compiler tool chain also is not in baseXX.tgz. You have to install the compXX.tgz file set.
Of course not. It is in compXX.tgz Topic of excluding compiler has been hashed to the death and IIRC leaving out compiler from the installation doesn't add to security.

Quote:
Originally Posted by J65nko View Post
With Bitrig the compiler is also not in their baseXX.tgz. But for reasons explained in https://github.com/bitrig/bitrig/wik...-on-first-boot it is a set of packages.
I don't see a big difference
I can assure you that OpenBSD is perfectly capable of compiling without connecting to Internet.
Reply With Quote
Old 4th December 2014
J65nko J65nko is offline
Administrator
 
Join Date: May 2008
Location: Budel - the Netherlands
Posts: 3,496
Default

Bitrig now has a compXX.tgz file set. From my current KVM install using serial console:
Code:
Let's install the sets!
Location of sets? (cd disk http nfs or 'done') [http] 
HTTP proxy URL? (e.g. 'http://proxy:8080', or 'none') [none] 
HTTP Server? (hostname, list#, 'done' or '?') [mirror2.us.bitrig.org] 
Server directory? [pub/bitrig/release/1.0/amd64] 

Select sets by entering a set name, a file name pattern or 'all'. De-select
sets by prepending a '-' to the set name, file name pattern or 'all'. Selected
sets are labelled '[X]'.
    [X] bsd           [X] base10.tgz    [X] game10.tgz    [X] xshare10.tgz
    [X] bsd.rd        [X] comp10.tgz    [X] xbase10.tgz   [X] xfont10.tgz
    [X] bsd.sp        [X] etc10.tgz     [X] xetc10.tgz    [X] xserv10.tgz
Set name(s)? (or 'abort' or 'done') [done] -game*
    [X] bsd           [X] base10.tgz    [ ] game10.tgz    [X] xshare10.tgz
    [X] bsd.rd        [X] comp10.tgz    [X] xbase10.tgz   [X] xfont10.tgz
    [X] bsd.sp        [X] etc10.tgz     [X] xetc10.tgz    [X] xserv10.tgz
The verify and download:
Code:
Set name(s)? (or 'abort' or 'done') [done] 
Get/Verify SHA256.sig   100% |**************************|  1696       00:00    
Signature Verified
Get/Verify bsd          100% |**************************| 10455 KB    00:23    
Get/Verify bsd.rd       100% |**************************| 16084 KB    00:27    
Get/Verify bsd.sp       100% |**************************| 10403 KB    00:19    
Get/Verify base10.tgz   100% |**************************| 65577 KB    01:32    
Get/Verify comp10.tgz   100% |**************************| 80406 KB    01:47    
Get/Verify etc10.tgz    100% |**************************|   178 KB    00:01    
Get/Verify xbase10.tgz  100% |**************************| 16051 KB    00:30    
Get/Verify xetc10.tgz   100% |**************************| 68836       00:01    
Get/Verify xshare10.tgz 100% |**************************|  4374 KB    00:08    
Get/Verify xfont10.tgz  100% |**************************| 38977 KB    01:02    
Get/Verify xserv10.tgz  100% |**************************| 18269 KB    00:23    
Installing bsd          100% |**************************| 10455 KB    00:00    
Installing bsd.rd       100% |**************************| 16084 KB    00:00    
Installing bsd.sp       100% |**************************| 10403 KB    00:00    
Installing base10.tgz   100% |**************************| 65577 KB    00:08    
Installing comp10.tgz   100% |**************************| 80406 KB    00:06    
Installing etc10.tgz    100% |**************************|   178 KB    00:00    
Installing xbase10.tgz  100% |**************************| 16051 KB    00:01    
Installing xetc10.tgz   100% |**************************| 68836       00:00    
Installing xshare10.tgz 100% |**************************|  4374 KB    00:01    
Installing xfont10.tgz  100% |**************************| 38977 KB    00:01    
Installing xserv10.tgz  100% |**************************| 18269 KB    00:01    
Location of sets? (cd disk http nfs or 'done') [done] 

What timezone are you in? ('?' for list) [Canada/Mountain] Europe/Amsterdam
Saving configuration files...Making all device nodes...done.
Completed install. If applicable remove installation media before
typing 'reboot' at the command prompt.
Looking at the older snapshots, I find the first compXX.tgz set in July 2014.
__________________
You don't need to be a genius to debug a pf.conf firewall ruleset, you just need the guts to run tcpdump
Reply With Quote
Old 5th December 2014
pawaan pawaan is offline
Fdisk Soldier
 
Join Date: Jan 2013
Posts: 82
Default

My first Bitrig amd64 journey
Code:
kern.version=Bitrig 1.0 (GENERIC) #1: Tue Nov 25 14:22:54 MST 2014
    root@amd64b0.bitrig.org:/usr/src/sys/arch/amd64/compile/GENERIC
    master:5a3eaa652924c2472b4f4b29a84b2c30f3530d1a
Code:
Bitrig 1.0 (GENERIC) #1: Tue Nov 25 14:22:54 MST 2014
    root@amd64b0.bitrig.org:/usr/src/sys/arch/amd64/compile/GENERIC
    master:5a3eaa652924c2472b4f4b29a84b2c30f3530d1a
RTC BIOS diagnostic error bf<clock_battery,config_unit,memory_size,fixed_disk,invalid_time>
real mem = 4006547456 (3820MB)
avail mem = 3895361536 (3714MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.6 @ 0xafd1c000 (20 entries)
bios0: vendor Hewlett-Packard version "68DVA Ver. F.03" date 08/13/2010
bios0: Hewlett-Packard HP 625
acpi0 at bios0: rev 0
acpi0: sleep states S0 S3 S4 S5
acpi0: tables DSDT FACP APIC MCFG SLIC HPET SSDT
acpi0: wakeup devices PCI0(S4) PB4_(S5) NIC_(S5) PB5_(S5) PB9_(S5) PB7_(S5) ECF0(S5) HDEF(S0) USB0(S3) USB1(S3) USB4(S3) USB5(S3)
acpitimer0 at acpi0: 3579545 Hz, 32 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: AMD Athlon(tm) II P360 Dual-Core Processor, 2294.36 MHz
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,MWAIT,CX16,POPCNT,NXE,MMXX,FFXSR,PAGE1GB,LONG,3DNOW2,3DNOW,LAHF,CMPLEG,SVM,EAPICSP,AMCR8,ABM,SSE4A,3DNOWP,OSVW,IBS,SKINIT,NODEID,ITSC
cpu0: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache, 512KB 64b/line 16-way L2 cache
cpu0: ITLB 32 4KB entries fully associative, 16 4MB entries fully associative
cpu0: DTLB 48 4KB entries fully associative, 48 4MB entries fully associative
cpu0: AMD erratum 721 detected and fixed
cpu0: smt 0, core 0, package 0
mtrr: Pentium Pro MTRR support, 8 var ranges, 88 fixed ranges
cpu0: apic clock running at 199MHz
cpu0: mwait min=64, max=64, C-substates=0.0.0.0.0, IBE
cpu1 at mainbus0: apid 1 (application processor)
cpu1: AMD Athlon(tm) II P360 Dual-Core Processor, 2294.39 MHz
cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,MWAIT,CX16,POPCNT,NXE,MMXX,FFXSR,PAGE1GB,LONG,3DNOW2,3DNOW,LAHF,CMPLEG,SVM,EAPICSP,AMCR8,ABM,SSE4A,3DNOWP,OSVW,IBS,SKINIT,NODEID,ITSC
cpu1: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache, 512KB 64b/line 16-way L2 cache
cpu1: ITLB 32 4KB entries fully associative, 16 4MB entries fully associative
cpu1: DTLB 48 4KB entries fully associative, 48 4MB entries fully associative
cpu1: AMD erratum 721 detected and fixed
cpu1: smt 0, core 1, package 0
ioapic0 at mainbus0: apid 4 pa 0xfec00000, version 21, 24 pins
ioapic0: misconfigured as apic 0, remapped to apid 4
acpimcfg0 at acpi0 addr 0xe0000000, bus 0-255
acpihpet0 at acpi0: 14318180 Hz
acpi0: WARNING EC not initialized
acpiprt0 at acpi0: bus 1 (PEGP)
acpiprt1 at acpi0: bus -1 (PEG2)
acpiprt2 at acpi0: bus 2 (PB4_)
acpiprt3 at acpi0: bus -1 (PB5_)
acpiprt4 at acpi0: bus 6 (PB9_)
acpiprt5 at acpi0: bus 3 (PB7_)
acpiprt6 at acpi0: bus 0 (PCI0)
acpiec0 at acpi0
acpicpu0 at acpi0: PSS
acpicpu1 at acpi0: PSS
acpipwrres0 at acpi0: APPR, resource for HDEF
acpipwrres1 at acpi0: PFN0, resource for FAN0
acpipwrres2 at acpi0: PFN1, resource for FAN1
acpipwrres3 at acpi0: PFN2, resource for FAN2
acpipwrres4 at acpi0: PFN3, resource for FAN3
acpipwrres5 at acpi0: PFN4, resource for FAN4
acpitz0 at acpi0: critical temperature is 108 degC
acpitz1 at acpi0: critical temperature is 108 degC
acpibat0 at acpi0: BAT0 model "Primary" serial 06255 2011/03/18 type LIon oem "Hewlett-Packard"
acpibat1 at acpi0: BAT1 not present
acpiac0 at acpi0: AC unit online
acpibtn0 at acpi0: SLPB
acpibtn1 at acpi0: LID_
acpivideo0 at acpi0: IGFX
acpivout0 at acpivideo0: LCD_
acpivideo1 at acpi0: EGFX
cpu0: 2294 MHz: speeds: 2300 1700 800 MHz
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "AMD RS880 Host" rev 0x00
ppb0 at pci0 dev 1 function 0 vendor "Hewlett-Packard", unknown product 0x9602 rev 0x00
pci1 at ppb0 bus 1
radeondrm0 at pci1 dev 5 function 0 "ATI Mobility Radeon HD 4200" rev 0x00
drm0 at radeondrm0
radeondrm0: apic 4 int 18
azalia0 at pci1 dev 5 function 1 "ATI Radeon HD 4200 HD Audio" rev 0x00: msi
azalia0: no supported codecs
ppb1 at pci0 dev 4 function 0 "AMD RS780 PCIE" rev 0x00: msi
pci2 at ppb1 bus 2
re0 at pci2 dev 0 function 0 "Realtek 8101E" rev 0x02: RTL8102EL (0x2480), msi, address 78:e3:b5:49:13:b1
rlphy0 at re0 phy 7: RTL8201L 10/100 PHY, rev. 1
ppb2 at pci0 dev 7 function 0 "AMD RS780 PCIE" rev 0x00: msi
pci3 at ppb2 bus 3
ppb3 at pci0 dev 9 function 0 "AMD RS780 PCIE" rev 0x00: msi
pci4 at ppb3 bus 6
"Broadcom BCM4313" rev 0x01 at pci4 dev 0 function 0 not configured
ahci0 at pci0 dev 17 function 0 "ATI SBx00 SATA" rev 0x00: apic 4 int 19, AHCI 1.2
scsibus1 at ahci0: 32 targets
sd0 at scsibus1 targ 0 lun 0: <ATA, WDC WD800BJKT-75, 11.0> SCSI3 0/direct fixed naa.50014ee20375cb02
sd0: 76319MB, 512 bytes/sector, 156301488 sectors
cd0 at scsibus1 targ 1 lun 0: <hp, CDDVDW TS-L633R, 0300> ATAPI 5/cdrom removable
ohci0 at pci0 dev 18 function 0 "ATI SB700 USB" rev 0x00: apic 4 int 18, version 1.0, legacy support
ehci0 at pci0 dev 18 function 2 "ATI SB700 USB2" rev 0x00: apic 4 int 17
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "ATI EHCI root hub" rev 2.00/1.00 addr 1
ohci1 at pci0 dev 19 function 0 "ATI SB700 USB" rev 0x00: apic 4 int 18, version 1.0, legacy support
ehci1 at pci0 dev 19 function 2 "ATI SB700 USB2" rev 0x00: apic 4 int 17
usb1 at ehci1: USB revision 2.0
uhub1 at usb1 "ATI EHCI root hub" rev 2.00/1.00 addr 1
piixpm0 at pci0 dev 20 function 0 "ATI SBx00 SMBus" rev 0x42: polling
iic0 at piixpm0
iic0: addr 0x4c 00=32 01=3e 02=80 03=20 04=06 05=4b 07=5a 09=20 0a=06 0b=4b 0d=5a 10=40 19=5f 20=55 21=0a 22=70 25=0d 27=12 29=c0 60=06 70=06 71=05 a4=7e a5=60 ac=29 ad=12 ae=06 af=50 b0=20 b1=20 fd=20 fe=5d ff=01 words 00=32ff 01=3eff 02=80ff 03=20ff 04=06ff 05=4bff 06=00ff 07=5aff
spdmem0 at iic0 addr 0x51: 4GB DDR3 SDRAM PC3-10600 SO-DIMM
azalia1 at pci0 dev 20 function 2 "ATI SBx00 HD Audio" rev 0x40: apic 4 int 16
azalia1: codecs: IDT/0x7667
audio0 at azalia1
pcib0 at pci0 dev 20 function 3 "ATI SB700 ISA" rev 0x40
ppb4 at pci0 dev 20 function 4 "ATI SB600 PCI" rev 0x40
pci5 at ppb4 bus 7
ohci2 at pci0 dev 20 function 5 "ATI SB700 USB" rev 0x00: apic 4 int 18, version 1.0, legacy support
ohci3 at pci0 dev 22 function 0 "ATI SB700 USB" rev 0x00: apic 4 int 18, version 1.0, legacy support
ehci2 at pci0 dev 22 function 2 "ATI SB700 USB2" rev 0x00: apic 4 int 17
usb2 at ehci2: USB revision 2.0
uhub2 at usb2 "ATI EHCI root hub" rev 2.00/1.00 addr 1
pchb1 at pci0 dev 24 function 0 "AMD AMD64 10h HyperTransport" rev 0x00
pchb2 at pci0 dev 24 function 1 "AMD AMD64 10h Address Map" rev 0x00
pchb3 at pci0 dev 24 function 2 "AMD AMD64 10h DRAM Cfg" rev 0x00
km0 at pci0 dev 24 function 3 "AMD AMD64 10h Misc Cfg" rev 0x00
pchb4 at pci0 dev 24 function 4 "AMD AMD64 10h Link Cfg" rev 0x00
usb3 at ohci0: USB revision 1.0
uhub3 at usb3 "ATI OHCI root hub" rev 1.00/1.00 addr 1
usb4 at ohci1: USB revision 1.0
uhub4 at usb4 "ATI OHCI root hub" rev 1.00/1.00 addr 1
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pms0: Synaptics touchpad, firmware 7.4
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
usb5 at ohci2: USB revision 1.0
uhub5 at usb5 "ATI OHCI root hub" rev 1.00/1.00 addr 1
usb6 at ohci3: USB revision 1.0
uhub6 at usb6 "ATI OHCI root hub" rev 1.00/1.00 addr 1
uvideo0 at uhub0 port 5 configuration 1 interface 0 "Foxlink HP Webcam [2 MP Fixed]" rev 2.00/1.06 addr 2
video0 at uvideo0
ugen0 at uhub4 port 4 "Broadcom Corp Broadcom 2070 Bluetooth" rev 2.00/4.81 addr 2
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
root on sd0a swap on sd0b dump on sd0b
drm: initializing kernel modesetting (RS880 0x1002:0x9712 0x103C:0x1475).
radeondrm0: VRAM: 256M 0x00000000C0000000 - 0x00000000CFFFFFFF (256M used)
radeondrm0: GTT: 512M 0x00000000A0000000 - 0x00000000BFFFFFFF
error: [drm:pid0:r600_init_microcode] *ERROR* r600_cp: Failed to load firmware "radeon-rs780_pfp"
error: [drm:pid0:r600_startup] *ERROR* Failed to load firmware!
error: [drm:pid0:r600_init] *ERROR* disabling GPU acceleration
error: [drm:pid0:radeon_bo_unpin] *ERROR* 0xffffff013f5c22e0 unpin not necessary
error: [drm:pid0:radeon_bo_unpin] *ERROR* 0xffffff013f5c22e0 unpin not necessary
radeondrm0: 1366x768
wsdisplay0 at radeondrm0 mux 1: console (std, vt100 emulation), using wskbd0
wsdisplay0: screen 1-5 added (std, vt100 emulation)
umass0 at uhub0 port 1 configuration 1 interface 0 " USB Flash Memory" rev 2.00/1.00 addr 3
umass0: using SCSI over Bulk-Only
scsibus4 at umass0: 2 targets, initiator 0
sd1 at scsibus4 targ 1 lun 0: <, USB Flash Memory, PMAP> SCSI0 0/direct removable serial.09306545EAB1751A0176
sd1: 7385MB, 512 bytes/sector, 15124992 sectors
my HP 625 seems to overheat more than when on OpenBSD 56-current

Code:
hw.sensors.acpitz0.temp0=62.00 degC (zone temperature)
hw.sensors.acpitz1.temp0=22.10 degC (zone temperature)
hw.sensors.km0.temp0=62.00 degC
Running cmixer outputs the same error message
Code:
Your screen is currently too small for this application.
Resize the screen and restart the application.
Press <CTRL+C> to exit...

Can't call method "attron" on an undefined value at /usr/local/libdata/perl5/site_perl/Curses/UI/Checkbox.pm line 216.
Bitrig still has xmix though
Reply With Quote
Reply

Tags
bitrig, bitrig.org

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenBSD OpenBSD forked to create Bitrig J65nko News 32 26th July 2012 07:38 AM
How - To install GNOME vile I install OpenBSD ? looop OpenBSD Installation and Upgrading 6 24th April 2010 08:58 PM


All times are GMT. The time now is 11:16 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick