DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 7th January 2018
ip6ix's Avatar
ip6ix ip6ix is offline
Port Guard
 
Join Date: Sep 2017
Location: UK
Posts: 20
Default Weird characters on OpenBSD console (update)

I've noticed several unexpected characters appear when using the console, and when using the man command, the â character (U+00E2) will appear, replacing the hyphen and certain quotation marks.

I'm sure it's a simple setting I've overlooked, but I couldn't find anything applicable in the FAQ or online search.

My locale is set to UTF-8 (LC_CTYPE=en_US.UTF-8), and $TERM is vt220, the default.

Here is an example:

Code:
LS(1)                       General Commands Manual                      LS(1)

NAME
     ls â list directory contents

SYNOPSIS
     ls [-1AaCcdFfgHhikLlmnopqRrSsTtux] [file ...]

DESCRIPTION
     For each operand that names a file of a type other than directory, ls
     displays its name as well as any requested, associated information.  For
     each named directory, ls displays the names of files contained within
     that directory, as well as any requested, associated information.

     If no operands are given, the contents of the current directory are
     displayed.  If more than one operand is given, non-directory operands are
     displayed first; directory and non-directory operands are sorted
     separately and in lexicographical order.  By default, ls lists one entry
     per line to standard output; the exceptions are to terminals or when the
     -C, -m, or -x options are specified.

     The options are as follows:

     -1      (The numeric digit “one”.) Force output to be one entry per line.
             This is the default when output is not to a terminal.

     -A      List all entries except for â.â and â..â.  Always set for the
             superuser.
As can be seen after the NAME line (hyphen replaced by â) and the -A option (single quotation marks replaced by â), this can become rather annoying when reading a lot of man pages, as I do.

This only appears on the console, not in X or when using ssh.

Thanks for any info.
__________________
echo '[q]sa[ln0=aln256%Pln256/snlbx]sb12247225403800449909543746snlbxq'|dc

Last edited by ip6ix; 9th January 2018 at 09:40 PM. Reason: More info.
Reply With Quote
  #2   (View Single Post)  
Old 9th January 2018
ip6ix's Avatar
ip6ix ip6ix is offline
Port Guard
 
Join Date: Sep 2017
Location: UK
Posts: 20
Default

Never mind. The mistake I made was to set my locale to en_US.UTF-8 in my shell start-up file instead of ~/.xinitrc. The console now uses the "C" locale and all is well.
__________________
echo '[q]sa[ln0=aln256%Pln256/snlbx]sb12247225403800449909543746snlbxq'|dc
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird freezing when downloading through ftp Martillo OpenBSD General 21 17th June 2013 04:40 PM
something weird nico_h FreeBSD Ports and Packages 3 15th January 2013 08:23 PM
Non US-ASCII characters on console under ksh or bash quique OpenBSD General 1 6th February 2010 03:36 AM
Weird time issues schrodinger OpenBSD General 7 26th October 2009 03:20 PM
Weird NAT issues EvanED FreeBSD General 3 11th July 2008 11:02 PM


All times are GMT. The time now is 07:38 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick