DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Security

OpenBSD Security Functionally paranoid!

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 23rd May 2017
Amithapr Amithapr is offline
Fdisk Soldier
 
Join Date: Dec 2015
Posts: 67
Question Problems with Applying a Patch

Hi,

I tried installing a patch given on OpenBSD errata pages. I used the command given on the errata page to apply the patch

cat <name of the patch>.patch | (cd /usr/src && patch -p0)

But it prompts for a filename by giving the information " File to patch: ". When I enter the file that needs to be patched on the errata page it prompts that " No file found--skip this patch?[n]" output.

Could you help me on this please?
Reply With Quote
  #2   (View Single Post)  
Old 23rd May 2017
cynwulf's Avatar
cynwulf cynwulf is offline
Package Pilot
 
Join Date: Mar 2014
Posts: 213
Default

Since 5.5-release, or so I believe, patches have been applied in conjunction with signify(1), so I assume you're trying to patch a very old release?

Without seeing the patch you're trying to apply or knowing the release involved, it's difficult to say.
Reply With Quote
  #3   (View Single Post)  
Old 23rd May 2017
Amithapr Amithapr is offline
Fdisk Soldier
 
Join Date: Dec 2015
Posts: 67
Default

Hi Cynwulf,

I'm using OpenBSD 5.3 and trying to apply the 014_openssl.patch patch

Thanks
Reply With Quote
  #4   (View Single Post)  
Old 23rd May 2017
cynwulf's Avatar
cynwulf cynwulf is offline
Package Pilot
 
Join Date: Mar 2014
Posts: 213
Default

Have you applied all the other patches up until now? Do the two files which that patch file relates to actually exist in your local source tree?

5.3-release supported ended in May 2014. You would be faced about 7 upgrades to get to the next supported release (6.0). It's better for you to make backups of user any modified files and clean install 6.1-release.
Reply With Quote
  #5   (View Single Post)  
Old 23rd May 2017
e1-531g e1-531g is offline
VPN Cryptographer
 
Join Date: Mar 2014
Posts: 366
Default

Can you show us what these commands print:
Code:
ls /usr/src
ls /usr/src/lib/libssl/src/ssl/
__________________
Signature: Furthermore, I consider that systemd must be destroyed.
Based on Latin oratorical phrase
Reply With Quote
  #6   (View Single Post)  
Old 24th May 2017
Amithapr Amithapr is offline
Fdisk Soldier
 
Join Date: Dec 2015
Posts: 67
Default

Hi cynwulf,

I haven't apply any patch until now. I have know idea whether my previous administrator applied any.


Hi e1-531g,

Please find the output of the two commands in the attached image.

Thanks
Attached Images
File Type: png SSLPatching.PNG (6.5 KB, 25 views)
Reply With Quote
  #7   (View Single Post)  
Old 24th May 2017
cynwulf's Avatar
cynwulf cynwulf is offline
Package Pilot
 
Join Date: Mar 2014
Posts: 213
Default

You don't have a source tree on that system. So you can't patch what isn't there.

You're not going to successfully flunk your way through administering this system using forums and google searching. Ultimately you will need to read the documentation/faqs - and you will need to install a supported release if you want a secure system: You will need to do the work.

But so far as I can tell, nothing has changed since September last year:

http://daemonforums.org/showthread.php?t=9942#post59635

Last edited by cynwulf; 24th May 2017 at 09:28 AM.
Reply With Quote
  #8   (View Single Post)  
Old 26th May 2017
Amithapr Amithapr is offline
Fdisk Soldier
 
Join Date: Dec 2015
Posts: 67
Default

Thanks
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
5.9 amd64 kernel panic after 004_mbuf.patch.sig patch shep OpenBSD General 0 2nd May 2016 04:34 PM
Patch 007 hitest OpenBSD Security 3 7th June 2014 05:17 PM
Patch question Mr-Biscuit Off-Topic 6 4th May 2010 07:47 PM
Patch for libXemu-1.0.3,1 mjj FreeBSD Installation and Upgrading 1 3rd January 2010 09:47 PM
problem applying patch sam-i-am OpenBSD General 4 25th July 2008 12:54 AM


All times are GMT. The time now is 07:17 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick