DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Packages and Ports

OpenBSD Packages and Ports Installation and upgrading of packages and ports on OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 1 Week Ago
philo_neo71 philo_neo71 is offline
Spam Deminer
 
Join Date: Jul 2009
Posts: 269
Default non root user xfce4 does not start

hello, i chose to install openBSD 6.5 with xfce4, in root mode xfce4 starts well.
when i use a non root user xfce4 does not start and returns me user rights errors.
how can i set the user rights so that xfce4 starts?
Reply With Quote
  #2   (View Single Post)  
Old 1 Week Ago
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 6,865
Default

You must either upgrade to the most recent release, or use xenodm(1). OpenBSD 6.5 does not permit non-root users to execute startx(1) or xinit(1).

This matter was discussed in the 6.5 Upgrade Guide:
Quote:
Xorg(1). The Xorg binary is no longer installed setuid, so startx(1) can no longer be used by non-root users. The xenodm(1) display manager has to be used instead.

To set it up:

# rcctl enable xenodm
# rcctl start xenodm

If you wish to customize X you need to create an executable .xsession file.
Reply With Quote
  #3   (View Single Post)  
Old 1 Week Ago
philo_neo71 philo_neo71 is offline
Spam Deminer
 
Join Date: Jul 2009
Posts: 269
Default

Customizing X for start xfce4 ?
what can i put in .xsession file for startxfce4 command ?
Reply With Quote
  #4   (View Single Post)  
Old 1 Week Ago
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 6,865
Default

The .xsession script file is similar to the .xinitrc script. Some admins use a linked filename, if these scripts happen to have the exact same contents.

From the xenodm(1) man page:
Quote:
Then xenodm runs the Xsession script as the user. This system session file may do some additional startup and typically runs the .xsession script in the user's home directory. When the Xsession script exits, the session is over.
Reply With Quote
  #5   (View Single Post)  
Old 1 Week Ago
shep shep is offline
Real Name: Scott
Arp Constable
 
Join Date: May 2008
Location: Dry and Dusty
Posts: 1,324
Default

From the xfce4 meta-package readme:

Code:
$OpenBSD: README-main,v 1.14 2019/08/15 07:16:48 landry Exp $

+-----------------------------------------------------------------------
| Running ${PKGSTEM} on OpenBSD
+-----------------------------------------------------------------------

The Xfce desktop is composed of 2 meta-packages:
    * xfce, for a base Xfce installation
    * xfce-extras, for a full Xfce installation.

Startup
=======
Xfce desktop environment is launched through the 'startxfce4' script.
Simply add '${LOCALBASE}/bin/startxfce4' to your .xinitrc/.xsession
script if you use startx, xenodm or slim.
If you use gdm or kdm, have a look at
https://wiki.xfce.org/faq#starting_xfce. An xfce4.desktop file is
provided for use by gdm.
Your ~/.xsession needs to be executable.

http://cvsweb.openbsd.org/cgi-bin/cv...ype=text/plain
Reply With Quote
  #6   (View Single Post)  
Old 1 Week Ago
johnR johnR is offline
Fdisk Soldier
 
Join Date: Nov 2017
Posts: 48
Default

Quote:
Originally Posted by shep View Post
Your ~/.xsession needs to be executable.
If the commands listed in ./xsession are executable, why does ./xsession itself need to be executable? IIUC it's just a configuration file.

Last edited by johnR; 1 Week Ago at 02:42 PM.
Reply With Quote
  #7   (View Single Post)  
Old 1 Week Ago
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 6,865
Default

It is an executed script if executable, or called in a separate shell if not.

$ tail -20 /etc/X11/xenodm/Xsession

Last edited by jggimi; 1 Week Ago at 05:09 PM. Reason: clarity, and not enough lines. -15 changed to -20
Reply With Quote
  #8   (View Single Post)  
Old 1 Week Ago
johnR johnR is offline
Fdisk Soldier
 
Join Date: Nov 2017
Posts: 48
Default

Quote:
Originally Posted by jggimi View Post
It is an executed script if executable, or called in a separate shell if not.
Thanks for the explanation.
Reply With Quote
  #9   (View Single Post)  
Old 1 Day Ago
hitest's Avatar
hitest hitest is offline
Real Name: George Nielsen
Spam Deminer
 
Join Date: Sep 2008
Location: B.C., Canada
Posts: 275
Default

Code:
bsd$ cat .xsession
exec ck-launch-session startxfce4
The above code works for me on XFCE4 and OpenBSD 6.6.

I edit /etc/group and add my regular user to the operator group so that I can use the XFCE4 shutdown button to turn off my laptop.
__________________
hitest
Reply With Quote
Old 22 Hours Ago
CiotBSD CiotBSD is offline
c107:b5d::
 
Join Date: Jun 2019
Location: Under /
Posts: 46
Default

You can just use into your personal .xsession:

Code:
startxfce4 --with-ck-launch
And, yes for the group operator; it's necessary!

__________________
GPG:Fingerprint ed25519 : **072A 4DA2 8AFD 868D 74CF 9EA2 B85E 9ADA C377 5E8E**
GPG:Fingerprint rsa4096 : **4E0D 4AF7 77F5 0FAE A35D 5B62 D0FF 7361 59BF 1733**
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HOWTO: mounting an USB device as normal non-root user in OpenBSD J65nko Guides 6 20th May 2017 12:03 PM
Cannot start X from a non-root account notooth NetBSD Security 4 2nd July 2015 02:31 PM
root: unknown user roddierod FreeBSD General 9 28th April 2009 10:18 PM
Run daemon as other user than root phreud FreeBSD General 8 11th November 2008 04:11 AM
Non-root user editing automatically mounted smb share tad1214 FreeBSD General 8 8th July 2008 02:28 AM


All times are GMT. The time now is 01:15 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick