Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Thread Tools Display Modes
  #1   (View Single Post)  
Old 22nd January 2010
quique quique is offline
New User
Join Date: Nov 2008
Posts: 5
Default Non US-ASCII characters on console under ksh or bash

I've installed OpenBSD 4.6. Keyboard is properly configured ("es" in /etc/kbdtype), and while running vim I can use the special characters of my language (áéíóúüñ¿¡) without any problem.

However, at the command line, these special characters are shown only under csh, but not under ksh or bash.

What should I do to persuade these shells to work with those characters?

Reply With Quote
  #2   (View Single Post)  
Old 6th February 2010
denta denta is offline
Shell Scout
Join Date: Nov 2009
Location: Sweden
Posts: 95

At the commandline, try
set +o emacs-usemeta
That setting enables me to use the "weird" swedish characters (ksh shell).

Last edited by denta; 6th February 2010 at 03:42 AM.
Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Good Bash/Scripting book? cwhitmore Programming 10 22nd December 2017 03:59 PM
Programming QL-500 (ASCII Code) PetitConcept FreeBSD General 1 29th June 2009 10:08 PM
Changing shell to bash rex FreeBSD General 13 29th August 2008 03:20 AM
Is bash included in OpenBSD? bsdnewbie999 OpenBSD General 21 2nd August 2008 02:57 AM
Can't use bash on chroot'd openssh environment jploh FreeBSD General 2 18th June 2008 02:12 AM

All times are GMT. The time now is 12:55 AM.

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick