DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Packages and Ports

OpenBSD Packages and Ports Installation and upgrading of packages and ports on OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 30th July 2020
victorvas's Avatar
victorvas victorvas is offline
Real Name: Victor
Fdisk Soldier
 
Join Date: May 2019
Posts: 77
Default Message-Id in Neomutt

hi I set up Neomutt with msmtp to send mail and isync to receive mail. I have to use msmtp and isync (mbsync) because they support PGP-encrypted password file.
Recently I needed to send email to a person, who's using one big email provider. I never sent emails to that provider before. That provider immediately start to reject my mail and mark it as spam. I contacted their technical support and they replied that my Message-Id was different from my email address hostname, and their anti-spam system automatically marked my email as spam. Further looking into that problem I've found that my message id when the mail sent from neomutt is <ffgas-fzs4h-guigf-uytfed@my-own-pc-hostname>, but when the mail is sent from Thunderbird, it's <ffgas-fzs4h-guigf-uytfed@my-mail-provider-hostname>.
Neomutt for some reason put the name of my own PC at the end of Message-Id, while Thunderbird put the proper name of my email provider. How do I fix that?
Reply With Quote
  #2   (View Single Post)  
Old 30th July 2020
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 7,093
Default

Set the hostname field in your .muttrc file.
Reply With Quote
  #3   (View Single Post)  
Old 7th August 2020
victorvas's Avatar
victorvas victorvas is offline
Real Name: Victor
Fdisk Soldier
 
Join Date: May 2019
Posts: 77
Default

That worked, thanks!
Another question is how to set Content-Language?
Code:
Content-Type: text/plain; charset=utf-8; format=flowed
Content-Language: en-US
Content-Transfer-Encoding: 8bit
I'm writing message in German, Content-Language is en-US and it delivers the message without any problems, but how do I make it set Content-Language: de-DE only when I send emails in German?
Reply With Quote
  #4   (View Single Post)  
Old 7th August 2020
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 7,093
Default

I don't have an answer. The neomuttrc man page (https://neomutt.org/man/neomuttrc) describes setting "preferred_languages" and that is not what you are asking. To reach the neomutt developers, see the "I need help" section on the main page of the website.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
5.7 message I keep seeing bceverly OpenBSD Installation and Upgrading 18 2nd May 2015 04:29 PM
shutdown message derf FreeBSD General 5 14th December 2010 04:57 PM
(ttyv0) message. delboy FreeBSD Security 10 29th May 2008 08:25 PM
Message alerts? ocicat Feedback and Suggestions 2 2nd May 2008 03:25 PM


All times are GMT. The time now is 09:20 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick