DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Installation and Upgrading

OpenBSD Installation and Upgrading Installing and upgrading OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 3 Days Ago
psypro psypro is offline
Shell Scout
 
Join Date: Mar 2016
Location: Continent:Europe
Posts: 125
Default 6.8 error "entry point at 0x1001000"

boot failed with error "entry point at 0x1001000"

bsd.rd works fine.
6.7 worked fine.

N3450 CPU notebook.
Reply With Quote
  #2   (View Single Post)  
Old 2 Days Ago
andinus's Avatar
andinus andinus is offline
Real Name: Andinus
Not new user
 
Join Date: Mar 2020
Posts: 2
Default

I wrote about it here: https://andinus.nand.sh/writings/202...t-failure.html

Related links:
- https://marc.info/?l=openbsd-misc&m=159147446008114&w=2
- https://marc.info/?l=openbsd-misc&m=160305239128360&w=2

AFAIK the fix is to either install OpenBSD in legacy mode (non-UEFI) or use older boot-loader. I tried replacing the boot-loader but that didn't work (most likely I made some mistake), so I installed in legacy mode.

If you haven't upgraded on target machine yet then you can manually upgrade it: https://www.openbsd.org/faq/upgrade68.html - just skip the boot-loader part.
Reply With Quote
  #3   (View Single Post)  
Old 1 Day Ago
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 7,107
Default

There's an uncommitted patch in snapshots for testing, per theo@. ref: https://marc.info/?l=openbsd-misc&m=160390222432642&w=2
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
userdel "must be a local user" error gustaf OpenBSD General 5 16th May 2020 02:59 AM
Difference between"arp info overwritten" and " duplicate IP address " varag OpenBSD Security 1 6th April 2015 02:57 PM
5.4 amd64 on Thinkpad x200: "render error detected" on booting. karl OpenBSD Installation and Upgrading 2 5th November 2013 04:28 AM
"Can't check filesystem" error after installation sepuku OpenBSD Installation and Upgrading 6 22nd July 2011 10:25 AM
Fixed "xinit" after _7 _8, "how" here in case anyones' "X" breaks... using "nvidia" jb_daefo Guides 0 5th October 2009 09:31 PM


All times are GMT. The time now is 10:24 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick