DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Packages and Ports

OpenBSD Packages and Ports Installation and upgrading of packages and ports on OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 21st August 2019
philo_neo71 philo_neo71 is offline
Spam Deminer
 
Join Date: Jul 2009
Posts: 267
Default can't resolve packages

hi,
I'm working with OpenBSD 6.5 / AMD64 with Xfce4 desktop.
for some time I have errors on the structure of my file system, I do not understand, every time I want to add a program with the command pkg_add I have errors >> can not resolve.
here are some examples of my output:

Code:
sta-raptor# pkg_add pcmanfm 
quirks-3.124 signed on 2019-04-15T12:10:16Z
Error: /dev/sd0d on /usr is not large enough (/usr/local/include/libfm-1.0/fm-extra.h)
Error: /dev/sd0d on /usr is not large enough (/usr/local/include/libfm-1.0/fm-version.h)
Error: /dev/sd0d on /usr is not large enough (/usr/local/include/libfm-1.0/fm-xml-file.h)
Error: ... more files do not fit on /dev/sd0d on /usr
/dev/sd0a on /: 215 bytes
/dev/sd0d on /usr: 82446 bytes (missing 18946 blocks)
/dev/sd0a on /: 215 bytes
/dev/sd0d on /usr: 82446 bytes (missing 18946 blocks)
Can't install menu-cache-1.1.0p0: can't resolve libfm-extra-1.3.1
Can't install libfm-1.3.1: can't resolve libfm-extra-1.3.1,menu-cache-1.1.0p0
Can't install pcmanfm-1.3.1: can't resolve libfm-1.3.1
Couldn't install libfm-1.3.1 libfm-extra-1.3.1 menu-cache-1.1.0p0 pcmanfm-1.3.1
sta-raptor#
Code:
sta-raptor# pkg_add -iv dolphin   
Update candidates: quirks-3.124 -> quirks-3.124
quirks-3.124 signed on 2019-04-15T12:10:16Z
Error: /dev/sd0d on /usr is not large enough (/usr/local/include/hidapi/hidapi.h)
Error: /dev/sd0d on /usr is not large enough (/usr/local/lib/libhidapi-libusb.a)
Error: /dev/sd0d on /usr is not large enough (/usr/local/lib/libhidapi-libusb.la)
Error: ... more files do not fit on /dev/sd0d on /usr
/dev/sd0a on /: 470 bytes
/dev/sd0d on /usr: 141913 bytes (missing 19062 blocks)
/dev/sd0a on /: 529 bytes
/dev/sd0d on /usr: 3265885 bytes (missing 25163 blocks)
Can't install llvm-7.0.1p9: can't resolve gtest-1.8.0p3
/dev/sd0a on /: 16321 bytes
/dev/sd0d on /usr: 11964871 bytes (missing 42153 blocks)
/dev/sd0a on /: 858 bytes
/dev/sd0d on /usr: 1731877 bytes (missing 22167 blocks)
Can't install geoclue-0.12.99p7: can't resolve gpsd-2.95p10
/dev/sd0a on /: 483 bytes
/dev/sd0d on /usr: 1156833 bytes (missing 21044 blocks)
/dev/sd0a on /: 1489 bytes
/dev/sd0d on /usr: 2338157 bytes (missing 23351 blocks)
Can't install qtbase-5.9.7p3: can't resolve geoclue-0.12.99p7,iodbc-3.52.12p0,libxkbcommon-0.8.4
/dev/sd0a on /: 532 bytes
/dev/sd0d on /usr: 337564 bytes (missing 19444 blocks)
/dev/sd0a on /: 16321 bytes
/dev/sd0d on /usr: 11964871 bytes (missing 42153 blocks)
/dev/sd0a on /: 470 bytes
/dev/sd0d on /usr: 141913 bytes (missing 19062 blocks)
Can't install llvm-7.0.1p9: can't resolve gtest-1.8.0p3
/dev/sd0a on /: 532 bytes
/dev/sd0d on /usr: 337564 bytes (missing 19444 blocks)
/dev/sd0a on /: 19448 bytes
/dev/sd0d on /usr: 1455831 bytes (missing 21628 blocks)
Can't install sfml-2.4.0p1: can't resolve openal-1.19.1v0
/dev/sd0a on /: 334 bytes
/dev/sd0d on /usr: 225899 bytes (missing 19226 blocks)
/dev/sd0a on /: 1189 bytes
/dev/sd0d on /usr: 4601973 bytes (missing 27773 blocks)
Can't install dolphin-nogui-5.0.0.20180901p2: can't resolve miniupnpc-2.1,libhidapi-0.8.0pre20160128p0,pulseaudio-12.2p1,mbedtls-2.16.1,pugixml-1.9,sfml-2.4.0p1,llvm-7.0.1p9
Can't install dolphin-5.0.0.20180901p2: can't resolve libhidapi-0.8.0pre20160128p0,miniupnpc-2.1,pulseaudio-12.2p1,dolphin-nogui-5.0.0.20180901p2,mbedtls-2.16.1,pugixml-1.9,qtbase-5.9.7p3,sfml-2.4.0p1,llvm-7.0.1p9
Couldn't install dolphin-5.0.0.20180901p2 dolphin-nogui-5.0.0.20180901p2 geoclue-0.12.99p7 gpsd-2.95p10 gtest-1.8.0p3 iodbc-3.52.12p0 libhidapi-0.8.0pre20160128p0 libxkbcommon-0.8.4 llvm-7.0.1p9 mbedtls-2.16.1 miniupnpc-2.1 openal-1.19.1v0 pugixml-1.9 pulseaudio-12.2p1 qtbase-5.9.7p3 sfml-2.4.0p1
sta-raptor#
I deleted the directories of / usr / games because / usr was saturated!

do I have to redo my system ?


Regards
Philo
Reply With Quote
  #2   (View Single Post)  
Old 21st August 2019
ip6ix's Avatar
ip6ix ip6ix is offline
Real Name: Neil
Port Guard
 
Join Date: Sep 2017
Location: Wales, UK
Posts: 44
Default

What's the output of the df(1) command?
__________________
dc -e '[q]sa[ln0=aln256%Pln256/snlbx]sb12247225403800449909543746snlbxq'
Reply With Quote
  #3   (View Single Post)  
Old 21st August 2019
PapaParrot's Avatar
PapaParrot PapaParrot is offline
parrot
 
Join Date: Jul 2015
Location: Durango, Mx.
Posts: 415
Default

The output of 'df -h ' will confirm , or show, but it looks like you have used up all the space available in /usr

Quote:
do I have to redo my system ?
You might be able to do some resizing of other partitions, and increase the /usr size, We need to see 'df -h' out put to determine if that is possible.
__________________
My best friends are parrots
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't install ...... : can't resolve ...... Monti OpenBSD Packages and Ports 11 19th April 2015 01:24 AM
I have 18 GB rpm packages mfaridi Programming 5 15th April 2010 09:41 PM
my pf won't allow my server to resolve revzalot OpenBSD Security 21 12th September 2009 10:39 AM
pkg_add - can't resolve <packagename> nihonto OpenBSD Packages and Ports 11 28th January 2009 10:03 PM


All times are GMT. The time now is 08:04 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick