DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Packages and Ports

OpenBSD Packages and Ports Installation and upgrading of packages and ports on OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 18th June 2019
brudan brudan is offline
Fdisk Soldier
 
Join Date: Dec 2018
Posts: 82
Default xfe 1.44 (prerelease) fails with "symbol foo size mismatch, relink your program"

I'm trying to compile pre-release xfe version 1.44 available here:
http://roland65.free.fr/xfe-1.44.tar.gz

All these steps complete successfully:
Code:
$ doas pkg_add intltool gmake fox
$ cd xfe-1.44
$ CPPFLAGS="-I/usr/local/include -I/usr/local/include/fox-1.6 -I/usr/X11R6/include -I/usr/X11R6/include/freetype2" LDFLAGS="-L/usr/local/lib -L/usr/X11R6/lib -lXft -pthread" ./configure
$ gmake
$ doas gmake install
But then when I try to run xfe, I get this unpleasant surprise:
Code:
$ xfe
xfe:/usr/lib/libstdc++.so.57.0: /usr/lib/libc++abi.so.0.1 : WARNING: symbol(_ZTVN10__cxxabiv120__si_class_type_infoE) size mismatch, relink your program
xfe:/usr/lib/libstdc++.so.57.0: /usr/lib/libc++abi.so.0.1 : WARNING: symbol(_ZTVN10__cxxabiv120__function_type_infoE) size mismatch, relink your program
xfe:/usr/lib/libstdc++.so.57.0: /usr/lib/libc++abi.so.0.1 : WARNING: symbol(_ZTVSt9type_info) size mismatch, relink your program
xfe:/usr/lib/libstdc++.so.57.0: /usr/lib/libc++abi.so.0.1 : WARNING: symbol(_ZTVN10__cxxabiv117__class_type_infoE) size mismatch, relink your program
xfe:/usr/lib/libstdc++.so.57.0: /usr/lib/libc++abi.so.0.1 : WARNING: symbol(_ZTVN10__cxxabiv123__fundamental_type_infoE) size mismatch, relink your program
xfe:/usr/lib/libstdc++.so.57.0: /usr/lib/libc++abi.so.0.1 : WARNING: symbol(_ZTVN10__cxxabiv119__pointer_type_infoE) size mismatch, relink your program
xfe:/usr/lib/libstdc++.so.57.0: /usr/lib/libc++abi.so.0.1 : WARNING: symbol(_ZTVN10__cxxabiv129__pointer_to_member_type_infoE) size mismatch, relink your program
xfe:/usr/lib/libstdc++.so.57.0: /usr/lib/libc++abi.so.0.1 : WARNING: symbol(_ZTVN10__cxxabiv116__enum_type_infoE) size mismatch, relink your program
xfe:/usr/lib/libstdc++.so.57.0: /usr/lib/libc++abi.so.0.1 : WARNING: symbol(_ZTVN10__cxxabiv121__vmi_class_type_infoE) size mismatch, relink your program
xfe:/usr/lib/libstdc++.so.57.0: /usr/lib/libc++abi.so.0.1 : WARNING: symbol(_ZTVN10__cxxabiv117__pbase_type_infoE) size mismatch, relink your program
xfe:/usr/lib/libstdc++.so.57.0: /usr/lib/libc++abi.so.0.1 : WARNING: symbol(_ZTVN10__cxxabiv117__array_type_infoE) size mismatch, relink your program
Segmentation fault
/usr/lib/libc++abi.so.0.1 exists on my system and you'd think the compiler would use the available version and not some other version.

What am I doing wrong?

Last edited by brudan; 18th June 2019 at 06:05 PM. Reason: clarity
Reply With Quote
  #2   (View Single Post)  
Old 18th June 2019
ibara's Avatar
ibara ibara is offline
Real-life IT professor
 
Join Date: Jan 2014
Posts: 717
Default

Code:
$ gmake CXX=c++
GNU make defaults to CXX=g++ (aka the in-base gcc-4.2.1), whose libstdc++ library conflicts with LLVM's libc++abi library.

Perhaps worth a change in the gmake port, perhaps not.

Last edited by ibara; 18th June 2019 at 03:11 PM. Reason: Correct GNU make default variables.
Reply With Quote
  #3   (View Single Post)  
Old 18th June 2019
brudan brudan is offline
Fdisk Soldier
 
Join Date: Dec 2018
Posts: 82
Default

Thank you very much, ibara. That did the trick.
Reply With Quote
Reply

Tags
configure, gmake, make, solved, xfe

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Failed to load module "qxl" (module requirement mismatch) KenJackson NetBSD Installation and Upgrading 3 10th January 2017 09:18 AM
pidgin message .. size mismatch, relink your program daemonfowl OpenBSD Packages and Ports 1 23rd August 2012 12:32 AM
jQuip: "90% of jQuery, 13% of the size" J65nko News 3 22nd November 2011 05:09 PM
Fixed "xinit" after _7 _8, "how" here in case anyones' "X" breaks... using "nvidia" jb_daefo Guides 0 5th October 2009 09:31 PM
Scripted sysinstall fails with "Command 'system' failed" PeterSteele FreeBSD Installation and Upgrading 0 13th November 2008 11:31 PM


All times are GMT. The time now is 02:23 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick