DaemonForums  

Go Back   DaemonForums > NetBSD > NetBSD Package System (pkgsrc)

NetBSD Package System (pkgsrc) Installation and upgrading of packages on NetBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 5th January 2019
KenJackson KenJackson is offline
Real Name: Ken Jackson
Multi-OS Guy
 
Join Date: Oct 2008
Posts: 7
Default Package 'dri', required by 'virtual:world', not found

Running NetBSD 8.0, I'm trying to install modular-xorg-apps. A binary pkg isn't available, so I did this:
Code:
cd /usr/pkgsrc/meta-pkgs/modular-xorg-apps
sudo make bin-install
It fails trying to build dependency modular-xorg-xephyr looking for dependency dri. I can't find it with pkgin nor in pkgsrc.
Code:
...
checking for SHA1 implementation... libc
checking for XSERVERCFLAGS... no
configure: error: Package requirements (fixesproto >= 5.0 damageproto >= 1.1 xcmiscproto >= 1.2.0 xtrans >= 1.3.5 bigreqsproto >= 1.1.0 xproto >= 7.0.31 randrproto >= 1.5.0 renderproto >= 0.11 xextproto >= 7.2.99.901 inputproto >= 2.3 kbproto >= 1.0.3 fontsproto >= 2.1.3 pixman-1 >= 0.27.2 videoproto compositeproto >= 0.4 recordproto >= 1.13.99.1 scrnsaverproto >= 1.1 resourceproto >= 1.2.0 xf86driproto >= 2.1.0 glproto >= 1.4.17 dri >= 7.8.0 presentproto >= 1.0 xineramaproto xkbfile  pixman-1 >= 0.27.2 xfont2 >= 2.0.0 xau xshmfence >= 1.1 xdmcp) were not met:

Package 'dri', required by 'virtual:world', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables XSERVERCFLAGS_CFLAGS
and XSERVERCFLAGS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
*** Error code 1

Stop.
make[4]: stopped in /usr/pkgsrc/x11/modular-xorg-xephyr
*** Error code 1

Stop.
make[3]: stopped in /usr/pkgsrc/x11/modular-xorg-xephyr
*** Error code 1

Stop.
make[2]: stopped in /usr/pkgsrc/x11/modular-xorg-xephyr
*** Error code 1

Stop.
make[1]: stopped in /usr/pkgsrc/meta-pkgs/modular-xorg-apps
*** Error code 1

Stop.
make: stopped in /usr/pkgsrc/meta-pkgs/modular-xorg-apps
When try to install modular-xorg-xephyr directly, it fails with,
"configure: error: threaded input requested but no pthread support has been found".
Different error. Odd. I can't find any pthread to install either.

How do I install dri and pthread?
Reply With Quote
  #2   (View Single Post)  
Old 3rd February 2019
Sensucht94's Avatar
Sensucht94 Sensucht94 is offline
Real Name: Paolo Vincenzo Olivo
Fdisk Soldier
 
Join Date: Oct 2017
Location: Rome
Posts: 49
Default

Hadn't noticed that thread, so here's a month late reply, probably useless, but possibly worth something:

If you're going to use modular Xorg, then you'll need to tell pkgsrc to use /usr/pkg/*instead of /usr/X11R7/* as PREFIX, which will set /usr/pkg/lib as LD_LIBRARY_PATH, etc....for all packages requiring X11 shared objects and headers. This can be accomplished by appending:

Code:
X11_TYPE=modular
to your /etc/mk.conf. If you hadn't done this in the first place, before compiling everytthing else, then this would account for all the unmet X11 runtime requirements mentioned in the error log you posted above

If you set X11_TYPE=modular right now, you'll likely have to recompile most packages either way, so it would be advisable to delete all packages and start over.

Quote:
Originally Posted by KenJackson
It fails trying to build dependency modular-xorg-xephyr looking for dependency dri. I can't find it with pkgin nor in pkgsrc.
[Mesa 3D] DRI is provided by graphics/MesaLib18 compiled with 'dri' build option

Hope this helps
__________________
Be the change you want to see in the World
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Block device required when mounting a floppy yetoo OpenBSD General 27 25th July 2018 05:40 PM
installing hpijs package: library jpeg.63.0 not found wimwauters OpenBSD Packages and Ports 11 23rd June 2010 11:30 PM
Netstart / Required Reboots on Interface Changes dylanz OpenBSD General 0 17th June 2010 05:48 PM
Dos batch file administrator privileges required a6zj6 Other OS 1 12th June 2009 02:02 PM
Required packages for running X enpey FreeBSD Ports and Packages 7 20th August 2008 09:16 AM


All times are GMT. The time now is 07:12 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick