DaemonForums  

Go Back   DaemonForums > NetBSD > NetBSD General

NetBSD General Other questions regarding NetBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 6th October 2015
philo_neo71 philo_neo71 is offline
Package Pilot
 
Join Date: Jul 2009
Posts: 183
Default how to find /dev/device and mount it

Hi,
I search how to find a device like usb key or usb hard drive and other partition on the same hardrive where NetBSD are installed ?
how to mount (/dev/device) that a says above ?

Regards
Philippe
Reply With Quote
  #2   (View Single Post)  
Old 6th October 2015
pygope pygope is offline
Port Guard
 
Join Date: Apr 2015
Posts: 32
Default

Hard disk drives usually are wd+number, wd0 is your first hard drive, wd1 your second and so on. Review your dmesg.
To see partitions in a hard drive:
sudo disklabel wd0 (or whatever hard drive you want)

For usb removable devices review your dmesg after insterting it. Usually should be sd0. To review the partitions, again:
sudo disklabel sd0

More information in http://netbsd.org/docs/guide/en/chap-rmmedia.html and
Reply With Quote
  #3   (View Single Post)  
Old 6th October 2015
philo_neo71 philo_neo71 is offline
Package Pilot
 
Join Date: Jul 2009
Posts: 183
Default

Hi,

I try to mount local hard drive !

the output of dmesg :
Code:
umass0 at uhub4 port 4 configuration 1 interface 0
umass0: JMicron USB to ATA/ATAPI bridge, rev 2.00/1.00, addr 3
umass0: using SCSI over Bulk-Only
scsibus0 at umass0: 2 targets, 1 lun per target
sd0 at scsibus0 target 0 lun 0: <Hitachi, HTS545032B9A300, PB3O> disk fixed
sd0: 298 GB, 16383 cyl, 16 head, 63 sec, 512 bytes/sect x 625142448 sectors
1/ for Usb hard drive, this is the output :
Code:
sta-antares# mount -t ntfs /dev/sd0 /media
mount_ntfs: Warning: realpath /dev/sd0: No such file or directory
mount_ntfs: /dev/sd0 on /media: No such file or directory
sta-antares#
1/ for ata hard drive, this is the output after Fdisk command :
Code:
sta-antares# fdisk
fdisk: removing corrupt bootsel information
Disk: /dev/rwd0d
NetBSD disklabel disk geometry:
cylinders: 310101, heads: 16, sectors/track: 63 (1008 sectors/cylinder)
total sectors: 312581808

BIOS disk geometry:
cylinders: 1023, heads: 255, sectors/track: 63 (16065 sectors/cylinder)
total sectors: 312581808

Partitions aligned to 2048 sector boundaries, offset 63

Partition table:
0: NetBSD (sysid 169)
    start 63, size 107780033 (52627 MB, Cyls 0-6709/0/11), Active
1: Linux native (sysid 131)
    start 107780096, size 197070848 (96226 MB, Cyls 6709/0/12-18976/23/55)
        PBR is not bootable: All bytes are identical (0x00)
2: Linux swap or Prime or Solaris (sysid 130)
    start 304850944, size 7729152 (3774 MB, Cyls 18976/23/56-19457/53/52)
        PBR is not bootable: All bytes are identical (0x00)
3: <UNUSED>
First active partition: 0
Drive serial number: 3341696156 (0xc72e3c9c)
sta-antares#
2.1/ i try to mount /dev/wd1, this is the output :
Code:
sta-antares# mount -t ext4 /dev/wd1 /mnt
mount: mount_ext4 not found for /mnt
sta-antares#
Regards
Philippe
Reply With Quote
  #4   (View Single Post)  
Old 6th October 2015
pygope pygope is offline
Port Guard
 
Join Date: Apr 2015
Posts: 32
Default

1) You cannot mount sd0, You can mount sd0a, sd0b and so on. Try sudo disklabel /dev/sd0 and choose your partititon accordingly.

2) NetBSD does not support ext4, sorry.
Reply With Quote
  #5   (View Single Post)  
Old 10th October 2015
philo_neo71 philo_neo71 is offline
Package Pilot
 
Join Date: Jul 2009
Posts: 183
Default

Posts or theads SOLVED
Reply With Quote
  #6   (View Single Post)  
Old 31st December 2016
philo_neo71 philo_neo71 is offline
Package Pilot
 
Join Date: Jul 2009
Posts: 183
Default

i forgot what can i do, 7 years ago

mount -t ntfs /dev/sd0a /media/
issue !
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
gmake can't find tcl/tk LeFrettchen OpenBSD General 5 19th August 2012 05:35 PM
Unable to find device node for /dev/mfid0s1b bforest FreeBSD Installation and Upgrading 4 30th September 2011 04:02 PM
K3b cannot find growisofs maxrussell FreeBSD General 5 26th April 2009 12:20 PM
identifying device associated with USB device? spiderpig OpenBSD General 2 7th July 2008 05:18 AM
where might I find 'libcamel'? Damien787 FreeBSD Ports and Packages 16 17th June 2008 11:35 PM


All times are GMT. The time now is 01:08 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick