DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Packages and Ports

OpenBSD Packages and Ports Installation and upgrading of packages and ports on OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 31st March 2017
yezster yezster is offline
New User
 
Join Date: Jan 2014
Posts: 8
Default pkg_add doesn't seemed to work after updating to latest snapshot.

Greetings all,

After updating to latest snapshot moments ago, I started noticing that my pkg_add doesn't seem to work.


my installurl file contains:

http://mirror.rise.ph/pub/OpenBSD



After trying to install a package like this.

$ doas pkg_add -v putty
http://mirror.rise.ph/pub/OpenBSD/6.1/packages/amd64/: no such dir
Can't find putty


I noticed the "6.1" in the branch, but I'm using snapshot I don't know why my OpenBSD system kept appending 6.1 instead of "snapshots". Now I'm stuck I don't know how to work around this.

Any tips from the big bros, sorry for such a lame question, I'm really noob at this.

Thanks in advance.
Reply With Quote
  #2   (View Single Post)  
Old 31st March 2017
TronDD TronDD is offline
Package Pilot
 
Join Date: Sep 2014
Posts: 155
Default

This is a caveat of running snapshots. Because development happens in one branch, once the project is preparing for the release, the version number is bumped and the tools are put into their release configuration. Once the new version is released, it is put back to the rolling snapshots configuration for development.

Use PKG_PATH, and set the full snaapshot path of your mirror as a workaround.

And if this isn't you on misc@, more information:
http://marc.info/?l=openbsd-misc&m=149094814632370&w=2

Last edited by TronDD; 31st March 2017 at 01:53 PM.
Reply With Quote
  #3   (View Single Post)  
Old 31st March 2017
jggimi's Avatar
jggimi jggimi is online now
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 5,972
Default

Or use # pkg_add -uD snap, which has been discussed just today on both the misc@ and ports@ mailing lists.
Reply With Quote
  #4   (View Single Post)  
Old 31st March 2017
yezster yezster is offline
New User
 
Join Date: Jan 2014
Posts: 8
Default

I think this worked as a work around.

# pkg_add -D snap <package name>

Thanks much.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
TEW-649UB usb wifi adapter doesn't work jakeswen OpenBSD General 4 26th July 2016 08:30 PM
Xen 3.3 Winxp Domu doesn't work AgustinSainato NetBSD Package System (pkgsrc) 3 12th May 2016 11:22 PM
Help: NAT doesn't work on OpenBSD 4.9 lcxpics OpenBSD General 1 18th May 2011 09:46 AM
ln -f at boot doesn't work lordyan OpenBSD General 3 19th February 2009 03:50 PM
fluxbox-generate_menu doesn't work nihonto NetBSD General 1 25th January 2009 06:46 PM


All times are GMT. The time now is 11:07 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick