DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Packages and Ports

OpenBSD Packages and Ports Installation and upgrading of packages and ports on OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 2nd May 2017
mktitsworth mktitsworth is offline
New User
 
Join Date: May 2017
Posts: 2
Default Gnome3 on OpenBSD 6.1

Yay! It's time for another "Gnome and/or GDM are being whack on OpenBSD" thread (because the world needs one every few months). On previous episodes we have this and this and several others which have obsolete instructions, exemplified by using "dbus_daemon" rather than "messagebus."

For background, I have a fresh OpenBSD 6.1 install and have run

Code:
# pkg_add gnome gnome-extras
Followed by

Code:
# rcctl disable xdm
# rcctl enable multicast messagebus avahi_daemon gdm
# reboot
from /usr/local/share/doc/pkg-readmes/gnome-3.22.2p0. Upon boot, this gives me a black screen with an X for the mouse pointer that flickers once and does nothing - I can only login by CTL+ALT+F2. I sourced this problem back to being from loading GDM. After removing gdm from the pkg_scripts, I am able to login, and running gdm from the commandline yields the same effect. After looking at this thread I went ahead and added
Code:
machdep.allowaperature=2
to rc.conf.local, to no avail. I've also gone through the mailinglist which report the exact same error, with no resolution. My fstab looks like

Code:
b6f3e77f641d275a.b none swap sw
b6f3e77f641d275a.a / ffs rw 1 1
b6f3e77f641d275a.k /home ffs rw,nodev,nosuid 1 2
b6f3e77f641d275a.d /tmp ffs rw,nodev,nosuid 1 2
b6f3e77f641d275a.f /usr ffs rw,nodev 1 2
b6f3e77f641d275a.g /usr/X11R6 ffs rw,nodev 1 2
b6f3e77f641d275a.h /usr/local ffs rw,wxallowed,nodev 1 2
b6f3e77f641d275a.j /usr/obj ffs rw,nodev,nosuid 1 2
b6f3e77f641d275a.i /usr/src ffs rw,nodev,nosuid 1 2
b6f3e77f641d275a.e /var ffs rw,nodev,nosuid 1 2
and I have confirmed that I own drm0

Code:
$ ls -l /dev/drm*
crw-------  1 matthew  matthew   87,   0 May  1 15:35 /dev/drm0
crw-------  1 root     wheel     87,   1 May  1 15:35 /dev/drm1
crw-------  1 root     wheel     87,   2 May  1 15:35 /dev/drm2
crw-------  1 root     wheel     87,   3 May  1 15:35 /dev/drm3
As to the current state of things, my rc.conf.local file looks like
Code:
multicast=YES
machdep.allowaperature=2
pkg_scripts=messagebus avahi_daemon
My path is
Code:
$ echo $PATH
/home/matthew/bin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/X11R6/bin:/usr/local/bin:/usr/local/sbin:/usr/games:.
I've attached copies of my dmesg, Xorg.0.log, \:0.log (from gdm), and \:0-greeter.log (also from gdm). The only error I can find in there is in the \:0-greeter.log which says

Code:
(gnome-settings-daemon:34354): GLib-GIO-CRITICAL **: g_task_return_error: assertion 'error != NULL' failed
Gdk-Message: gnome-settings-daemon: Fatal IO error 35 (Resource temporarily unavailable) on X server :0.
but I have no idea what this means.

Thanks.
Attached Files
File Type: tgz gdm.tgz (8.6 KB, 19 views)
Reply With Quote
  #2   (View Single Post)  
Old 2nd May 2017
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 5,887
Default

Hello, and welcome!

I'm going to guess that there is an error in documentation -- specifically, the pkg-readme is likely to be out-of-date. That is because in 6.1, xdm(1) was replaced with xenodm(1). So the command # rcctl disable xdm should have been # rcctl disable xenodm.

Let us know if that solves the problem.

Last edited by jggimi; 2nd May 2017 at 09:36 PM. Reason: added a welcome. This was mktitsworth's first post
Reply With Quote
  #3   (View Single Post)  
Old 2nd May 2017
mktitsworth mktitsworth is offline
New User
 
Join Date: May 2017
Posts: 2
Default

Thanks! I've lurked forever but apparently my search skills have failed me this time.

Speaking of, unfortunately # rcctl disable xenodm did not fix the problem. This had no effect on logs/rc.conf.local or output, so there is nothing new to post for that.

To permute things, I also tried removing machdep.allowaperture=2 from rc.conf.local. I cross referenced this change with a warning in X0rg.0.log which says "Check that you have set 'machdep.allowaperture=1' in /etc/sysctl.conf and reboot your machine." This was probably there to begin with, but I went ahead and created a /etc/sysctl.conf file with the line machdep.allowaperture=1 and rebooted. This didn't fix the problem, but it did remove the warning from X0rg.0.log. I also tried iterating through allowaperature=2 and 3, as per xf86(4).
Reply With Quote
  #4   (View Single Post)  
Old 24th July 2017
plavcik plavcik is offline
New User
 
Join Date: Jul 2017
Posts: 1
Default

yes, machdep.allowaperture=2 belongs to /etc/sysctl.conf not /etc/rc.conf.local

there is sometimes typo in the variable in posts above, but as the warning disappeared, I assume you typed it right

this URL may be helpful: https://www.x.org/archive/X11R7.5/do...s/OpenBSD.html

Last edited by plavcik; 24th July 2017 at 08:10 PM.
Reply With Quote
  #5   (View Single Post)  
Old 25th July 2017
cynwulf's Avatar
cynwulf cynwulf is offline
Package Pilot
 
Join Date: Mar 2014
Posts: 204
Default

If intel or radeon DRM/KMS drivers are in use the machdep.allowaperture sysctl becomes irrelevant.
Reply With Quote
Reply

Tags
gnome, gnome-session, openbsd 6.1

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble getting Gnome3 to work Itproman OpenBSD Packages and Ports 5 20th January 2016 12:10 AM
Gnome3's and AMD64 / INTEL philo_neo71 OpenBSD Installation and Upgrading 0 13th November 2014 10:22 AM


All times are GMT. The time now is 03:58 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick