DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 4 Weeks Ago
brudan brudan is offline
Port Guard
 
Join Date: Dec 2018
Posts: 29
Default how to make volume louder than 100%?

I run OpenBSD 6.4 (amd64) on my personal laptop. I have the MATE desktop environment installed, which unfortunately pulls in the pulseaudio-12.2 package.

I have maxed out both things I know of...
Code:
$ mixerctl outputs.master=255,255
$ pactl set-sink-volume 0 100%
...but volume is still too low to be comfortable. With mixerctl(1) 255,255 is the maximum setting for outputs.master (trying to set a higher level results in 255,255 being set). With pactl(1) I can set-sink-volume above 100%, but the output does not actually sound louder than 100%. (This is particularly perplexing, as set-sink-volume >100% *does* make things louder when using MATE in GNU/Linux. Obviously I don't understand how sound works in OpenBSD at a low level.)

Is there a way to use pactl(1) and force a setting >100% to work? If not, is there something else I can increase in order to make the volume louder than the supposed maximum? The output of mixerctl and pactl list is here.

Last edited by brudan; 4 Weeks Ago at 04:19 PM. Reason: made thread title more specific
Reply With Quote
  #2   (View Single Post)  
Old 4 Weeks Ago
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 6,455
Default

I'd go through every one of the mixer settings that appear to have a 0-255 range, and set them to 255 and see if that makes any difference. Why? The Multimedia FAQ states, "The controls of an audio device may be labeled differently." I've seen outputs labelled as inputs, so I'd set each of these to 255, and see if there are any differences in output volume:

inputs.dac-0
inputs.dac-2
record.adc-2
record-adc-0
inputs.mic
inputs.mic2
record.volume
Reply With Quote
  #3   (View Single Post)  
Old 4 Weeks Ago
brudan brudan is offline
Port Guard
 
Join Date: Dec 2018
Posts: 29
Default

Thank you, jggimi. I did as you suggested and maxed out everything:

Code:
bruno@thinkpad:~446$ mixerctl
inputs.dac-0:1=222,222
inputs.dac-2:3=222,222
inputs.beep=85
record.adc-2:3_source=mic2
record.adc-2:3=240,240
record.adc-0:1_source=mic
record.adc-0:1=240,240
outputs.hp_source=dac-0:1
outputs.hp_boost=on
inputs.mic=252,252
outputs.mic_dir=input-vr80
outputs.spkr_source=dac-2:3
outputs.spkr_eapd=on
inputs.mic2=252,252
outputs.hp_sense=unplugged
outputs.mic_sense=unplugged
outputs.master=255,255
outputs.master.mute=off
outputs.master.slaves=dac-0:1,dac-2:3
record.volume=255,255
record.volume.mute=off
record.volume.slaves=adc-2:3,adc-0:1
record.enable=sysctl
(The settings that are 85, 222, 240 or 252 will not go any higher.)

I also ran this:

Code:
bruno@thinkpad:~448$ gsettings list-recursively | grep volume
org.mate.peripherals-keyboard click-volume 0
org.mate.SettingsDaemon.plugins.media-keys volume-up 'XF86AudioRaiseVolume'
org.mate.SettingsDaemon.plugins.media-keys volume-mute 'XF86AudioMute'
org.mate.SettingsDaemon.plugins.media-keys volume-step 6
org.mate.SettingsDaemon.plugins.media-keys volume-down 'XF86AudioLowerVolume'
org.gnome.desktop.sound allow-volume-above-100-percent false
org.mate.engrampa.dialogs.batch-add volume-size 0
org.mate.caja.desktop volumes-visible true

bruno@thinkpad:~449$ gsettings set org.gnome.desktop.sound allow-volume-above-100-percent true
Alas even after all the above, the sound is no louder than before.
Reply With Quote
  #4   (View Single Post)  
Old 4 Weeks Ago
Head_on_a_Stick's Avatar
Head_on_a_Stick Head_on_a_Stick is offline
Real Name: Matthew
Bloaty McBloatFace
 
Join Date: Dec 2015
Location: London
Posts: 115
Default

Is the sound still quiet if you start one of the window managers from the base system without PulseAudio?

Perhaps post (or link) the dmesg output as well.

If you have a DAC, try the debugging tips:

https://www.openbsd.org/faq/faq13.html#audioprob
__________________
Linux is for people who hate Windows. BSD is for people who love UNIX.
Reply With Quote
  #5   (View Single Post)  
Old 4 Weeks Ago
brudan brudan is offline
Port Guard
 
Join Date: Dec 2018
Posts: 29
Default

Thanks, Matthew.

If I kill pulseaudio, it makes no difference in the volume (BTW, pulseaudio respawns itself. The only way for it to stay dead is to do chmod a-x /usr/local/bin/pulseaudio before trying to kill it. I love MATE but gosh I could really do without pulseaudio).

My laptop is an old T400 ThinkPad without any bells or whistles. I found this in my dmesg, so I guess I have an Intel DAC?

Code:
azalia0 at pci0 dev 27 function 0 "Intel 82801I HD Audio" rev 0x03
The complete dmesg is here.

Your signature is great, by the way. Best way to put it.

P.S. I can hear stuff. Music is soft but listenable. It's just when trying to listen to a lecture via mpv(1) or youtube (e.g., https://www.youtube.com/watch?v=OXS8ljif9b8 ) that I have to strain my ear in order to understand everything. I had the same problem with this T400 laptop back when I was using GNU/Linux, which I could solve by increasing the volume to around 150% or 160% via pactl(1). Maybe a similar volume boost is just not possible in OpenBSD?

Last edited by brudan; 4 Weeks Ago at 07:07 PM.
Reply With Quote
  #6   (View Single Post)  
Old 4 Weeks Ago
jak3b jak3b is offline
New User
 
Join Date: Nov 2017
Posts: 5
Default

I had the same problem. I use cwm but that didnt matter. I do use headphones, I have no speakers.What DID work for me was setting outputs.master=255,255 and outsputs.hp_boost=on.This made it loud enough. mpv and mplayer have some settings that go over %100 to.
Reply With Quote
  #7   (View Single Post)  
Old 4 Weeks Ago
Head_on_a_Stick's Avatar
Head_on_a_Stick Head_on_a_Stick is offline
Real Name: Matthew
Bloaty McBloatFace
 
Join Date: Dec 2015
Location: London
Posts: 115
Default

Quote:
Originally Posted by brudan View Post
I had the same problem with this T400 laptop back when I was using GNU/Linux, which I could solve by increasing the volume to around 150% or 160% via pactl(1). Maybe a similar volume boost is just not possible in OpenBSD?
Perhaps not, but I really don't know for sure.

So the maximum, un-boosted volume level is the same in both OpenBSD and GNU/Linux?

You seem to already have outputs.hp_boost turned on but maybe this is interfering with PA — try disabling hp_boost and then set the volume to 150% with `pactl`.

(My signature is one of the adages from Plan9's fortune(1), I can claim no credit there )
__________________
Linux is for people who hate Windows. BSD is for people who love UNIX.
Reply With Quote
  #8   (View Single Post)  
Old 4 Weeks Ago
brudan brudan is offline
Port Guard
 
Join Date: Dec 2018
Posts: 29
Default

@Matthew: outputs.hp_boost was off before today. I turned it on to see if it would help. On or off, it makes no difference when I use pactl to set volume over 100%.

@jak3b: Thanks for the tip. I use mpv(1) and found that it only goes up to 130% by default (use keys 9 and 0 to adjust playback volume), but user can set a different maximum volume with the --volume-max flag. Also, I discovered that I can play youtube videos in mpg by giving the url as the argument, for example:

Code:
$ mpv --volume-max=200 https://www.youtube.com/watch?v=OXS8ljif9b8
Using applications rather than pactl(1) to (actually) increase volume beyond 100% is an acceptable workaround. Thank you all.

Last edited by brudan; 4 Weeks Ago at 08:00 PM.
Reply With Quote
  #9   (View Single Post)  
Old 2 Weeks Ago
Funkygoby Funkygoby is offline
Port Guard
 
Join Date: Aug 2015
Posts: 45
Default

Hello,
I have few suggestions.

Can you try headphones or earbuds? I am wondering if a bad connection to the loudspeaker could explain your problem. Like only having the phase attached but the neutral being disconnected.
Having the same problem with Linux is strange.
I once found a clip stuck (due to the magnet) to the loudspeaker membrane of my thinkpad. The sound was terrible until I removed the clip.
Thinkpads should have no problem under OpenBSD (I am using a X200).

Regarding pulseaudio, I use Xfce (that installs pulseaudio too). I removed it from the autostart services of Xfce.
Now PA is still installed but never used.
You might want to see if you can configure which services Mate launch at startup (there should a GUI tool for that), and disable pusleaudio.
Reply With Quote
Old 1 Week Ago
brudan brudan is offline
Port Guard
 
Join Date: Dec 2018
Posts: 29
Default

Thanks, Funkygoby, and sorry for the delayed response.

I never considered disabling PA because I thought MATE required it. I disabled it via MATE's GUI (System -> Preferences -> Personal -> Startup Applications -> uncheck PulsAudio Sound System) and MATE seems not to care. Alas, it makes no difference with the loudness. Nevertheless, I'm thankful for your suggestion because from now on PA is disabled--it seems superfluous on OpenBSD, so it's a dispensable complication.

No bad contacts: Since this laptop was new, sound has always been soft. Setting outputs.master=255,255 then going over 100% in mpv makes it so that I can hear well enough.

Thank you all for your help.
Reply With Quote
Reply

Tags
volume amplify

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
/usr/local volume full hrsetrdr OpenBSD General 14 2nd January 2019 11:26 PM
Volume Control (in Java) mattthumper Programming 1 6th August 2015 03:23 PM
Volume Control Graphical Utility mattthumper OpenBSD Packages and Ports 21 31st July 2015 01:05 AM
MS DOS volume labels? bigearsbilly FreeBSD General 2 1st April 2009 10:50 PM
mplayer volume cannot increase. bsdnewbie999 OpenBSD General 3 19th June 2008 03:16 PM


All times are GMT. The time now is 04:01 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick