DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Packages and Ports

OpenBSD Packages and Ports Installation and upgrading of packages and ports on OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 2nd June 2015
EverydayDiesel EverydayDiesel is offline
Shell Scout
 
Join Date: Jan 2009
Posts: 124
Default Weird PKG_ADD error

Hello,

I am not having any luck installing SMB server on my machine. Can someone please tell me what I am doing wrong? The machine is OpenBSD 5.7 on
amd64 hardware/installation

FAQ tells me that I should check the versions which I believe to be the same.

FAQ: http://www.openbsd.org/faq/faq15.html#PkgFAQ

Installed from here: http://mirror.esc7.net/pub/OpenBSD/5.../install57.iso

Trying to install samba from here:
http://mirror.esc7.net/pub/OpenBSD/5...-3.6.15p14.tgz

Here is a screenshot of the errors

Thanks in advance

Last edited by EverydayDiesel; 2nd June 2015 at 09:17 PM.
Reply With Quote
  #2   (View Single Post)  
Old 2nd June 2015
shep shep is offline
Real Name: Scott
Arp Constable
 
Join Date: May 2008
Location: Dry and Dusty
Posts: 1,389
Default

"library X11.16.0 not found"

It looks like you need the xorg file sets. Although OpenBSD will run without Xorg, many packages are dependent on the xorg libraries.
Reply With Quote
  #3   (View Single Post)  
Old 3rd June 2015
ibara ibara is offline
QEX author
 
Join Date: Jan 2014
Posts: 777
Default

Generally speaking, you should install the X sets these days even if you don't think you will use them directly.
This is why.
Reply With Quote
  #4   (View Single Post)  
Old 3rd June 2015
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 7,416
Default

You do not need to re-install. The X sets can be added after-the-fact. See FAQ 4.11
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
something weird nico_h FreeBSD Ports and Packages 3 15th January 2013 08:23 PM
netstart equivalent .. pkg_add error daemonfowl NetBSD General 15 17th February 2012 05:48 AM
pkg_add error ustar archive header player1 OpenBSD Installation and Upgrading 4 31st May 2011 03:41 PM
Weird NAT issues EvanED FreeBSD General 3 11th July 2008 11:02 PM
pkg_add error buba OpenBSD Packages and Ports 4 13th June 2008 03:29 PM


All times are GMT. The time now is 08:08 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick