DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 27th September 2016
roggy roggy is offline
Port Guard
 
Join Date: Nov 2013
Posts: 41
Default Problem with LACP

Hi,

I have a lab with HP switch JG924A and OpenBSD 6 configured with LACP.

- hostname.em1
up

- hostname.em2
up

- hostname.trunk0
trunkproto lacp trunkport em1 trunkport em2 up

root@server~# ifconfig trunk
trunk0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
lladdr 84:44:64:9b:58:a1
index 10 priority 0 llprio 3
trunk: trunkproto lacp
trunk id: [(8000,84:44:64:9b:58:a1,4054,0000,0000),
(FFFF,00:00:00:00:00:00,0000,0000,0000)]
trunkport em2 active,collecting,distributing
trunkport em1 active,collecting,distributing
groups: trunk
media: Ethernet autoselect
status: active

When removing the cable from an interface status changes to

root@server~# ifconfig trunk
trunk0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
lladdr 84:44:64:9b:58:a1
index 10 priority 0 llprio 3
trunk: trunkproto lacp
trunk id: [(8000,84:44:64:9b:58:a1,4054,0000,0000),
(FFFF,00:00:00:00:00:00,0000,0000,0000)]
trunkport em2 active,collecting,distributing
trunkport em1
groups: trunk
media: Ethernet autoselect
status: active

When I connect the cable again not return to active interface

root@server~# ifconfig trunk
trunk0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
lladdr 84:44:64:9b:58:a1
index 10 priority 0 llprio 3
trunk: trunkproto lacp
trunk id: [(8000,84:44:64:9b:58:a1,4054,0000,0000),
(FFFF,00:00:00:00:00:00,0000,0000,0000)]
trunkport em2 active,collecting,distributing
trunkport em1 collecting,distributing
groups: trunk
media: Ethernet autoselect
status: active

The two interfaces are returned to active restart with sh /etc/netstart trunk0

root@server~# ifconfig trunk
trunk0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
lladdr 84:44:64:9b:58:a1
index 10 priority 0 llprio 3
trunk: trunkproto lacp
trunk id: [(8000,84:44:64:9b:58:a1,4054,0000,0000),
(FFFF,00:00:00:00:00:00,0000,0000,0000)]
trunkport em2 active,collecting,distributing
trunkport em1 active,collecting,distributing
groups: trunk
media: Ethernet autoselect
status: active

Does anyone know what is missing to go up automatically?
Thanks!!
Reply With Quote
  #2   (View Single Post)  
Old 27th September 2016
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 6,347
Default

LACP recovery should be automatic, so this may be reported to the project.

Meanwhile, you could deploy ifstated(8) for a scripted solution.
Reply With Quote
  #3   (View Single Post)  
Old 27th September 2016
roggy roggy is offline
Port Guard
 
Join Date: Nov 2013
Posts: 41
Default

I am with this problem since version 5.8. I do not know the previous.
Reply With Quote
  #4   (View Single Post)  
Old 27th September 2016
roggy roggy is offline
Port Guard
 
Join Date: Nov 2013
Posts: 41
Default

jggimi,

I reported to reik@openbsd.org, which is the trunk driver developer.
Let's see what he says.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Boot problem. Geometry problem? gulanito FreeBSD Installation and Upgrading 0 3rd July 2009 03:03 AM


All times are GMT. The time now is 02:00 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick