DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Installation and Upgrading

OpenBSD Installation and Upgrading Installing and upgrading OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 17th October 2017
Trihex's Avatar
Trihex Trihex is offline
Real Name: Trihexagonal
Port Guard
 
Join Date: Jul 2017
Location: Over the hills and far away
Posts: 40
Default Problem after upgrade from OpenBSD 6.1 to 6.2

I normally do a fresh build with each release but decided to upgrade from OpenBSD 6.1 to OpenBSD 6.2 this time.

The upgrade process went smoothly but when I booted to the desktop xfe failed to start like it should from .xinitrc and gave this error:

Code:
$ xfe
xfe:/usr/lib/libstdc++.so.57.0: /usr/lib/libc++abi.so.0.0 : WARNING: symbol(_ZTVN10__cxxabiv121__vmi_class_type_infoE) size mismatch, relink your program
xfe:/usr/lib/libstdc++.so.57.0: /usr/lib/libc++abi.so.0.0 : WARNING: symbol(_ZTVN10__cxxabiv120__si_class_type_infoE) size mismatch, relink your program
xfe:/usr/lib/libstdc++.so.57.0: /usr/lib/libc++abi.so.0.0 : WARNING: symbol(_ZTVN10__cxxabiv117__class_type_infoE) size mismatch, relink your program
xfe:/usr/lib/libstdc++.so.57.0: /usr/lib/libc++abi.so.0.0 : WARNING: symbol(_ZTVN10__cxxabiv119__pointer_type_infoE) size mismatch, relink your program
xfe:/usr/lib/libstdc++.so.57.0: /usr/lib/libc++abi.so.0.0 : WARNING: symbol(_ZTVN10__cxxabiv123__fundamental_type_infoE) size mismatch, relink your program
xfe:/usr/lib/libstdc++.so.57.0: /usr/lib/libc++abi.so.0.0 : WARNING: symbol(_ZTVN10__cxxabiv129__pointer_to_member_type_infoE) size mismatch, relink your program
xfe:/usr/lib/libstdc++.so.57.0: /usr/lib/libc++abi.so.0.0 : WARNING: symbol(_ZTVSt9type_info) size mismatch, relink your program
xfe:/usr/lib/libstdc++.so.57.0: /usr/lib/libc++abi.so.0.0 : WARNING: symbol(_ZTVN10__cxxabiv117__pbase_type_infoE) size mismatch, relink your program
xfe:/usr/lib/libstdc++.so.57.0: /usr/lib/libc++abi.so.0.0 : WARNING: symbol(_ZTVN10__cxxabiv117__array_type_infoE) size mismatch, relink your program
xfe:/usr/lib/libstdc++.so.57.0: /usr/lib/libc++abi.so.0.0 : WARNING: symbol(_ZTVN10__cxxabiv116__enum_type_infoE) size mismatch, relink your program
xfe:/usr/lib/libstdc++.so.57.0: /usr/lib/libc++abi.so.0.0 : WARNING: symbol(_ZTVN10__cxxabiv120__function_type_infoE) size mismatch, relink your program
xfe:/usr/local/lib/libFOX-1.6.so.2.1: /usr/lib/libc++abi.so.0.0 : WARNING: symbol(_ZTVN10__cxxabiv120__si_class_type_infoE) size mismatch, relink your program
xfe:/usr/local/lib/libFOX-1.6.so.2.1: /usr/lib/libc++abi.so.0.0 : WARNING: symbol(_ZTVN10__cxxabiv117__class_type_infoE) size mismatch, relink your program
xfe:xfe: /usr/lib/libc++abi.so.0.0 : WARNING: symbol(_ZTVN10__cxxabiv120__si_class_type_infoE) size mismatch, relink your program
xfe:xfe: /usr/lib/libc++abi.so.0.0 : WARNING: symbol(_ZTVN10__cxxabiv117__class_type_infoE) size mismatch, relink your program
xfe:/usr/lib/libc++.so.1.0: undefined symbol 'newlocale'
ld.so: xfe: lazy binding failed!
Killed
I went ahead and did a fresh build of OpenBSD 6.2 but thought it worth mentioning due to the nature of the error.

Code:
$ uname -a                        
OpenBSD tengu 6.2 GENERIC.MP#0 amd64
Other than an error in screenfetch regarding memory that did not occur with OpenBSD 6.1 everything else seems to be going well:

Code:
$ screenfetch
/usr/local/bin/screenfetch: line 1424: 6527M: value too great for base (error token is "6527M")
Reply With Quote
  #2   (View Single Post)  
Old 17th October 2017
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 6,238
Default

1. What do you mean by your term, "fresh build"?

2. Did you update your installed packages after upgrading to 6.2?
Reply With Quote
  #3   (View Single Post)  
Old 17th October 2017
Oko's Avatar
Oko Oko is offline
Rc.conf Instructor
 
Join Date: May 2008
Location: Kosovo, Serbia
Posts: 1,102
Default

Looks like you are trying to run 6.1 packages on 6.2 kernel.

sysmerge was not needed almost surely this time after the upgrade. But have you done

pkg_add -u

Make sure that your /etc/installurl is not empty and has something like

https://openbsd.cs.toronto.edu/pub/OpenBSD

before running the command. You could also run pkg_delete -a after the upgrade to remove stale libraries.
I have upgraded all of mine 15 machines running OpenBSD to 6.2 two of which (my desktop and my laptop) run in GUI mode. I have not seeing anything crazy yet. As a matter of fact

WARNING: symbol(icudt58_dat) size mismatch, relink your program

https://marc.info/?l=openbsd-misc&m=149271724912565&w=2

has being fixed (it was affecting many programs not just slappasswd which I cared about.

Last edited by Oko; 17th October 2017 at 03:58 AM.
Reply With Quote
  #4   (View Single Post)  
Old 17th October 2017
Trihex's Avatar
Trihex Trihex is offline
Real Name: Trihexagonal
Port Guard
 
Join Date: Jul 2017
Location: Over the hills and far away
Posts: 40
Default

Quote:
Originally Posted by Oko View Post
Looks like you are trying to run 6.1 packages on 6.2 kernel.

sysmerge was not needed almost surely this time after the upgrade. But have you done

pkg_add -u
Thanks.

You are correct, I hadn't ran pkg_add -u and was that the problem.

Quote:
Originally Posted by jggimi View Post
1. What do you mean by your term, "fresh build"?

2. Did you update your installed packages after upgrading to 6.2?
By "fresh build" I mean rebuild the system from scratch, which is what I've always done before. I was at fault for not updating the programs with the upgrade.
Reply With Quote
  #5   (View Single Post)  
Old 17th October 2017
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 6,238
Default

Quote:
Originally Posted by Trihex View Post
... I mean rebuild the system from scratch.
Building -release from the -release source tree will produce an operationally identical set of binary modules to the published binary -release.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Opera problem (FreeBSD] after v10 upgrade jb_daefo FreeBSD Ports and Packages 16 27th April 2015 01:50 AM
Upgrade from Openbsd 4.6 to Opbsd 4.7 Ultiny OpenBSD Installation and Upgrading 4 21st May 2010 11:07 PM
Big5 Character Set in Apache problem after upgrade to 6.4 paul-lkw FreeBSD Installation and Upgrading 0 23rd February 2009 09:20 AM
Problem during kernel-build for a 6.x-to-7 upgrade clevershark FreeBSD Installation and Upgrading 2 1st February 2009 10:45 PM
problem(s) after opera upgrade jb_daefo FreeBSD Ports and Packages 4 28th August 2008 11:58 AM


All times are GMT. The time now is 06:38 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick