DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 2nd July 2008
ltwally ltwally is offline
New User
 
Join Date: Jul 2008
Posts: 5
Thanked 0 Times in 0 Posts
Default KDM over VNC

I am trying to get KDM working over VNC for the first time. The system is running FreeBSD 6.3.

I know that KDE has a built-in VNC server, but I cannot find an option to enable it for KDM.

I have also tried TightVNC. I am able to use TightVNC to start a KDE session, but have thus far been unable to make KDM work with it.


Any help would be appreciated!

Thanks
Reply With Quote
  #2   (View Single Post)  
Old 3rd July 2008
davidgurvich davidgurvich is offline
Fdisk Soldier
 
Join Date: May 2008
Location: NYC
Posts: 57
Thanked 3 Times in 3 Posts
Default

You need to configure vnc to start using inetd and allow kdm to respond to xdmcp requests. Should not need anything else.
Reply With Quote
  #3   (View Single Post)  
Old 3rd July 2008
ltwally ltwally is offline
New User
 
Join Date: Jul 2008
Posts: 5
Thanked 0 Times in 0 Posts
Default

I have tried that basic methodology. The only result was that KDM was no longer visible at its own monitor.

Do you have (or know of) an actual guide to doing this?

Thanks
Reply With Quote
  #4   (View Single Post)  
Old 3rd July 2008
davidgurvich davidgurvich is offline
Fdisk Soldier
 
Join Date: May 2008
Location: NYC
Posts: 57
Thanked 3 Times in 3 Posts
Default

What steps have you followed? You should still have local login.
Reply With Quote
  #5   (View Single Post)  
Old 3rd July 2008
ltwally ltwally is offline
New User
 
Join Date: Jul 2008
Posts: 5
Thanked 0 Times in 0 Posts
Default

Just like we had said, above. Config inetd to start vncserver. kdmrc set to xdmcp, with the default port 177.

At first, I left the vncserver's xstartup file as stock. When that didn't work, I tried replacing startx with startkde, kdm, and xdm. Nothing worked.

But, as previously mentioned, I did manage to rob my local screen of the KDM login. That was just lovely. After I restored all the files back to their original state - from backup copies, no less - my KDM login screen is different. It's quite a bit less attractive now. I guess whatever theme/skin it had been using somehow got changed. Ain't that skippy. And I KNOW that I didn't mess with any theming. *sigh*

So... Unless someone has an actual, tested and verified method... I guess I'll just stick to having the vncserver autostart with a root user. It's good enough for administration purposes.
Reply With Quote
  #6   (View Single Post)  
Old 3rd July 2008
davidgurvich davidgurvich is offline
Fdisk Soldier
 
Join Date: May 2008
Location: NYC
Posts: 57
Thanked 3 Times in 3 Posts
Default

The most recent vnc server configuration I've done has been on opensolaris. That required the following step, translated to FreeBSD
Quote:
echo 'vnc\t5900/tcp\t\t#VNC server' >>/etc/services
echo 'vnc stream tcp nowait nobody /usr/local/bin/Xvnc' >> /etc/inetd.conf
/etc/rc.d/inetd restart
That should prepare the system to use vnc, test with vncviewer on either 'localhost' or 'localhost:0' or 'localhost:1' (I don't recall which). Then configuring /etc/X11/gdm/custom.conf. I think on FreeBSD with kdm, you need to enable XDMCP in '/usr/local/share/config/kdm/Xaccess', but I can't tell what needs to be changed or added.

Sorry if this is what you have already done. I don't believe any other files need to be configured, just restart inetd and restart kdm.
Reply With Quote
  #7   (View Single Post)  
Old 3rd July 2008
ltwally ltwally is offline
New User
 
Join Date: Jul 2008
Posts: 5
Thanked 0 Times in 0 Posts
Default

Yeah. That's what I'd already done. It hosed things up.

And, I'm still uncertain about is the xstartup script. I would assume that "startx" is not the correct way to launch KDM... but I have yet to stumble across what is the correct way.

I might play with it some more over the weekend... but I really hate wasting this much time just fumbling in the dark.
Reply With Quote
  #8   (View Single Post)  
Old 3rd July 2008
davidgurvich davidgurvich is offline
Fdisk Soldier
 
Join Date: May 2008
Location: NYC
Posts: 57
Thanked 3 Times in 3 Posts
Default

You can't have a kdm session without editing /etc/ttys.
Reply With Quote
  #9   (View Single Post)  
Old 3rd July 2008
ltwally ltwally is offline
New User
 
Join Date: Jul 2008
Posts: 5
Thanked 0 Times in 0 Posts
Default

What do I need to edit in /etc/ttys?
Reply With Quote
Old 4th July 2008
davidgurvich davidgurvich is offline
Fdisk Soldier
 
Join Date: May 2008
Location: NYC
Posts: 57
Thanked 3 Times in 3 Posts
Default

From the handbook
Quote:
To enable kdm, the ttyv8 entry in /etc/ttys has to be adapted. The line should look as follows:
ttyv8 "/usr/local/bin/kdm -nodaemon" xterm on secure
Reply With Quote
Reply

Tags
kdm, vnc

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:34 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick