DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 19th July 2008
ronaldmcdonald9 ronaldmcdonald9 is offline
New User
 
Join Date: Jul 2008
Posts: 6
Thanked 0 Times in 0 Posts
Smile Solution: FreeBSD 7 and Sigmatel 9274D codec

Hi. I have an Intel D975XBX2 motherboard and I have installed FreeBSD 7 on my computer. This motherboard comes with the Sigmatel 9274D codec and the sound was not working at first. I loaded the snd_hda module with
Code:
kldload snd_hda
and the sound worked! I then added
Code:
snd_hda_load="YES"
to my /boot/loader.conf file so that this module is loaded at boot time.

This sound codec is not listed as supported in the snd_hda man pages and when I load the module I get
Code:
pcm0: <HDA Codec: Sigmatel (Unknown)>
when I run dmesg, so it doesn't look like it is totally recognized. However, at least the sound output works. I am posting this for the sake of anyone who has the same problem.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Any Solution for Xorg high CPU usage in Ubuntu 9.04? Mantazz Other BSD and UNIX/UNIX-like 11 14th July 2009 06:10 AM
Which is the best solution from start bsd.mp? aleunix OpenBSD General 18 4th May 2009 06:33 PM
consider OpenVPN production-grade solution? nimnod Off-Topic 1 26th March 2009 12:22 AM


All times are GMT. The time now is 07:55 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick