DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 7th July 2008
blancolado blancolado is offline
New User
 
Join Date: Jul 2008
Posts: 3
Thanked 0 Times in 0 Posts
Default portsdb -Uu failes at ismail, BUG w/ fix

Environment:
FreeBSD VANHALEN.EDDIE 6.3-STABLE FreeBSD 6.3-STABLE #1: Wed Jul 2 14:19:02 UTC 2008
Also repeated problem on multpile freebsd 5.4 and 6.2 servers. Th

Description:
portsdb fails after cvsup.

Here is the error message I received before fixing the Makefile:

portsdb -Uu
Updating the ports index ... Generating INDEX.tmp - please wait.."/usr/ports/chinese/links/../../www/links/Makefile", line 75: warning: duplicate script for target "pre-configure" ignored
"Makefile", line 32: Could not find bsd.port.options.mk
make: fatal errors encountered -- cannot continue
===> www/ismail failed
*** Error code 1
1 error

************************************************** ******************
Before reporting this error, verify that you are running a supported
version of FreeBSD (see http://www.FreeBSD.org/ports/) and that you
have a complete and up-to-date ports collection. (INDEX builds are
not supported with partial or out-of-date ports collections -- in
particular, if you are using cvsup, you must cvsup the "ports-all"
collection, and have no "refuse" files.) If that is the case, then
report the failure to ports@FreeBSD.org together with relevant
details of your ports configuration (including FreeBSD version,
your architecture, your environment, and your /etc/make.conf
settings, especially compiler flags and WITH/WITHOUT settings).

Note: the latest pre-generated version of INDEX may be fetched
automatically with "make fetchindex".
************************************************** ******************

*** Error code 1

Stop in /usr/ports.
*** Error code 1

Stop in /usr/ports.
failed to generate INDEX!
portsdb: index generation error

How-To-Repeat:
1. Run cvsup and update to latest ports tree (as of: 07/07/08 11:00pmCST)
2. Update portsdb with portsdb -Uu

Fix:
To fix the problem I had to modify /usr/ports/www/ismail/Makefile to
include the full path on the makefile includes. Possibly the make files
have been moved? Why would this makefile cause portsdb to fail when the ismail port is not even installed?

Is anyone else experiencing this issue? I have seen this on 4 or 5 computers ranging from freebsd 4.5 to 6.3. All where working fine until a cvsup on the latest version. No changes, no refuse files, no mergemaster, just used cvsup and then ran portsdb -Uu.
Reply With Quote
  #2   (View Single Post)  
Old 8th July 2008
cuongvt cuongvt is offline
New User
 
Join Date: May 2008
Posts: 7
Thanked 0 Times in 0 Posts
Default

I have same problem, but with multimedia/gstreamer.
And there is nothing under multimedia/gstreamer, no Make file, nothing.
I'm stuck!!!
Blancolado and all, could you tell me how to fix this?
Please help me.
I need your help
Below is output of portupgrade when facing prob.
-----------------------------------------------------
Building new INDEX files... done.
Ports tree is already up to date.
localhost# portsdb -Uu
Updating the ports index ... Generating INDEX.tmp - please wait.."Makefile", line 20: Could not find /usr/ports/chinese/xmms/../../multimedia/xmms/Makefile
make: fatal errors encountered -- cannot continue
===> chinese/xmms failed
*** Error code 1
1 error

************************************************** ******************
Before reporting this error, verify that you are running a supported
version of FreeBSD (see http://www.FreeBSD.org/ports/) and that you
have a complete and up-to-date ports collection. (INDEX builds are
not supported with partial or out-of-date ports collections -- in
particular, if you are using cvsup, you must cvsup the "ports-all"
collection, and have no "refuse" files.) If that is the case, then
report the failure to ports@FreeBSD.org together with relevant
details of your ports configuration (including FreeBSD version,
your architecture, your environment, and your /etc/make.conf
settings, especially compiler flags and WITH/WITHOUT settings).

Note: the latest pre-generated version of INDEX may be fetched
automatically with "make fetchindex".
************************************************** ******************

*** Error code 1

Stop in /usr/ports.
*** Error code 1

Stop in /usr/ports.
failed to generate INDEX!
portsdb: index generation error
Reply With Quote
  #3   (View Single Post)  
Old 8th July 2008
blancolado blancolado is offline
New User
 
Join Date: Jul 2008
Posts: 3
Thanked 0 Times in 0 Posts
Default

1. What version are you using (uname -a)?
2. Have you ran cvsup lately? what do you exclude?
3. When did the error occur? Where you making any major changes at that time?

It looks like its an error in the file /usr/ports/chinese/xmms/Makefile. Try fixing the error on line 20, its having trouble finding the make file that is being included, possibly the file has moved. you could also possibly comment out/delete that line if your not using the port, its worth a shot.

Honestly, I don't understand why portsdb -Uu creates errors for ports that are not installed?

Last edited by blancolado; 8th July 2008 at 07:55 PM.
Reply With Quote
  #4   (View Single Post)  
Old 9th July 2008
cuongvt cuongvt is offline
New User
 
Join Date: May 2008
Posts: 7
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by blancolado View Post
1. What version are you using (uname -a)?
2. Have you ran cvsup lately? what do you exclude?
3. When did the error occur? Where you making any major changes at that time?

It looks like its an error in the file /usr/ports/chinese/xmms/Makefile. Try fixing the error on line 20, its having trouble finding the make file that is being included, possibly the file has moved. you could also possibly comment out/delete that line if your not using the port, its worth a shot.

Honestly, I don't understand why portsdb -Uu creates errors for ports that are not installed?
1. Freebsd 7.0 latest
2. I ran portsnap extract update right before I posted this article to this forum. I excluded nothing.
3. No.
4. I will try based on ur advice and reply tonight.
Reply With Quote
  #5   (View Single Post)  
Old 21st July 2008
blancolado blancolado is offline
New User
 
Join Date: Jul 2008
Posts: 3
Thanked 0 Times in 0 Posts
Default

Did you track down the problem?

So far the easy fix for freebsd 5 and 6 is to create a sim link. (/usr/share/mk/bsd.port.options.mk -> /usr/ports/Mk/bsd.port.options.mk).

So if you wanna keep running freebsd 5.4 or 6.2, just use this command:
ln -s /usr/ports/Mk/bsd.port.options.mk /usr/share/mk/bsd.port.options.mk


Response from Ion-Mihai Tetcu [itetcu@FreeBSD.org]:
Quote:
Because of the way out make works (include time and order of various
*.mk) it needs to have bsd.port.* in /usr/share/mk/

For 5.x I know it fails (I waited for it to EOL before using options.mk).
For 6 it shouldn't fail on any supported version.

What I don't understand is why it isn't working for you in 6.3R

Last edited by blancolado; 21st July 2008 at 07:59 PM. Reason: acquired more info on the subject
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Crash my FreeBSD server - run portsdb Bruco FreeBSD Ports and Packages 15 1st September 2008 06:28 PM


All times are GMT. The time now is 01:49 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick