DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 25th July 2008
neurosis neurosis is offline
Fdisk Soldier
 
Join Date: Jul 2008
Posts: 69
Thanked 0 Times in 0 Posts
Default Jumpy mouse while HDD is busy in X??

I never had this problem until I moved to FreeBSD 7.0 but now when im in KDE and my hard drive is hammering away while compiling or copying files etc, the mouse just stalls out and jumps around. Its not just the mouse but other programs stall as well when the hdd is very active. Any idea what could cause this problem?
Reply With Quote
  #2   (View Single Post)  
Old 25th July 2008
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

This sounds like a DMA issue, if a drive is in PIO mode the processor has to handle a lot more... are you receiving any errors in your dmesg or system logs?
Reply With Quote
  #3   (View Single Post)  
Old 25th July 2008
neurosis neurosis is offline
Fdisk Soldier
 
Join Date: Jul 2008
Posts: 69
Thanked 0 Times in 0 Posts
Default

I cant see any errors in there. The only error that I notice is a network card problem that I cant seem to get rid of that has watchdog timeouts. Ive looked this up too and never found a solution.
Reply With Quote
  #4   (View Single Post)  
Old 25th July 2008
ephemera's Avatar
ephemera ephemera is offline
Knuth's homeboy
 
Join Date: Apr 2008
Posts: 537
Thanked 49 Times in 43 Posts
Default

Quote:
Originally Posted by neurosis View Post
I never had this problem until I moved to FreeBSD 7.0 but now when im in KDE and my hard drive is hammering away while compiling or copying files etc, the mouse just stalls out and jumps around. Its not just the mouse but other programs stall as well when the hdd is very active. Any idea what could cause this problem?
i have had the same issue since i switched to fbsd 7. i am running it on a 3 yr old pentium4 m/c and the hardware is well supported (even on solaris ).
this happens with nv as well as nvidia drivers. i have tried different versions of xorg but to no avail.
Reply With Quote
  #5   (View Single Post)  
Old 25th July 2008
vermaden's Avatar
vermaden vermaden is offline
Administrator
 
Join Date: Apr 2008
Location: pl_PL.lodz
Posts: 1,052
Thanked 118 Times in 93 Posts
Default

If you run stock 7.0-RELEASE then you should recompile kernel with SCHED_ULE scheduler which is a lot better then current used.
__________________
religions, worst damnation of mankind
"If 386BSD had been available when I started on Linux, Linux would probably never had happened." Linus Torvalds

Linux is not UNIX! Face it! It is not an insult. It is fact: GNU is a recursive acronym for “GNU's Not UNIX”.
vermaden's: links resources deviantart spreadbsd
Reply With Quote
  #6   (View Single Post)  
Old 26th July 2008
neurosis neurosis is offline
Fdisk Soldier
 
Join Date: Jul 2008
Posts: 69
Thanked 0 Times in 0 Posts
Default

Are you talking about in place of

Code:
options         SCHED_4BSD              # 4BSD scheduler
?
Reply With Quote
  #7   (View Single Post)  
Old 26th July 2008
DrJ DrJ is offline
ISO Quartermaster
 
Join Date: Apr 2008
Location: Gold Country, CA
Posts: 506
Thanked 39 Times in 39 Posts
Default

Yup; that's the spot.
Reply With Quote
  #8   (View Single Post)  
Old 26th July 2008
neurosis neurosis is offline
Fdisk Soldier
 
Join Date: Jul 2008
Posts: 69
Thanked 0 Times in 0 Posts
Default

Damn! that totally fixed the problem. No more mouse jumping and stalling. Thanks!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
USB mouse, ums and wsmouse useche OpenBSD General 5 27th July 2009 01:08 AM
mouse freezes in X spiderpig OpenBSD Installation and Upgrading 0 20th April 2009 09:05 AM
/dev/cuad0 busy csimmons0 FreeBSD General 1 7th January 2009 08:48 PM
help with usb mouse?? renej FreeBSD General 14 18th September 2008 01:25 PM
Mouse problems dctr FreeBSD General 3 16th May 2008 02:52 PM


All times are GMT. The time now is 07:23 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick