DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 2nd August 2008
mc_i2020 mc_i2020 is offline
Port Guard
 
Join Date: Jul 2008
Posts: 22
Thanked 0 Times in 0 Posts
Default Speakers not working in Dell Vostro 1400

Hi,
The speakers of Dell Vostro 1400 do not work out of the box for any *nix distributions as well as FreeBSD. The headphones jacks are completely functional though. The linux people fixed it in the kernel 2.6.25. I was wondering if there is any way to make them work in FreeBSD 7.0 . Below are a few links describing the problem in other distribution:-

http://bbs.archlinux.org/viewtopic.php?pid=371844
http://ubuntuforums.org/archive/index.php/t-766591.html

Thanking you,
Mani chandra

Last edited by mc_i2020; 3rd August 2008 at 04:27 AM.
Reply With Quote
  #2   (View Single Post)  
Old 2nd August 2008
Carpetsmoker's Avatar
Carpetsmoker Carpetsmoker is offline
Real Name: Martin
Old man from scene 24
 
Join Date: Apr 2008
Location: Eindhoven, Netherlands
Posts: 2,080
Thanked 198 Times in 156 Posts
Default

Did you try the snd_hda(4) driver? You can load it with:
# kldload snd_hda

See this thread for more information on setting up sound on FreeBSD.
__________________
UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things.
Reply With Quote
  #3   (View Single Post)  
Old 3rd August 2008
mc_i2020 mc_i2020 is offline
Port Guard
 
Join Date: Jul 2008
Posts: 22
Thanked 0 Times in 0 Posts
Default

I am using the snd_hda driver. The headphone jacks work but not the speakers.
Reply With Quote
  #4   (View Single Post)  
Old 5th August 2008
chill's Avatar
chill chill is offline
Fdisk Soldier
 
Join Date: Jun 2008
Location: Federal Republic of the US
Posts: 74
Thanked 6 Times in 6 Posts
Default

The snd_hda driver is still hardly mature in FreeBSD. I had to recompile the driver with some extra fixes I got off the mailing lists in order for it to attach and work with my laptop.

I think I might have the same card as you. For a quick fix try adding
hint.pcm.0.config="noeapdinv" to /boot/device.hints

If that doesn't do anything try adding hint.pcm.0.config="eapdinv" instead.

EDIT: I think one of those should work for you but lastly give noapdinv, noivref or noovref a shot if the other two hints don't work. Just make sure to reboot after each attempt to let the driver try and attach itself with each hint ^_^

Last edited by chill; 5th August 2008 at 09:12 PM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dell 1395 WLAN Drivers yanjchan FreeBSD General 2 30th August 2009 09:28 AM
NetBSD on Dell Inspiron 5150 kdu NetBSD Installation and Upgrading 5 10th June 2009 01:12 AM
Dell Insprion 1525 jwhal OpenBSD General 9 4th December 2008 01:40 PM
Dell R300 bce interface not recognized under 7.0 jwilson FreeBSD General 2 28th July 2008 07:39 PM
Hardware: Dell XPS M1530 h00k3 FreeBSD Installation and Upgrading 0 30th May 2008 02:31 AM


All times are GMT. The time now is 12:03 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick