DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 13th October 2008
biscuits biscuits is offline
Port Guard
 
Join Date: Oct 2008
Posts: 10
Thanked 0 Times in 0 Posts
Default Atheros L1E - linux driver fustration

I've got a Asus P5KPL-CM board here that im trying to install FreeBSD 7.0 AMD64 REL on ... the onboard ethernet didnt get recognised so I grabbed the driver (which apparently is a Atheros L1E linux driver) off asus's website and have been trying to install it since...

After the first bunch of errors I figured out I was probably meant to be using gmake instead of make ... however now that ive installed gmake im getting the error:

"Makefile:62: *** Linux kernel source not found. Stop."

Any ideas??

Edit: I've tried putting linux_enable="yes" into rc.conf as a stab in the dark but that didnt seem to do much ...


Cheers,
Dave.

Last edited by biscuits; 13th October 2008 at 04:32 AM.
Reply With Quote
  #2   (View Single Post)  
Old 13th October 2008
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

A driver written for Linux will not work on FreeBSD, two entirely different operating systems..

The "Linux" emulation, which isn't really emulation, is for user-land applications only..

If the Ethernet chipset isn't supported, you'll have to wait until it is.. vendor supplied drivers for BSD are rare, most are developed by dedicated developers. (From either documentation, or reverse engineering..).
Reply With Quote
  #3   (View Single Post)  
Old 13th October 2008
biscuits biscuits is offline
Port Guard
 
Join Date: Oct 2008
Posts: 10
Thanked 0 Times in 0 Posts
Default

Aww nuts ...

looks like its a dodgy old realtek LAN card for this board then!!

Thanks anyway,

Dave.
Reply With Quote
  #4   (View Single Post)  
Old 13th October 2008
anomie's Avatar
anomie anomie is offline
Local
 
Join Date: Apr 2008
Location: Texas
Posts: 446
Thanked 69 Times in 46 Posts
Default

Quote:
Originally Posted by biscuits
looks like its a dodgy old realtek LAN card for this board then!
Perhaps you've already checked, but does an ath0 ethernet card show up if you run:
% pciconf -lv

?
__________________
Kill your t.v.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
atheros AR5424 amru OpenBSD General 5 12th June 2009 12:29 AM
linux compat and linux-only drivers fbsduser FreeBSD General 9 22nd January 2009 05:42 PM
Atheros 5214 will it work on Freebsd 7 businessgeeks FreeBSD Installation and Upgrading 1 26th December 2008 10:58 AM
Losing connection with Atheros wifi noonereallycares FreeBSD General 2 11th June 2008 03:57 AM
[FB7|wireless]Atheros 5213 cannot search AP magnus FreeBSD General 3 8th May 2008 11:46 PM


All times are GMT. The time now is 08:09 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick