DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 13th October 2008
DNAeon DNAeon is offline
Shell Scout
 
Join Date: Sep 2008
Location: Bulgaria
Posts: 138
Thanked 6 Times in 6 Posts
Default Asus WL-167G setup on FreeBSD 7.0

Okay, I'll need a little help with this one here.. This is my first time using a wireless card under FreeBSD..

I've bought a new Asus WL-167G wireless card, but I can't get it work under FreeBSD 7.0. I've tested the card under WinXP machine and it works fine there - scans, connects, etc..

During boot time my Asus WL-167G card has been detected by FreeBSD and the rum driver is loaded, so the card appears as rum0

Here's what I've done so far, perhaps someone can show me where I'm doing something wrong..
Code:
# ifconfig rum0 list scan
-- getting information about available access points ---
# ifconfig rum0 ssid MYSSID
ifconfig rum0 shows that is connected to MYSSID, but there is no carrier, also the channel is set to a different that the ifconfig rum0 list scan shows so I tried ifconfig rum0 ssid MYSSID channel 6:g, but it seems that FreeBSD always sets the channel to a different value, not 6 and the access point uses only channel 6.

Also the IP address is set by DHCP, so dhclient rum0 always shows no link........... giving up

Adding this to /etc/rc.conf have no result either:
Code:
ifconfig_rum0="DHCP ssid MYSSID"
How to configure that wireless card for my FreeBSD system, I'm missing something here, but what?

Thanks!
Reply With Quote
  #2   (View Single Post)  
Old 13th October 2008
richardpl richardpl is offline
Spam Deminer
 
Join Date: May 2008
Location: Croatia
Posts: 284
Thanked 25 Times in 24 Posts
Default

what is output of:

$ ifconfig
Reply With Quote
  #3   (View Single Post)  
Old 13th October 2008
DNAeon DNAeon is offline
Shell Scout
 
Join Date: Sep 2008
Location: Bulgaria
Posts: 138
Thanked 6 Times in 6 Posts
Default

This is the output of ifconfig rum0:
Code:
rum0: flags=108802<BROADCAST,SIMPLEX,MULTICAST,NEEDSGIANT> metric 0 mtu 1500
	ether 00:1e:8c:bd:25:3a
	media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
	status: no carrier
	ssid "MYSSID" channel 1 (2412 Mhz 11b)
	authmode OPEN privacy OFF txpower 50 bmiss 7 scanvalid 60 bgscan
	bgscanintvl 300 bgscanidle 250 roam:rssi11b 7 roam:rate11b 1 bintval 0
Output from ifconfig rum0 list scan:
Code:
SSID            BSSID              CHAN RATE   S:N     INT CAPS
MYSSID         00:e3:xx:x:xx:xx    6   54M -94:-95  100 ES   ATH
Under WinXP it connects fine, but I can't connect under FreeBSD.

I'm currently using the following to connect, but with no success (in /etc/rc.conf)
Code:
ifconfig_rum0="DHCP ssid MYSSID channel 6"
Any tips?

Thanks for any help!
Reply With Quote
  #4   (View Single Post)  
Old 13th October 2008
richardpl richardpl is offline
Spam Deminer
 
Join Date: May 2008
Location: Croatia
Posts: 284
Thanked 25 Times in 24 Posts
Default

First rum0 interface is down:
use:
# ifconfig rum0 up

second, signal is to low to be actually useful (known problem of this driver because I have similar card)

Try to improve signal strength, so that it become at least 92.
Also use following command:

# ifconfig rum0 roam:rssi 0 roam:rate 0

So that card do not roam if signal strength is lower than 7 rssi (7 is default).
Reply With Quote
  #5   (View Single Post)  
Old 13th October 2008
DNAeon DNAeon is offline
Shell Scout
 
Join Date: Sep 2008
Location: Bulgaria
Posts: 138
Thanked 6 Times in 6 Posts
Default

Quote:
Originally Posted by richardpl
First rum0 interface is down:
use:
# ifconfig rum0 up

second, signal is to low to be actually useful (known problem of this driver because I have similar card)

Try to improve signal strength, so that it become at least 92.
Also use following command:

# ifconfig rum0 roam:rssi 0 roam:rate 0

So that card do not roam if signal strength is lower than 7 rssi (7 is default).
Thanks for the tips!

I was in a hurry to get this card working that actually I haven't noticed that the card was down.

The command I used is this (after bringing the interface up):
# ifconfig rum0 roam:rssi11g 0 roam:rate11g 0

Currently I'm not at home and that's why I use this wireless card, and btw the signal is not that good really, but it serves me well - I get about 600-700KB/s which is enough for now.

Anyway I wasn't able to connect with this settings either.. Seems that I'll have to stick on winxp for the next two weeks, because I need that inet connection..

Anyway, Thanks for your help, I appreciate it!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
freeBSD on Asus EEE PC 1000H ccc FreeBSD Installation and Upgrading 20 24th June 2009 12:14 AM
FreeBSD 7 on ASUS P5K SE psantacr FreeBSD General 11 1st June 2009 02:33 PM
setup gdm for fluxbox on FreeBSD 6.2 map7 FreeBSD General 9 10th November 2008 01:06 AM
Asus P5Q-E support in FreeBSD 7.1-BETA (amd64) hydra FreeBSD General 4 1st October 2008 06:22 PM
asus wl-167g wirless pin question droolin FreeBSD General 2 8th May 2008 11:00 AM


All times are GMT. The time now is 09:19 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick