DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 24th October 2008
biscuits biscuits is offline
Port Guard
 
Join Date: Oct 2008
Posts: 10
Thanked 0 Times in 0 Posts
Default Turn off daylight savings adjust??

Tearing my hair out on this problem at the moment: Perth (GMT +0800) comes into daylight savings this weekend (GMT +0900) and the automatic 1 hr shift is causing absolutely havoc with my PHP pages in the office.

I'm not sure if its FreeBSD 7.0 or PHP 4 doing it (suspect FreeBSD tho) but I really need to somehow turn off the automatic DST adjust and keep everything going along at GMT +0800 for the sake of my PHP scripts.

Basically the problem stems from if you get php to give the date today:

echo date(r); and you get: Wed, 24 Oct 2008 10:26:07 +0800

now if i set the date in FreeBSD to the 29th Oct say, i get: Wed, 29 Oct 2008 10:26:07 +0900

So one way or the other, i really need to fix the +0800 setting somehow??

Any idea how I might be able to accomplish this?

Thanks in advance,
Dave.
Reply With Quote
  #2   (View Single Post)  
Old 24th October 2008
biscuits biscuits is offline
Port Guard
 
Join Date: Oct 2008
Posts: 10
Thanked 0 Times in 0 Posts
Default

Ok, think I've got a workaround for it anyway ... my server now resides in Hong Kong (+0800 GMT)

Dave
Reply With Quote
  #3   (View Single Post)  
Old 24th October 2008
BSDKaffee's Avatar
BSDKaffee BSDKaffee is offline
Real Name: Jason Hale
Coffee Addict
 
Join Date: May 2008
Location: Wintersville, Ohio
Posts: 212
Thanked 36 Times in 34 Posts
Default

You probably need to update your timezone database. Try using the misc/zoneinfo port to do so. Or update your system sources and do buildworld.

Last edited by BSDKaffee; 24th October 2008 at 06:34 AM.
Reply With Quote
  #4   (View Single Post)  
Old 24th October 2008
robbak's Avatar
robbak robbak is offline
Real Name: Robert Backhaus
VPN Cryptographer
 
Join Date: May 2008
Location: North Queensland, Australia
Posts: 366
Thanked 40 Times in 39 Posts
Default

Well, that would work. Another way would be to edit the system crontab (/etc/crontab) or /etc/periodic/ to disable running tzupdate.
__________________
The only dumb question is a question not asked.
The only dumb answer is an answer not given.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to turn drives off after a period of time? drhowarddrfine FreeBSD General 9 3rd May 2009 12:05 PM
Can't turn off laptop speaker GullibleJones OpenBSD General 5 22nd November 2008 03:40 AM


All times are GMT. The time now is 02:24 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick