DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 18th October 2008
snes-addict's Avatar
snes-addict snes-addict is offline
Real Name: Ken
BSD gamer
 
Join Date: Oct 2008
Location: Minnesota, USA
Posts: 34
Thanked 0 Times in 0 Posts
Question Network connection works fine, and then...

...suddenly, as of yesterday, I cannot access most websites. The other computers on the network seem to work, and when booting into a live GNU/Linux on my OpenBSD box, everything also works. I'm pretty darn sure that this is config related, but I'm not sure where I went wrong.

What's bizzare about this is that some sites, such as daemonforums.org, netbsd.org, openbsd.org, and linux.org work fine, even though I cannot even get simple requests from most websites.

Here is a very rough visual of the network. Nothing special.
Code:
 _______________________
(                       )
(       Internet        )
(_______________________)
           | |
           | |
        ___| |___
       |         |
       |  Modem  |
       |_________|              _________
            ||                 |         |
         ___||___            __| Printer |
        |        |          |  |_________|
        | router |          |
        |________|          |        _________________
          | | | |___________|       |                 |
          | | |_____________________| OpenBSD Machine | -Partial Internet >:(
          | |___________________    |_________________|
     _____|_____________        |___________________
    |                   |       |                   |
    | Windows Machine 1 |       | Windows Machine 2 |
    |___________________|       |___________________|
My /etc/hosts file:
Code:
#       $OpenBSD: hosts,v 1.11 2002/09/26 23:35:51 krw Exp $
#
# Host Database
#
# RFC 1918 specifies that these networks are "internal".
# 10.0.0.0      10.255.255.255
# 172.16.0.0    172.31.255.255
# 192.168.0.0   192.168.255.255
#
::1 localhost.domain.actdsltmp localhost
127.0.0.1 localhost.domain.actdsltmp localhost
::1 puffin.domain.actdsltmp puffin
127.0.0.1 puffin.domain.actdsltmp puffin

192.168.0.3   router.domain.actdsltmp router
192.168.0.4   router.domain.actdsltmp router
192.168.1.100 puffin.domain.actdsltmp puffin
And here's some more:
Code:
puffin:ken {22} route -n show -inet
Routing tables

Internet:
Destination        Gateway            Flags    Refs      Use    Mtu  Interface
default            192.168.1.1        UGS         0      527      -   vr0
127/8              127.0.0.1          UGRS        0        0  33208   lo0
127.0.0.1          127.0.0.1          UH          2        4  33208   lo0
192.168.1/24       link#1             UC          2        0      -   vr0
192.168.1.1        MAC addr           UHLc        1        0      -   vr0
192.168.1.100      127.0.0.1          UGHS        0        0  33208   lo0
192.168.1.101      MAC addr           UHLc        0        0      -   vr0
224/4              127.0.0.1          URS         0        0  33208   lo0
I hope that I've provided enough correct information.

Any suggestions on this?
Reply With Quote
  #2   (View Single Post)  
Old 18th October 2008
phoenix's Avatar
phoenix phoenix is offline
Risen from the ashes
 
Join Date: May 2008
Posts: 699
Thanked 90 Times in 81 Posts
Default

Static IP or DHCP?

Sounds like a DNS issue.

Anything in /etc/resolv.conf?

What happens if you run ping www.google.com in a terminal? Or ping 208.67.217.231?

If the first fails and the second succeeds, then your system is having problems querying DNS servers.
__________________
Freddie

Help for FreeBSD: Handbook, FAQ, man pages, mailing lists.
Reply With Quote
  #3   (View Single Post)  
Old 18th October 2008
snes-addict's Avatar
snes-addict snes-addict is offline
Real Name: Ken
BSD gamer
 
Join Date: Oct 2008
Location: Minnesota, USA
Posts: 34
Thanked 0 Times in 0 Posts
Default

I'm using DHCP.

Code:
puffin:ken {27} cat /etc/resolv.conf
search domain.actdsltmp
nameserver 192.168.0.1
nameserver 205.171.3.26
lookup file bind
Code:
puffin:ken {23} ping -c5 google.com
PING google.com (72.14.207.99): 56 data bytes
64 bytes from 72.14.207.99: icmp_seq=0 ttl=245 time=77.586 ms
64 bytes from 72.14.207.99: icmp_seq=1 ttl=245 time=77.115 ms
64 bytes from 72.14.207.99: icmp_seq=2 ttl=245 time=74.625 ms
64 bytes from 72.14.207.99: icmp_seq=3 ttl=245 time=75.068 ms
64 bytes from 72.14.207.99: icmp_seq=4 ttl=245 time=76.961 ms
--- google.com ping statistics ---
5 packets transmitted, 5 packets received, 0.0% packet loss
round-trip min/avg/max/std-dev = 74.625/76.271/77.586/1.189 ms
Code:
puffin:ken {24} ping -c5 208.67.217.231
PING 208.67.217.231 (208.67.217.231): 56 data bytes
64 bytes from 208.67.217.231: icmp_seq=0 ttl=55 time=65.500 ms
64 bytes from 208.67.217.231: icmp_seq=1 ttl=55 time=64.874 ms
64 bytes from 208.67.217.231: icmp_seq=2 ttl=55 time=64.551 ms
64 bytes from 208.67.217.231: icmp_seq=3 ttl=55 time=64.721 ms
64 bytes from 208.67.217.231: icmp_seq=4 ttl=55 time=65.130 ms
--- 208.67.217.231 ping statistics ---
5 packets transmitted, 5 packets received, 0.0% packet loss
round-trip min/avg/max/std-dev = 64.551/64.955/65.500/0.369 ms
Reply With Quote
  #4   (View Single Post)  
Old 18th October 2008
ai-danno's Avatar
ai-danno ai-danno is offline
Spam Deminer
 
Join Date: May 2008
Location: Boca Raton, Florida
Posts: 284
Thanked 35 Times in 31 Posts
Default

You appear to have references to two different private networks... 192.168.1.0/24 and 192.168.0.0/24. This screws up your DNS as the first DNS server listed is not your actual DNS server-

192.168.0.1 is listed as your first nameserver, but your default gateway in the routing table is listed as 192.168.1.1.

So you can probably ping the heck outta IP addresses, but more than half the time you will not be able to resolve DNS (the backup nameserver appears to be a real address.)

Now, of course, I'm wrong about this if, in fact, you really have a 192.168.0.1, but even then, your machine has to route to the router to get to that nameserver, and that particular host isn't represented in the information you provided anywhere.

Also, if my hunch is correct, you will also want to correct in any entries in your hosts file that make reference to 192.168.0.x to 192.168.1.x.
__________________
Network Firefighter
Reply With Quote
  #5   (View Single Post)  
Old 18th October 2008
snes-addict's Avatar
snes-addict snes-addict is offline
Real Name: Ken
BSD gamer
 
Join Date: Oct 2008
Location: Minnesota, USA
Posts: 34
Thanked 0 Times in 0 Posts
Default

@ ai-danno: yes, I do have a 192.168.0.1, that would be my modem.

I think I might understand what you are saying. Would this mean that I have to add 192.168.0.1 into /etc/hosts, or do I need the router's IP address?
Reply With Quote
  #6   (View Single Post)  
Old 18th October 2008
phoenix's Avatar
phoenix phoenix is offline
Risen from the ashes
 
Join Date: May 2008
Posts: 699
Thanked 90 Times in 81 Posts
Default

Two options: either remove the first nameserver line in /etc/resolv.conf, or edit that line to read 192.168.1.1.

You'll also want to remove the two lines with 192.168.0.x entries from /etc/hosts. They aren't correct, or needed.
__________________
Freddie

Help for FreeBSD: Handbook, FAQ, man pages, mailing lists.
Reply With Quote
  #7   (View Single Post)  
Old 19th October 2008
snes-addict's Avatar
snes-addict snes-addict is offline
Real Name: Ken
BSD gamer
 
Join Date: Oct 2008
Location: Minnesota, USA
Posts: 34
Thanked 0 Times in 0 Posts
Default

I got it working again! Cool, thank you very much, phoenix and ai-danno!

I think it was all in /etc/resolv.conf. The file now reads:
Code:
search domain.actdsltmp
nameserver 205.171.3.26
nameserver 192.168.1.1
lookup file bind
And /etc/resolv.conf.tail is:
Code:
nameserver 192.168.1.1
lookup file bind
Now I only have to figure out how to make my edit to /etc/resolv.conf permanent. I know that, according to the OpenBSD FAQ, /etc/dhclient.conf has something to do with this, but how would I ensure that the old line "nameserver 192.168.0.1" is not re-added on bootup?
Reply With Quote
  #8   (View Single Post)  
Old 19th October 2008
phoenix's Avatar
phoenix phoenix is offline
Risen from the ashes
 
Join Date: May 2008
Posts: 699
Thanked 90 Times in 81 Posts
Default

Fix the DHCP server. Most likely it's your router. Just go through the configs on there and put in the correct DNS server entries.
__________________
Freddie

Help for FreeBSD: Handbook, FAQ, man pages, mailing lists.
Reply With Quote
  #9   (View Single Post)  
Old 20th October 2008
snes-addict's Avatar
snes-addict snes-addict is offline
Real Name: Ken
BSD gamer
 
Join Date: Oct 2008
Location: Minnesota, USA
Posts: 34
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by phoenix View Post
Fix the DHCP server. Most likely it's your router. Just go through the configs on there and put in the correct DNS server entries.
Got it.
dhclient vr0 updates /etc/resolv.conf with correct info now. Thanks!
Reply With Quote
Reply

Tags
internet, networking

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Openbsd 4.5 network connection timeout andrewm OpenBSD General 4 11th September 2009 02:32 AM
hard disk: avail 0 capacity 100% is it fine to use it like this? gosha General Hardware 13 17th June 2009 03:53 PM
.wav file playing very fast on unix, fine on win gosha General software and network 16 2nd June 2009 02:37 PM
Wireless Network Loses Connection JMJ_coder NetBSD General 5 17th February 2009 09:14 PM
Numeric keypad don't works on X aleunix OpenBSD Installation and Upgrading 3 15th June 2008 11:59 AM


All times are GMT. The time now is 07:20 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick