DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 16th November 2008
Bubba_HoTep Bubba_HoTep is offline
New User
 
Join Date: Nov 2008
Posts: 6
Thanked 0 Times in 0 Posts
Default FreeBSD hangs on boot

Gidday FreeBSDers

I've a FreeBSD 7.0 64 bit server which has a boot problem that is driving me nuts.

It takes multiple gos to boot successfully. Most times it just hangs, always at the same point in the boot sequence -

firewire 0: bus manager 0 (me)

I have to kill the power and reboot and eventually I get lucky and it boots.

This didn't bother me so much cos once booted the server stayed on - but I'm testing an UPS with the box and need to reboot to test my shutdown scripts - and it's getting to be a real pain.

I also suspect that my hitting the power switch may be causing filesystem corruption - my first post on this board http://www.daemonforums.org/showthread.php?t=2342 was about this. I fixed that problem with a fsck - only for the problem to reappear.

The OS disk is a 4Gb CF card - and so I don't have a swap partition. The CF card I haven't set ro yet as I'm still messing about with bits and pieces.

All the hardware (apart from the CF card) is known to be good as this box was running problem free with Linux before i wiped it and put on FreeBSD.

When the server boots its runs fine (apart from the FS errors noted above)

dmesg doesn't throw up any errors that I can see either...


As I see it there's 3 possible causes:

1) Something wrong with my CF card (which would explain FS errors)

2) something wrong with my FreeBSD install

3) something that I haven't thought of


Can anyone shed any light?
Reply With Quote
  #2   (View Single Post)  
Old 16th November 2008
J65nko J65nko is offline
Administrator
 
Join Date: May 2008
Location: Budel - the Netherlands
Posts: 3,188
Thanked 182 Times in 149 Posts
Default

Can you disable firewire in the BIOS?
You could download a 7.1BETA2 snapshot, install it and see whether your issue is solved. See ftp://ftp.freebsd.org/pub/FreeBSD/re...SO-IMAGES/7.1/
__________________
You don't need to be a genius to debug a pf.conf firewall ruleset, you just need the guts to run tcpdump
Reply With Quote
  #3   (View Single Post)  
Old 20th November 2008
Bubba_HoTep Bubba_HoTep is offline
New User
 
Join Date: Nov 2008
Posts: 6
Thanked 0 Times in 0 Posts
Default

I'm still having problems with this.

It seems FreeBSD doesn't like my hardware.

I disabled firewire and what the hell I disabled the parallel ports as well.

No difference.

Next I swapped out the Transcend CF card for a different brand - Sandisk.
Installing FreeBSD on the Sandisk CF went smoothly and it booted ok for the first few times.

Now however i can't get FreeBSD to boot at all on either the Transcend or Sandisk cards.

On another Sandisk card i have a Linux OS which boots ok.

The motherboard is an Intel, there isn't any exotic hardware hanging off it.

Has anyone any ideas what I can try next?
Reply With Quote
  #4   (View Single Post)  
Old 29th November 2008
mdh's Avatar
mdh mdh is offline
Real Name: Matt D. Harris
FreeBSD 2.2.6 User
 
Join Date: Oct 2008
Location: West Virginia
Posts: 139
Thanked 8 Times in 8 Posts
Default

This should probably get a PR. It seems like a race condition.

I've heard of similar issues where a piece of hardware existed in the system (in that case, a gem ethernet controller) and that driver was not enabled in the kernel. Perhaps try creating a very liberal kernel where you're absolutely sure it had drivers compiled in for all of the hardware the system has.

Regardless, it probably needs a PR to get fixed.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenBSD 4.6 i386 boot hangs with old gateway system - resolved comet--berkeley OpenBSD Installation and Upgrading 6 22nd July 2011 08:15 AM
make build hangs chill OpenBSD Installation and Upgrading 5 2nd April 2009 05:03 PM
openbsd hangs momentarily at boot bogd OpenBSD General 11 9th January 2009 02:53 PM
FreeBSD 7.0 hangs with USB disk drive. map7 FreeBSD General 7 9th August 2008 03:02 AM
FreeBSD boot problem kdi FreeBSD General 2 25th May 2008 07:09 AM


All times are GMT. The time now is 01:53 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick