DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 4th November 2009
nightcrawler nightcrawler is offline
New User
 
Join Date: Mar 2009
Posts: 4
Thanked 0 Times in 0 Posts
Default cupsaddsmb error

Hi,

I hope you won't mind if I post here the question I've already posted on 2 other sites -- there's no answer for 2 days, and I've no idea of how to solve this, and it's urgent for me.

So I installed a CUPS 1.3.10 and Samba (3.3.8) PDC server on FreeBSD 7.2. File share works ok, printing works from CUPS web interface ok, and at least from one of the Win workstations, but now I wish to share the printer drivers, too.

So I installed the cups-samba port, made sure my [Printers] and [$print] sections are as suggested in the cupsaddsmb man page, copied the Win drivers for my printer to /usr/local/share/cups/drivers, added the root account to samba and tried to export the drivers to the samba share, but cupsaddsmb refuses to:

Code:
myserver# cupsaddsmb -U root -a -v
cupsaddsmb: No PPD file for printer "hplj6l" - Missing double quote on line 224!
Now, hplj6l is how I named my HP LaserJet 6L printer in CUPS. I installed it using a ppd file from linuxprinting.org (HP-LaserJet_6L-lj4dith.ppd). CUPS also seems to have put a file named hplj6l.ppd in /usr/local/etc/cups/ppd/hplj6l.ppd. I tried to run 'cupstestppd' against the two files but they pass ok.
Tried to add the two files and hplj6p_4.ppd (a file from Windows driver cab) to /usr/local/share/cups/model, but no effect.

Now, where does cupsaddsmb look for the PPD file, and where does it get the funny "Missing double quote on line 224"? Could it be a bug? Any ideas of what's wrong here or how to get it work?

Thanks in advance, seriously.
Reply With Quote
  #2   (View Single Post)  
Old 10th November 2009
nightcrawler nightcrawler is offline
New User
 
Join Date: Mar 2009
Posts: 4
Thanked 0 Times in 0 Posts
Default Partially solved

I noticed that there's difference between the permissions CUPS itself has made for its drivers in

/usr/local/share/cups/drivers and the Win drivers I copied there. So I changed the permissions to

cups:wheel 644, and now cupsaddsmb executes ok, at last.

But there's another issue I can't still figure out: I can only add that printer on Win workstations when

I log in there with local administrator's priviledges. If not, an error message pops up:

"A policy is effect on your computer which prevents you from connecting to this print queue. Please

contact your system administrator."

I set /var/spool/samba permissions to 777 but this didn't change anything.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:48 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick