DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 20th December 2008
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default Mount DVD - invalid argument.

I have two DVD drives on my machine.

/dev looks like this:

Code:
acd0            cuad0.init      mdctl           random          ttyv7
acd0t01         cuad0.lock      mem             sndstat         ttyv8
acd1            dcons           midistat        stderr          ttyv9
acpi            devctl          mixer0          stdin           ttyva
ad0             devstat         net             stdout          ttyvb
ad0s1           dgdb            net1            sysmouse        ttyvc
ad0s1a          dsp0.0          net2            ttyd0           ttyvd
ad0s1b          dumpdev         net3            ttyd0.init      ttyve
ad0s1c          fd              network         ttyd0.lock      ttyvf
ad0s1d          fido            nfs4            ttyp0           ugen0
ad0s1e          geom.ctl        nfslock         ttyp1           ugen0.1
ad0s1f          io              null            ttyp2           ums0
ata             kbd0            nvidia0         ttyp3           urandom
atkbd0          kbd1            nvidiactl       ttyv0           usb
audit           kbdmux0         pci             ttyv1           usb0
bpf0            klog            ppi0            ttyv2           usb1
console         kmem            ptyp0           ttyv3           xpt0
consolectl      log             ptyp1           ttyv4           zero
ctty            lpt0            ptyp2           ttyv5
cuad0           lpt0.ctl        ptyp3           ttyv6
acd0 is my burner, acd1 is my non-burner/rom drive.

/etc/fstab looks like this:
Code:
# Device		Mountpoint	FStype	Options		Dump	Pass#
/dev/ad0s1b		none		swap	sw		0	0
/dev/ad0s1a		/		ufs	rw		1	1
/dev/ad0s1e		/tmp		ufs	rw		2	2
/dev/ad0s1f		/usr		ufs	rw		2	2
/dev/ad0s1d		/var		ufs	rw		2	2
/dev/acd0		/cdrom		cd9660	ro,noauto	0	0
/dev/acd1		/cdrom		cd9660	ro,noauto	0	0
/dev/da0s1		/mnt/flash	msdosfs	rw,noauto	0	0
I have enabled the atapi support in /boot/loader.conf

snd_hda_load="YES"
loader_logo="beastiebw"
nvidia_load="YES"
hw.ata.atapi_dma="1"

however mounting still fails -
sudo mount /dev/acd0 /cdrom
mount: /dev/acd0 : Invalid argument

I've tried using (what seems to me) a more appropriate mount point, creating /dvdburner and /dvdrom respectively.

I've also tried variations on the mount command.

Where am I going wrong please?
Reply With Quote
  #2   (View Single Post)  
Old 20th December 2008
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

max@~: grep acd /var/run/dmesg.boot
acd0: DVDR <PIONEER DVD-RW DVR-111D/1.19> at ata1-master UDMA66
acd1: DMA limited to UDMA33, device found non-ATA66 cable
acd1: DVDROM <ASUS DVD-E616A2/1.03> at ata1-slave UDMA33
Reply With Quote
  #3   (View Single Post)  
Old 20th December 2008
Oko's Avatar
Oko Oko is offline
Fsck Surgeon
 
Join Date: May 2008
Location: Kosovo, Serbia
Posts: 759
Thanked 36 Times in 32 Posts
Default

Quote:
Originally Posted by maxrussell View Post
max@~: grep acd /var/run/dmesg.boot
acd0: DVDR <PIONEER DVD-RW DVR-111D/1.19> at ata1-master UDMA66
acd1: DMA limited to UDMA33, device found non-ATA66 cable
acd1: DVDROM <ASUS DVD-E616A2/1.03> at ata1-slave UDMA33
I personally have more than two optical drives on two of my computers attached to the same IDE controller on the same cable but it is not recommended!!!

Make sure that pins on the back of your Pioneer are in master position and that pins on you ASUS DVD ROM are in slave position.

Check if the devices properly detected by BIOS as a master and slave.
If not you have a hardware problem. I suspect that one of the devices doesn't work on UDM66 cable.
Check then the dmesg Try to mount CDs on the devices manually before altering fstab.

Also you can read this regarding DMA IDE. It is for OpenBSD but it should
be similar in FreeBSD

http://www.openbsd.org/faq/faq14.html#pciideErr

Last edited by Oko; 20th December 2008 at 11:47 PM.
Reply With Quote
  #4   (View Single Post)  
Old 20th December 2008
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

Code:
/dev/acd0		/cdrom		cd9660	ro,noauto	0	0
/dev/acd1		/cdrom		cd9660	ro,noauto	0	0
Don't give 2 devices the same mount point.

Also, DVD's typically use the UDF file system.. not ISO9660. (s/cd9660/udf)

fstab(5) aliases get complicated with mount points that may use different file systems.. consider mounting disks manually.

If that's not an option, you could re-purpose each of the available drives.. i.e: /mnt/cdrom and /mnt/dvdrom..

Code:
/dev/acd0		/mnt/cdrom	cd9660	ro,noauto	0	0
/dev/acd1		/mnt/dvdrom	udf	ro,noauto	0	0
So you could inset a DVD into the second drive.. and then type "mount /mnt/dvdrom".

The choice is yours.
Reply With Quote
  #5   (View Single Post)  
Old 20th December 2008
Oko's Avatar
Oko Oko is offline
Fsck Surgeon
 
Join Date: May 2008
Location: Kosovo, Serbia
Posts: 759
Thanked 36 Times in 32 Posts
Default

Quote:
Originally Posted by BSDfan666 View Post
Code:
/dev/acd0		/cdrom		cd9660	ro,noauto	0	0
/dev/acd1		/cdrom		cd9660	ro,noauto	0	0
Don't give 2 devices the same mount point.

Also, DVD's typically use the UDF file system.. not ISO9660. (s/cd9660/udf)

fstab(5) aliases get complicated with mount points that may use different file systems.. consider mounting disks manually.

If that's not an option, you could re-purpose each of the available drives.. i.e: /mnt/cdrom and /mnt/dvdrom..

Code:
/dev/acd0		/mnt/cdrom	cd9660	ro,noauto	0	0
/dev/acd1		/mnt/dvdrom	udf	ro,noauto	0	0
So you could inset a DVD into the second drive.. and then type "mount /mnt/dvdrom".

The choice is yours.
It is so much simpler to use command line instead of HAL but that is the way you and me think.

For all I know he might not have edited /etc/sysctl.conf,
/etc/rc.conf and /etc/devfs.conf properly as well. That is way I suggested mounting
file systems manually to rule out the hardware problems before trying to hunt for his HAL problem.
Dbus is buggy as Hell as well.

Obviously reading about cd9660, udf and other stuff would help to.

Most dvd players do NOT mount file system. They just play it like you would play CD or just like you play DVD on your home DVD player. On another hand you are completely right that DVD format is actually micro UDF which is backward compatible with
cd9660. Video DVD mounted either as udf or cd9660 will be probably
not be readable without help of mencoder or libcss/libdvdread because of
scrambling. If it is not scrambled either way you are in business.
That doesn't mean that there are no serous other differences between
DVD and CD as mediums and the way they should be burned.
Reply With Quote
  #6   (View Single Post)  
Old 22nd December 2008
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

My /etc/sysctl.conf

#security.bsd.see_other_uids=0

hw.syscons.bell=0

devfs.conf
Code:
#link   ttyv0   vga

# Commonly used by many ports
#link   acd0    cdrom

# Allow a user in the wheel group to query the smb0 device
#perm   smb0    0660

# Allow members of group operator to cat things to the speaker
#own    speaker root:operator
#perm   speaker 0660
Both default (apart from turning off the system bell.

I've changed the two lines of my etc/rc.conf to look like this:
Code:
/dev/acd0               /dvdburner              udf,cd9660      ro,noauto      00
/dev/acd1               /dvdrom         udf,cd9660      ro,noauto       0      0
However:

max@~: sudo mount /dvdburner/
Password:
mount: /dev/acd0 : Operation not supported by device


So still no success...

Last edited by maxrussell; 22nd December 2008 at 09:37 PM. Reason: spelling error, oops
Reply With Quote
  #7   (View Single Post)  
Old 22nd December 2008
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

Should also mention that I'm trying to access AVI files on the DVD; it isn't a DVD (proper)
Reply With Quote
  #8   (View Single Post)  
Old 22nd December 2008
phoenix's Avatar
phoenix phoenix is offline
Risen from the ashes
 
Join Date: May 2008
Posts: 699
Thanked 90 Times in 81 Posts
Default

Is there anything logged to dmesg (or /var/log/messages) when you get that error?

Have you tried specifying the filesystem (first udf, then cd9660) on the commandline: mount -t udf -r /dev/acd0 /cdrom
__________________
Freddie

Help for FreeBSD: Handbook, FAQ, man pages, mailing lists.
Reply With Quote
  #9   (View Single Post)  
Old 23rd December 2008
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

I've tried mount_udf /dev/acd0 /dvdburner (the mount point I now have in fstab)
Reply With Quote
Old 23rd December 2008
phoenix's Avatar
phoenix phoenix is offline
Risen from the ashes
 
Join Date: May 2008
Posts: 699
Thanked 90 Times in 81 Posts
Default

Side note: Don't use mount_whatever. Those binaries are going away. You should always use "mount -t <whatever>". The end result is the same, but you won't run into the "command not found" issues as the mount_whatever binaries are removed.

What happens when you use -t cd9660?
__________________
Freddie

Help for FreeBSD: Handbook, FAQ, man pages, mailing lists.
Reply With Quote
Old 23rd December 2008
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by phoenix View Post
Side note: Don't use mount_whatever. Those binaries are going away. You should always use "mount -t <whatever>". The end result is the same, but you won't run into the "command not found" issues as the mount_whatever binaries are removed.

What happens when you use -t cd9660?
I'll try doing it in the mount -t udf format tonight. the cd9660 previously failed, but I'll look again.
Reply With Quote
Old 23rd December 2008
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

Okay. I have the two lines in fstab as:

/dev/acd0 /dvdburner cd9660,udf ro,noauto 0 0
/dev/acd1 /dvdrom cd9660,udf ro,noauto 0 0

Mounting still fails;

/dev/acd0 /dvdburner cd9660,udf ro,noauto 0 0
/dev/acd1 /dvdrom cd9660,udf ro,noauto 0 0
Reply With Quote
Old 23rd December 2008
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

Also, last /var/log/messages provides this:

Code:
root ; COMMAND=/sbin/mount -t udf /dvdrom
Dec 23 20:28:57 ironteeth sudo:      max : TTY=ttyp2 ; PWD=/usr/home/max ; USER=root ; COMMAND=/sbin/mount -t udf /dev/acd1 /dvdrom
Dec 23 20:28:57 ironteeth kernel: FSD does not lie within the partition!
Dec 23 20:30:02 ironteeth sudo:      max : TTY=ttyp3 ; PWD=/usr/home/max ; USER=root ; COMMAND=/usr/local/bin/kedit /etc/fstab
Dec 23 20:30:30 ironteeth sudo:      max : TTY=ttyp2 ; PWD=/usr/home/max ; USER=root ; COMMAND=/sbin/mount -t udf /dev/acd1 /dvdrom
Dec 23 20:30:30 ironteeth kernel: FSD does not lie within the partition!
Dec 23 20:30:35 ironteeth sudo:      max : TTY=ttyp2 ; PWD=/usr/home/max ; USER=root ; COMMAND=/sbin/mount -t udf /dvdrom
Dec 23 20:30:39 ironteeth sudo:      max : TTY=ttyp2 ; PWD=/usr/home/max ; USER=root ; COMMAND=/sbin/mount /dvdrom
Dec 23 20:30:47 ironteeth sudo:      max : TTY=ttyp2 ; PWD=/usr/home/max ; USER=root ; COMMAND=/sbin/mount -t cd9660 /dvdrom
Dec 23 20:31:59 ironteeth sudo:      max : TTY=ttyp2 ; PWD=/usr/home/max ; USER=root ; COMMAND=/sbin/mount -t udf /dev/acd1
Dec 23 20:32:06 ironteeth sudo:      max : TTY=ttyp2 ; PWD=/usr/home/max ; USER=root ; COMMAND=/sbin/mount -t udf /dvdrom/
Dec 23 20:32:09 ironteeth sudo:      max : TTY=ttyp2 ; PWD=/usr/home/max ; USER=root ; COMMAND=/sbin/mount -t udf /dvdrom
Reply With Quote
Old 23rd December 2008
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

I do not believe that BSD fstab(5) supports multiple file system type selections.. i.e: the third column isn't comma separated.

Your only option is separate mount points, or.. manually specifying the file system type.

i.e:
Code:
/dev/acd0 /dvdburner cd9660 ro,noauto 0 0
/dev/acd1 /dvdrom cd9660 ro,noauto 0 0
Now, by default, it'll assume ISO9660 formated disks.. to override that, specify the type implicitly.

ISO9600 disk:
% sudo mount /dvdrom # or /dvdburner

UDF disk:
% sudo mount -t udf /dvdrom # or /dvdburner

This is all really a non-issue maxrussell..

@Oko, your claims of UDF backwards compatibility are false.. DVD's can use ISO9660 instead of UDF, but the UDF file system itself is not backwards compatible with ISO9660.
Reply With Quote
Old 23rd December 2008
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

Also note; the ro option in the 4th column is redundant.. compact disks are always mounted read-only.

Some bullet points:
  • You do not need to mount a DVD movie in order to play it.
  • When you're burning a CD/DVD, the device is not mounted.
Hope that helps.
Reply With Quote
Old 23rd December 2008
phoenix's Avatar
phoenix phoenix is offline
Risen from the ashes
 
Join Date: May 2008
Posts: 699
Thanked 90 Times in 81 Posts
Default

Doing a google search for "FSD does not lie within the partition!" makes it sounds like you have a faulty DVD, that does not have a proper filesystem layout. As such, the kernel cannot mount it.
__________________
Freddie

Help for FreeBSD: Handbook, FAQ, man pages, mailing lists.
Reply With Quote
Old 28th December 2008
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

So I've trawled through my highly organised workspace and verified this with some other media - mounting CDs or DVDs seems fine. This one particular disc seems to be faulty as suggested (it was burned on an XP machine using the 'standard' Windows writing software...) It reads on a WIndows machine, but not on FreeBSD.

Thanks for all the help, I've learned a great deal about mountpoints and filesystems, so I don't consider it wasted effort. Really should remember to Try the SImplest Thing First though...
Reply With Quote
Old 7th January 2009
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

as a post-script to this: could anyone tell me offhand what the default burning behaviour is for Windows (XP), using the standard (OS) tools? Is it doing something non-standard? The DVD I wished to use was just divx files.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
mount-msdosfs /dev/dao: : Invalid argument harold FreeBSD General 5 12th December 2010 06:59 AM
Pidgin MSN connection issues, invalid SSL Certificate chain TerryP Guides 5 8th December 2010 01:06 AM
how to mount ext3 guitarscn FreeBSD General 2 26th August 2009 07:31 PM
Cannot mount (NTFS) IIMarckus OpenBSD General 4 11th August 2008 08:44 PM
Invalid capture filter: "not ip host "! ccc FreeBSD General 2 19th June 2008 08:12 PM


All times are GMT. The time now is 01:29 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick