DaemonForums  

Go Back   DaemonForums > Other Operating Systems > Solaris

Solaris SUN Solaris & OpenSolaris.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 31st January 2009
DraconianTimes's Avatar
DraconianTimes DraconianTimes is offline
Security Geek
 
Join Date: May 2008
Location: United Kingdom
Posts: 37
Thanked 2 Times in 2 Posts
Default radeonhd with two monitors

I'm in the process of building my new workstation (OpenSolaris 2008.11), but am a bit stuck with configuring X to span my two monitors (3840x1200).

Graphics card: PowerColor Radeon HD 4870
Monitors: 2 x Dell 2408WFP 24" (1920x1200)

I've searched around various places and stitched together a file for /etc/X11/xorg.conf. However, using this file gives me only console log-on - if I remove the xorg.conf, I get gdm starting up, but the screen is essentially duplicated on both monitors.

Any idea where I've gone wrong? I've copied in xorg.conf below, the Xorg.0.log is here.

Thanks...

/etc/X11/xorg.conf
Code:
Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "MyScreen" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	RgbPath      "/usr/X11/lib/X11/rgb"
	ModulePath   "/usr/X11/lib/modules/amd64"
	FontPath     "catalogue:/etc/X11/fontpath.d"
	FontPath     "/TrueType/"
	FontPath     "/Type1/"
	FontPath     "/Type1/sun/"
	FontPath     "/F3bitmaps/"
	FontPath     "/misc/"
	FontPath     "/100dpi/"
	FontPath     "/75dpi/"
EndSection

Section "Module"
	Load  "extmod"
	Load  "GLcore"
	Load  "xtrap"
	Load  "dri"
	Load  "IA"
	Load  "dbe"
	Load  "glx"
	Load  "record"
	Load  "freetype"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/mouse"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	Identifier   "Dell 2408WFP (Left)"
	Option       "DPMS"
	HorizSync    30-83
	VertRefresh  56-75
EndSection

Section "Monitor"
	Identifier   "Dell 2408WFP (Right)"
	Option       "DPMS"
	HorizSync    30-83
	VertRefresh  56-75
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "DefaultRefresh"     	# [<bool>]
        #Option     "ModeSetClearScreen" 	# [<bool>]
	Identifier  "HD4870"
	Driver      "radeonhd"
	VendorName  "ATI Technologies Inc"
	BoardName   "RV770 [Radeon HD 4870]"
	BusID       "PCI:1:0:0"
EndSection

Section "Screen"
	Identifier "MyScreen"
	Device     "HD4870"
	DefaultDepth	24
EndSection
Reply With Quote
  #2   (View Single Post)  
Old 31st January 2009
adamk adamk is offline
Spam Deminer
 
Join Date: May 2008
Posts: 250
Thanked 5 Times in 8 Posts
Default

We would really need to see the Xorg.0.log file from when you used that xorg.conf file. Instead, you gave us the Xorg.0.log file from when you didn't use an xorg.conf file at all :-)

In the future, also, please use a service like http://pastebin.com/ rather than a site that bombards users with ads and popups.

Adam
Reply With Quote
  #3   (View Single Post)  
Old 31st January 2009
DraconianTimes's Avatar
DraconianTimes DraconianTimes is offline
Security Geek
 
Join Date: May 2008
Location: United Kingdom
Posts: 37
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by adamk View Post
We would really need to see the Xorg.0.log file from when you used that xorg.conf file. Instead, you gave us the Xorg.0.log file from when you didn't use an xorg.conf file at all :-)

In the future, also, please use a service like http://pastebin.com/ rather than a site that bombards users with ads and popups.

Adam
Thanks for the link to pastebin, that's really useful. I've grabbed the log from when I had the xorg.conf enabled, have dumped it here
Reply With Quote
  #4   (View Single Post)  
Old 31st January 2009
adamk adamk is offline
Spam Deminer
 
Join Date: May 2008
Posts: 250
Thanked 5 Times in 8 Posts
Default

You are currently using radeonhd 1.2.1 which just doesn't support your GPU. According to the X.Org radeonhd wiki page (http://wiki.x.org/wiki/radeonhd), RV770 support was introduced in 1.2.2. If possible, I would suggest upgrading the driver.

Adam
Reply With Quote
  #5   (View Single Post)  
Old 31st January 2009
DraconianTimes's Avatar
DraconianTimes DraconianTimes is offline
Security Geek
 
Join Date: May 2008
Location: United Kingdom
Posts: 37
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by adamk View Post
You are currently using radeonhd 1.2.1 which just doesn't support your GPU. According to the X.Org radeonhd wiki page (http://wiki.x.org/wiki/radeonhd), RV770 support was introduced in 1.2.2. If possible, I would suggest upgrading the driver.

Adam
Cheers, will see about getting the driver updated and try again...
Reply With Quote
  #6   (View Single Post)  
Old 4th February 2009
DraconianTimes's Avatar
DraconianTimes DraconianTimes is offline
Security Geek
 
Join Date: May 2008
Location: United Kingdom
Posts: 37
Thanked 2 Times in 2 Posts
Default UPDATE 2009-02-04 2130Z

Have now got it all working! Some very kind help from Alan Coopersmith at Sun got me sorted out after getting stuck with compiling radeonhd on amd64. For reference, the solution can be found here
Reply With Quote
  #7   (View Single Post)  
Old 4th February 2009
adamk adamk is offline
Spam Deminer
 
Join Date: May 2008
Posts: 250
Thanked 5 Times in 8 Posts
Default

Did you get your dual monitors to work properly when X starts up? This is a pretty good wiki on xrandr 1.2, and gives a good example on modifying xorg.conf to do what you want:

http://wiki.debian.org/XStrikeForce/HowToRandR12

Adam
Reply With Quote
  #8   (View Single Post)  
Old 5th February 2009
DraconianTimes's Avatar
DraconianTimes DraconianTimes is offline
Security Geek
 
Join Date: May 2008
Location: United Kingdom
Posts: 37
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by adamk View Post
Did you get your dual monitors to work properly when X starts up? This is a pretty good wiki on xrandr 1.2, and gives a good example on modifying xorg.conf to do what you want:

http://wiki.debian.org/XStrikeForce/HowToRandR12

Adam
I have an xorg.conf which mirrors the login screen, then a
shell script (run on login) which calls xrandr to span the two monitors.

I will post copies of both when I get home tonight.
Reply With Quote
  #9   (View Single Post)  
Old 5th February 2009
DraconianTimes's Avatar
DraconianTimes DraconianTimes is offline
Security Geek
 
Join Date: May 2008
Location: United Kingdom
Posts: 37
Thanked 2 Times in 2 Posts
Default

As promised, here are the two configuration files:

/etc/X11/xorg.conf
Code:
Section "Monitor"
        Identifier   "DELL2408_R"
EndSection

Section "Monitor"
        Identifier   "DELL2408_L"
        Option       "LeftOf" "DVI-I_1/digital"
EndSection

Section "Device"
	Identifier  "HD4870"
	Driver      "radeonhd"
	VendorName  "ATI Technologies Inc"
	BoardName   "RV770 [Radeon HD 4870]"
        BusID       "PCI:1:0:0"
        Option      "DVI-I_1/digital" "DELL2408_R"
        Option      "DVI-I_2/digital" "DELL2408_L"
EndSection

Section "Screen"
        Identifier "MyScreen"
        Device     "HD4870"
        DefaultDepth     24
	SubSection "Display"
		Depth	24
		Virtual	3840 1200
        EndSubSection
EndSection
dual screen startup script
Code:
#!/bin/sh
xrandr --output DVI-I_1/digital --right-of DVI-I_2/digital
Reply With Quote
Old 8th February 2009
roundkat roundkat is offline
Shell Scout
 
Join Date: May 2008
Posts: 107
Thanked 1 Time in 1 Post
Default

I just went through a similar issue with 2 19" Dell monitors..
My work box is a Dell OptiPlex 755 (IIRC) with one of those
Funky ATI 2400 cards with the cheesy dongle..

The PC guys had a EVGA 8600 GTS that I swapped out and since
OpenSolaris seems to have better support for NVidia, it was
dead Simple..

Thx for posting the xorg.conf..

rk
__________________
All posts sent on ReCycled Electrons...
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2 Video Cards, 2 Monitors Braveheart_BSD FreeBSD General 3 23rd July 2008 11:55 AM
radeonHD support chavez243 FreeBSD General 6 13th May 2008 09:24 AM


All times are GMT. The time now is 03:07 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick