DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 12th May 2008
pcfxer pcfxer is offline
Port Guard
 
Join Date: May 2008
Location: Ottawa, Ontario, Canada
Posts: 14
Thanked 0 Times in 0 Posts
Default Samba NOT STARTING

Hello all,

I have been having some "fun" with NFS and when that didn't work I resorted to my "ten minute install"-Samba. Guess what? It's been more like three hours and counting.. Anyhow, I just deinstall cleaned the port and re compiled it again. So, without any configuration Samba freezes on smbd. So Ctrl+C it and proceed to the logs

Code:
[2008/05/11 17:40:13, 0] smbd/server.c:main(944)
  smbd version 3.0.28a started.
  Copyright Andrew Tridgell and the Samba Team 1992-2008
More like, umm, not started. Okay, so I now move to configuration

Code:
workgroup = MSHOME
server string = Samba Server
hosts allow = 192.168.1. 192.168.2. 127.
dns proxy = no


[homes]
comment = Home Directories
browseable = no
writable = yes
Still doesn't start....Ctrl+C it->go to logs->same message Samba "Started"

I decide to restart it and see if it won't hang/produce different errors in the log. The result: Same message "it started"

Code:
# -- sysinstall generated deltas -- # Sat May 10 17:32:11 2008
# Created: Sat May 10 17:32:11 2008
# Enable network daemons for user convenience.
# Please make all changes to this file, not to /etc/defaults/rc.conf.
# This file now contains just the overrides from /etc/defaults/rc.conf.
#hostname="webfold.doverosx.com"
ifconfig_dc0="DHCP"
keymap="us.iso"
linux_enable="YES"
sshd_enable="YES"
apache22_enable="YES"
samba_enable="YES"
# http://bsdguides.org/guides/freebsd/security/harden.php
sendmail_enable="NO"
kern_securelevel_enable="YES"
kern_securelevel="2"
clear_tmp_enable="YES"
syslogd_flags="-sso"
icmp_drop_redirect="YES"
icmp_log_redirect="YES"
update_motd="NO"
I'm hitting the hay soon, going to let my brain work this one over as I rest for work tomorrow .

TIA,
PS,
If you're going to BSDCan I'm volunteering so scope me out and maybe we can both work this out-I pay in BEvERages.
Reply With Quote
  #2   (View Single Post)  
Old 12th May 2008
rex rex is offline
Real Name: Nikhil Rathod
Shell Scout
 
Join Date: May 2008
Location: Chicago
Posts: 114
Thanked 2 Times in 2 Posts
Default

I never had problem with samba on FreeBSD.
Here are the two links which are more then enough for basic samba installation and configuration

Samba Installation

SAmba Configuration

hope it helps.
Reply With Quote
  #3   (View Single Post)  
Old 12th May 2008
pcfxer pcfxer is offline
Port Guard
 
Join Date: May 2008
Location: Ottawa, Ontario, Canada
Posts: 14
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by rex View Post
I never had problem with samba on FreeBSD.
Here are the two links which are more then enough for basic samba installation and configuration

Samba Installation

SAmba Configuration

hope it helps.
Hello Rex, you don't happen to be a professor at Algonquin are you?

Thanks for the reply, but the issue was Apache not starting, then Samba not starting. Why? HOSTS FILE. Apache wasn't starting because it couldn't resolve my host's IPv4 address with the current hosts file configuration.

Anyhow, fixing up my hostname configuration in /etc/rc.conf and interestingly enough SAMBA started! I shall slap my wrists and expect some wrist slapping this week possibly from the man himself (Dan).

Phew, don't you just love fixing your own issues ?
Reply With Quote
  #4   (View Single Post)  
Old 12th May 2008
corey_james corey_james is offline
Uber Geek
 
Join Date: Apr 2008
Location: Brisbane, Australia
Posts: 238
Thanked 4 Times in 10 Posts
Default

may i slap you too ?
Reply With Quote
  #5   (View Single Post)  
Old 12th May 2008
pcfxer pcfxer is offline
Port Guard
 
Join Date: May 2008
Location: Ottawa, Ontario, Canada
Posts: 14
Thanked 0 Times in 0 Posts
Default

*cough* well, my hosts went to poop which is good because I fixed that and now apache is running FIIIINE, but Samba is not working anymore and I hadn't changed ANYTHING! ARGHH!

I am going to check those sites Rex...oh and Corey you can slap me if you help me with this one now lol.
Reply With Quote
  #6   (View Single Post)  
Old 12th May 2008
pcfxer pcfxer is offline
Port Guard
 
Join Date: May 2008
Location: Ottawa, Ontario, Canada
Posts: 14
Thanked 0 Times in 0 Posts
Default

1. Is anyone else running samba on FreeBSD7.0?
2. Does anyone else use samba_enable or smbd_enable in their /etc/rc.conf
I have noticed that Samba will NOT start when launched during bootup. However, it starts fine if I disable Samba from bootup and launch manually.

That makes me think this situation is a little bit beyond me and *gasp* may be a bug. Or, user error on my part....I'm going to reinstall it once more ensuring that I delete logs and temp files again.

What say you folks?
Reply With Quote
  #7   (View Single Post)  
Old 12th May 2008
corey_james corey_james is offline
Uber Geek
 
Join Date: Apr 2008
Location: Brisbane, Australia
Posts: 238
Thanked 4 Times in 10 Posts
Default

how are you launching it ?

If you use the rc script it will need a variable in rc.conf. ... to find out the variable run /usr/local/etc/rc.d/<samba_script> rcvar
Reply With Quote
  #8   (View Single Post)  
Old 12th May 2008
mtx's Avatar
mtx mtx is offline
Real Name: Valentin Bud
Fdisk Soldier
 
Join Date: May 2008
Location: RO/TM
Posts: 79
Thanked 5 Times in 3 Posts
Default

Quote:
Originally Posted by pcfxer View Post
1. Is anyone else running samba on FreeBSD7.0?
yes and it works just fine.
Code:
% uname -a
FreeBSD seth 7.0-RELEASE FreeBSD 7.0-RELEASE #3: Thu Apr  3 14:20:12 EEST 2008     root@seth:/usr/obj/usr/src/sys/SETH  i386
Code:
% smbcontrol -V
Version 3.0.28
Quote:
2. Does anyone else use samba_enable or smbd_enable in their /etc/rc.conf
yes again
Code:
% grep samba /etc/rc.conf
samba_enable="YES"
PS:
Quote:
What say you folks?
increase log level to see what really happens.

all the best,
v
__________________
Stop! think! ... the problem is somewhere between the monitor and chair...
"First they ignore you, then they laugh at you, then they fight you, then you win." Gandhi
links: spreadbsd syk

Last edited by mtx; 12th May 2008 at 07:17 AM.
Reply With Quote
  #9   (View Single Post)  
Old 12th May 2008
pcfxer pcfxer is offline
Port Guard
 
Join Date: May 2008
Location: Ottawa, Ontario, Canada
Posts: 14
Thanked 0 Times in 0 Posts
Default

Samba appears to be launching just fine now. I just need to get the shares working..I wonder if I should start a new thread for that.

Thanks for the help guys .
Reply With Quote
Old 12th May 2008
hamba hamba is offline
Fdisk Soldier
 
Join Date: Apr 2008
Posts: 71
Thanked 5 Times in 4 Posts
Default

mmm weird, I updated samba today and now I'm getting the same type of problem.

Can you please let me know how you got samba working.

Thanks
hamba
Reply With Quote
Old 13th May 2008
pcfxer pcfxer is offline
Port Guard
 
Join Date: May 2008
Location: Ottawa, Ontario, Canada
Posts: 14
Thanked 0 Times in 0 Posts
Default

This is what I've done.

cd /usr/ports/net/samba3;make deinstall clean

make deinstall will recommend deleting certain files..I did (from what I remember), rm /var/log/log.smbd;rm /var/log/log.nmbd

I then deleted all smb.confs (make don't follow my exact command as your system may differ from mine and have files called smb4 or something), rm /usr/local/etc/smb*

Then I restarted the system, updated ports (nothing pertaining to smb so far), cd /usr/ports/net/samba3;make install clean.

Corey,
I am using smbd_enable="YES" right now, do I need to set the variable in rc.conf?

Anyhow, I'm going to begin editing smb.conf to share some files-I forget how to make a public share, so we'll see how it goes .

Thanks all!
Reply With Quote
Old 13th May 2008
hamba hamba is offline
Fdisk Soldier
 
Join Date: Apr 2008
Posts: 71
Thanked 5 Times in 4 Posts
Default

I found the problem

Before the upgrade I never had to start cups, we don't use a printer on the server.
I started cups and then samba and bang it all works

The cups config is a standard install with no changes to the conf file.

So now the office is a happy place again
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Named not starting on NetBSD boot Antimidget NetBSD General 2 27th August 2009 10:57 PM
startx not starting correctly - XOrg 7.4_2 Mantazz FreeBSD Ports and Packages 1 8th July 2009 04:17 PM
ACL, Samba ACL, FTP acl da1 FreeBSD General 3 3rd April 2009 10:14 PM
Daemon Process not starting on boot map7 FreeBSD General 4 11th September 2008 04:24 PM


All times are GMT. The time now is 01:37 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick