DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 9th February 2009
shep shep is offline
ISO Quartermaster
 
Join Date: May 2008
Location: Dry and Dusty
Posts: 585
Thanked 9 Times in 9 Posts
Default Mouse works in console not Xorg

I had FreeBSD 7.0 AMD64 running on and ECS A 770M-A mobo with a ps/2 wired mouse that the kernel ID's as an intellimouse on irq 3. I recall have some trouble getting the mouse set up on the initial install.

I upgraded to 7.1 as a dual boot with BlueWhite64 linux.

My problem is that the mouse is not recognized in FreeBSD 7.1 Xorg. It works fine in BlueWhite 64 and in FreeBSD console cutting and pasting.

I also tried a different mouse that was recognized as a ps/2 mouse irq12 in the kernel and stopping moused and setting Xorg protocol to "ps/2" and device to "/dev/psm0"

Still works in everything but Xorg

Any suggestions

Thanks in advance
Reply With Quote
  #2   (View Single Post)  
Old 9th February 2009
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

You should always generate a new X configuration file, just encase default parameters change.

# Xorg -configure

If you're using the mouse daemon, aka moused(8).. directly accessing the mouse via /dev/psm0 probably isn't recommended.

Try killing the mouse daemon before using psm0 device, set the protocol to Auto; see if that helps.
Reply With Quote
  #3   (View Single Post)  
Old 9th February 2009
shep shep is offline
ISO Quartermaster
 
Join Date: May 2008
Location: Dry and Dusty
Posts: 585
Thanked 9 Times in 9 Posts
Default

Thanks for the reply. I tried rebooting with the moused in rc.conf commented out. Then generated a another xorg.conf.new and still have the problem. The mouse pointer does not move in X and <ctl><alt> <backspace> doesn't kill X. I can open another console. Google indicates there were some problems with intellimouse protocols but I get the same behaviour with a generic ps/2 mouse. I have been google to see if I can find the page that helped me sort this out 8 months age but so far no luck.
Reply With Quote
  #4   (View Single Post)  
Old 9th February 2009
BSDKaffee's Avatar
BSDKaffee BSDKaffee is offline
Real Name: Jason Hale
Coffee Addict
 
Join Date: May 2008
Location: Wintersville, Ohio
Posts: 212
Thanked 36 Times in 34 Posts
Default

Which version of Xorg is this? If it is 7.4 without HAL enabled, try adding:
Code:
Option "AllowEmptyInput" "off"
to the "ServerLayout" section of your xorg.conf.
Reply With Quote
  #5   (View Single Post)  
Old 10th February 2009
shep shep is offline
ISO Quartermaster
 
Join Date: May 2008
Location: Dry and Dusty
Posts: 585
Thanked 9 Times in 9 Posts
Default

Thanks Coffee Addict. That did the trick. Was there something I missed in the documentation? Once I get XFCE built and enable hald I assume I will need to delete that line in the xorg.conf server layout

Thanks Again!

Edit:

I enabled dbus and hald in /etc/rc.conf and setup ttys for a graphical xdm login. I removed the AllowEmptyInput Option in the "ServerLayout" and lose the mouse pointer in xdm. When I added back the "AllowEmptyInput" line to the "ServerLayout" It worked.
I do not recall finding anything about this when googling about mice freebsd and xorg. Hopefully, others having this problem will find this post

Thanks again

Last edited by shep; 10th February 2009 at 05:09 AM.
Reply With Quote
  #6   (View Single Post)  
Old 10th February 2009
BSDKaffee's Avatar
BSDKaffee BSDKaffee is offline
Real Name: Jason Hale
Coffee Addict
 
Join Date: May 2008
Location: Wintersville, Ohio
Posts: 212
Thanked 36 Times in 34 Posts
Default

Quote:
Originally Posted by shep View Post
That did the trick. Was there something I missed in the documentation?
It was in /usr/ports/UPDATING in the 20090123 entry for x11-servers/xorg-server.
Quote:
Originally Posted by shep View Post
I enabled dbus and hald in /etc/rc.conf and setup ttys for a graphical xdm login. I removed the AllowEmptyInput Option in the "ServerLayout" and lose the mouse pointer in xdm. When I added back the "AllowEmptyInput" line to the "ServerLayout" It worked.
If you didn't build x11/xorg-server with HAL support, it probably won't work without the "AllowEmptyInput" line. It doesn't for me anyways.
Reply With Quote
  #7   (View Single Post)  
Old 13th February 2009
shep shep is offline
ISO Quartermaster
 
Join Date: May 2008
Location: Dry and Dusty
Posts: 585
Thanked 9 Times in 9 Posts
Default

I glossed over it but my setup also still needs use of AllowEmptyInput.

Here is my /usr/ports/UPDATING:
Quote:
20090124:
AFFECTS: users of x11-servers/xorg-server, sysutils/hal
AUTHOR: rnoland@FreeBSD.org

sysutils/hal has been updated and should now properly detect
mice for use in Xorg. Use of AllowEmptyInput should no longer
be needed for most users and moused should now work fine.

20090123:
AFFECTS: users of x11-servers/xorg-server
AUTHOR: rnoland@FreeBSD.org

If you are using an older xorg.conf several config lines are
no longer needed and will generate warnings when X is started.
RgbPath will cause X to fail to start, remove it from your config.

Server 1.5.3 also really wants to configure its input devices
via hald. This is causing some issues with moused and
/dev/sysmouse. There are a couple of options for how to deal
with it.

1. Add Option "AllowEmptyInput" "off" to your ServerLayout section.
This will cause X to use the configured kbd, mouse, and vmmouse
sections from your xorg.conf

2. Don't use moused. If you want it to work with addon usb mice
set this in rc.conf:

Server 1.5.3 also really wants to configure its input devices
via hald. This is causing some issues with moused and
/dev/sysmouse. There are a couple of options for how to deal
with it.

1. Add Option "AllowEmptyInput" "off" to your ServerLayout section.
This will cause X to use the configured kbd, mouse, and vmmouse
sections from your xorg.conf

2. Don't use moused. If you want it to work with addon usb mice
set this in rc.conf:

moused_enable="NO"
moused_nondefault_enable="NO"

I'm working on fixing hald or the mouse driver or both.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
netbsd 5 xorg no mouse jaideep_jdof NetBSD Installation and Upgrading 16 20th October 2009 06:23 AM
Enhanced Speedstep only works for two CPU cores on FreeBSD 7.1 Android1 FreeBSD General 13 19th April 2009 08:59 PM
Skype on FreeBSD 7.1 - works very slow.. DNAeon FreeBSD General 2 27th January 2009 11:48 AM
Network connection works fine, and then... snes-addict OpenBSD General 8 20th October 2008 11:13 PM
Numeric keypad don't works on X aleunix OpenBSD Installation and Upgrading 3 15th June 2008 11:59 AM


All times are GMT. The time now is 10:25 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick