DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 5th February 2009
ccc ccc is offline
Shell Scout
 
Join Date: May 2008
Posts: 97
Thanked 0 Times in 1 Post
Default marked as IGNORE packages

hi

should I deinstall marked as IGNORE packages after portupgrade -a ?
Code:
** Listing the failed packages (-:ignored / *:skipped / !:failed)
        - security/pecl-hash (marked as IGNORE)
        - devel/pecl-json (marked as IGNORE)
        - x11-drivers/xf86-video-vga (marked as IGNORE)
        - x11-drivers/xf86-video-via (marked as IGNORE)
        * x11-drivers/xorg-drivers (xorg-drivers-7.3_2)
Reply With Quote
  #2   (View Single Post)  
Old 5th February 2009
jb_daefo jb_daefo is offline
Package Pilot
 
Join Date: May 2008
Posts: 196
Thanked 5 Times in 5 Posts
Default

grep vga /etc/X11/xorg.conf
grep via /etc/X11/xorg.conf
IF no results,
pkg_delete -f /var/db/pkg/xf86-video-vga-[number]
.................................................. .via------------
you need a driver other than those two in the xorg.conf
after the pkg_delete you can do "pkgdb -u"
Reply With Quote
  #3   (View Single Post)  
Old 5th February 2009
Carpetsmoker's Avatar
Carpetsmoker Carpetsmoker is offline
Real Name: Martin
Old man from scene 24
 
Join Date: Apr 2008
Location: Eindhoven, Netherlands
Posts: 2,051
Thanked 198 Times in 156 Posts
Default

From /usr/ports/Mk/bsd.port.mk

Code:
# IGNORE     - Package build should be skipped entirely (e.g.
#                      because of serious unfixable problems in the build,
#                      because it cannot be manually fetched, etc).  Error
#                      logs will not appear on pointyhat, so this should be
#                      used sparingly.
Code:
% cd /usr/ports/x11-drivers/xf86-video-vga
% make -V IGNORE
is marked as broken: Needs to be removed
% cd ../../devel/pecl-json/
% make -V IGNORE
cannot install: doesn't work with PHP version : 5 (Doesn't support PHP 5)
__________________
UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things.
Reply With Quote
  #4   (View Single Post)  
Old 19th February 2009
Calderon's Avatar
Calderon Calderon is offline
Real Name: Patrick Ääripää
Fdisk Soldier
 
Join Date: May 2008
Location: Finland
Posts: 57
Thanked 0 Times in 0 Posts
Default

make config in 'usr/ports/x11-drivers/xorg-drivers/' and remove these two vga/via and select the driver of your hardware. Atleast xorg will be updated then.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
packages vs ports zelut FreeBSD Ports and Packages 17 28th October 2009 08:19 AM
Can't Add Packages due to intl.4.0 jrs665 OpenBSD Packages and Ports 4 20th October 2008 10:44 AM
squidGuard port marked broken chavez243 FreeBSD Ports and Packages 0 17th September 2008 12:55 PM
Where have all the packages gone? PatrickBaer FreeBSD Ports and Packages 6 12th June 2008 11:03 PM
where all packages OpenSolaris whispersGhost Solaris 15 11th June 2008 09:55 AM


All times are GMT. The time now is 02:49 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick