DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 9th March 2009
Zmyrgel Zmyrgel is offline
Port Guard
 
Join Date: May 2008
Posts: 26
Thanked 0 Times in 0 Posts
Default Screen + utf8 not working

I'm having problems with unicode on my OpenBSD.
I've installed the ROXTerm from the ports and set the keyboard encoding to UTF-8.
I tested it with emacs 'hello-page' (run with -nw) and it displays quite a lot of the languages correctly so utf-8 seems to work on emacs and on the terminal itself so everythings OK this far.

On terminal when I type ä it displays it correctly but when I delete it I have to delete two chars. I think this is the normal behavior as OpenBSD doesn't have OS-level unicode support yet.

Then to the problem. When I run GNU screen it breaks things. When I type ä inside screen it prints "a. Also, when I close the screen it still gives "a instead of ä.

I have given following options in .screenrc:
Code:
defutf8 on
utf8 on on
I also tried to start the screen with the -U switch but nothing seems to help me.

Any suggestions how to get the screen to behave properly?
Reply With Quote
  #2   (View Single Post)  
Old 10th March 2009
gosha gosha is offline
Spam Deminer
 
Join Date: Jun 2008
Location: China
Posts: 256
Thanked 0 Times in 0 Posts
Default

Code:
On terminal when I type ä it displays it correctly but when I delete it I have to delete two chars. I think this is the normal behavior as OpenBSD doesn't have OS-level unicode support yet.
Is this in roxterm? I don't have this problem, if I type ä I will cancel it going back only once.
But I guess this does'n really help you a lot.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
No Screen during NetBSD 5.0 install shep NetBSD Installation and Upgrading 7 16th October 2009 02:54 AM
X - Virtual screen too big for memory backrow OpenBSD General 1 4th July 2009 07:22 PM
Fluxbox + Firefox = UTF8 title problem.. DNAeon FreeBSD Ports and Packages 7 10th December 2008 08:52 AM
screen casting via v4l ddekok Other BSD and UNIX/UNIX-like 2 17th July 2008 03:27 PM
How to take a screen in xfce? aleunix OpenBSD Packages and Ports 23 4th June 2008 02:54 PM


All times are GMT. The time now is 05:37 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick