DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Packages and Ports

OpenBSD Packages and Ports Installation and upgrading of packages and ports on OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 7th June 2009
dialeight dialeight is offline
New User
 
Join Date: Jun 2009
Posts: 6
Thanked 0 Times in 0 Posts
Default Apache 1.3 and PHP 5, Not Working!

Hey Everybody,

Here is my current setup:

OpenBSD 4.4
Apache 1.3 running outside chroot environment
PHP 5.2.6 installed from package, performed symlink, php5.conf is in the /var/www/conf/modules/ directory.

For some reason apache is not loading the module. When I access my phptest.php file which contains the phpinfo() function it shows up as a blank screen, but when I view source I see the PHP code. When I run apachectl configtest, it shows that it's loading it and there are no syntax errors.

I am at a loss since this is the first time working with php5 for me, I'm finally upgrading from php 4. Any help here would be appreciated.
Reply With Quote
  #2   (View Single Post)  
Old 7th June 2009
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,686
Thanked 214 Times in 189 Posts
Default

By default, the AddType for filetypes .php is commented out in /var/www/conf/httpd.conf.

Edit the file. Search for "php". Uncomment the line. Restart apache.
Reply With Quote
  #3   (View Single Post)  
Old 7th June 2009
dialeight dialeight is offline
New User
 
Join Date: Jun 2009
Posts: 6
Thanked 0 Times in 0 Posts
Default

Hey There,

Thanks for the response. I'm sorry I didn't mention that I already had done that. It was late when I posted.

I did remove the comment before:
AddType application/x-httpd-php .php

And restarted using apachectl stop and apachectl start.

Still not working.. Any other suggestions?

Thanks
Reply With Quote
  #4   (View Single Post)  
Old 7th June 2009
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,686
Thanked 214 Times in 189 Posts
Default

I don't think apachectl should be used for start; disabling chroot is done by using httpd -u, see the /etc/rc script.
Reply With Quote
  #5   (View Single Post)  
Old 7th June 2009
dialeight dialeight is offline
New User
 
Join Date: Jun 2009
Posts: 6
Thanked 0 Times in 0 Posts
Default

Chroot is disabled by using the -U flag within the /etc/rc.conf file. Should I be using the httpd command to stop and start the server?
Reply With Quote
  #6   (View Single Post)  
Old 7th June 2009
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,686
Thanked 214 Times in 189 Posts
Default

apachectl stop
httpd -u
Reply With Quote
  #7   (View Single Post)  
Old 7th June 2009
dialeight dialeight is offline
New User
 
Join Date: Jun 2009
Posts: 6
Thanked 0 Times in 0 Posts
Default

Hey,

Thanks for the responses.

Still having trouble after restarting apache using the -u option. When I load the page in the browser php is not being processed. Any other ideas?
Reply With Quote
  #8   (View Single Post)  
Old 7th June 2009
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,686
Thanked 214 Times in 189 Posts
Default

Prove to yourself that you have the correct symbolic link to the php5.conf module.

(Hint: ls -l /var/www/conf/modules)

Prove to yourself that you are using /var/www/conf/httpd.conf for your configuration, and not some other configuration file (e.g.: httpd -f).

Double check the AddType directive and the php5.conf module are correct in httpd.conf.

----
That's all I can think of.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Working with CVS? Zmyrgel OpenBSD General 15 6th October 2009 01:32 PM
Apache Randomly Stops Working plexter OpenBSD Packages and Ports 21 4th May 2009 04:41 PM
Upgrade Apache 1.3 mod_ssl to Apache 2.2 beandip FreeBSD Ports and Packages 11 26th March 2009 09:12 PM
x11 forwarding over ssh not working kasse OpenBSD General 14 23rd December 2008 02:21 PM
Apache with php stopped working after upgrade map7 FreeBSD Ports and Packages 7 7th December 2008 10:39 PM


All times are GMT. The time now is 04:05 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick