DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 20th May 2009
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default Amarok post 7.2 update

I've upgrade to 7.2 from 7.1.

Amarok wasn't functioning post install, pkg_add returned the following:
Code:
pkg_add: package 'amarok-1.4.10_3' or its older version already installed
So I've tried pkg_deinstall to clean out the old version, but no success:
Code:
[Updating the pkgdb <format:bdb_btree> in /var/db/pkg ... - 782 packages found (-0 +1) . done]
[Updating the portsdb <format:bdb_btree> in /usr/ports ... - 20214 port entries found .........1000.........2000.........3000.........4000.........5000.........6000.........7000.........8000.........9000.........10000.........11000.........12000.........13000.........14000.........15000.........16000.........17000.........18000.........19000.........20000.. ..... done]
Stale dependency: amarok-1.4.7 --> gtk-2.12.1_1 -- manually run 'pkgdb -F' to fix, or specify -O to force.
I've run portsnap to update the ports tree, but am feeling particularly dim about all this...

I want my music back!
Reply With Quote
  #2   (View Single Post)  
Old 20th May 2009
TerryP's Avatar
TerryP TerryP is offline
Arp Constable
 
Join Date: May 2008
Location: USofA
Posts: 1,547
Thanked 112 Times in 104 Posts
Default

uninstall old amarok, install new amarok, and tell pkgdb the magic word as directed.
__________________
My Journal

Thou shalt check the array bounds of all strings (indeed, all arrays), for surely where thou typest ``foo'' someone someday shall type ``supercalifragilisticexpialidocious''.
Reply With Quote
  #3   (View Single Post)  
Old 20th May 2009
phoenix's Avatar
phoenix phoenix is offline
Risen from the ashes
 
Join Date: May 2008
Posts: 699
Thanked 90 Times in 81 Posts
Default

Sounds like you have the KDE3 version of Amarok installed (1.3.x).

The packages for FreeBSD 7.2 are built around KDE4, which would be Amarok 2.0.x.

So, you either have to continue using amarok 1.3, or remove it (pkg_delete -xi amarok) and install the amarok 2.0.x package (pkg_add -r amarok). Which you do depends on whether or not you want KDE4.
__________________
Freddie

Help for FreeBSD: Handbook, FAQ, man pages, mailing lists.
Reply With Quote
  #4   (View Single Post)  
Old 21st May 2009
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

I think it may be the KDE 3 version (certainly I'm still running 3 as I'm jumpy about 4). However, the version was 1.4.7.

I believe I must be missing something altogether quite obvious though - I've since posting this carried out pkg_delete -O on amarok, then a pkg_add -r and it still doesn't seem to be fetching v 2.

I'm going to have to go get my head round updating the pkg_db
Reply With Quote
  #5   (View Single Post)  
Old 25th May 2009
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

This really is an absolute state on my machine. I can't get the KDE 3 version to install at all. I've had to remove the openldap client and reinstall and can't get Amarok either via ports or packages. I'll put up full data later.
Reply With Quote
  #6   (View Single Post)  
Old 27th May 2009
fbsduser fbsduser is offline
Shell Scout
 
Join Date: Aug 2008
Posts: 103
Thanked 4 Times in 4 Posts
Default

Code:
Stale dependency: amarok-1.4.7 --> gtk-2.12.1_1 -- manually run 'pkgdb -F' to fix, or specify -O to force.
Hmm. Dunno if it's just me but, isn't it a bit odd that the amarok package haves gtk2 as a dependency (amarok uses the QT libraries, not the gtk2 ones AFAIK)?
Reply With Quote
  #7   (View Single Post)  
Old 29th May 2009
BSDKaffee's Avatar
BSDKaffee BSDKaffee is offline
Real Name: Jason Hale
Coffee Addict
 
Join Date: May 2008
Location: Wintersville, Ohio
Posts: 212
Thanked 36 Times in 34 Posts
Default

Quote:
Originally Posted by fbsduser View Post
Code:
Stale dependency: amarok-1.4.7 --> gtk-2.12.1_1 -- manually run 'pkgdb -F' to fix, or specify -O to force.
Hmm. Dunno if it's just me but, isn't it a bit odd that the amarok package haves gtk2 as a dependency (amarok uses the QT libraries, not the gtk2 ones AFAIK)?
It is an indirect dependency. By default, amarok depends on audio/libgpod which depends on gtk2.
Reply With Quote
  #8   (View Single Post)  
Old 29th May 2009
fbsduser fbsduser is offline
Shell Scout
 
Join Date: Aug 2008
Posts: 103
Thanked 4 Times in 4 Posts
Default

Quote:
Originally Posted by BSDKaffee View Post
It is an indirect dependency. By default, amarok depends on audio/libgpod which depends on gtk2.
Learned something new.
Reply With Quote
  #9   (View Single Post)  
Old 18th June 2009
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

I ran pkgdb -Fa, then tried installing the port using make install clean. However, I'm getting a lot of warning output now that my dependencies are the wrong versions:

Code:
max@~: sudo pkg_add -r amarok
Password:
Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-7.2-release/Latest/amarok.tbz... Done.
pkg_add: warning: package 'amarok-1.4.10_3' requires 'xextproto-7.0.5', but 'xextproto-7.0.2' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'randrproto-1.3.0', but 'randrproto-1.2.1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'printproto-1.0.4', but 'printproto-1.0.3' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'inputproto-1.5.0', but 'inputproto-1.4.2.1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'dmidecode-2.10', but 'dmidecode-2.9' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libdvdread-4.1.3', but 'libdvdread-0.9.7_3' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'pciids-20090224', but 'pciids-20081012' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'ruby-1.8.7.72_1,1', but 'ruby-1.8.6.287,1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'python25-2.5.4_1', but 'python25-2.5.2_3' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'xcb-proto-1.4', but 'xcb-proto-1.2' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'perl-5.8.9_2', but 'perl-5.8.8_1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'png-1.2.35', but 'png-1.2.33' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'lcms-1.18,1', but 'lcms-1.17,1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'tiff-3.8.2_3', but 'tiff-3.8.2_2' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'jasper-1.900.1_7', but 'jasper-1.900.1_6' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'pixman-0.15.2', but 'pixman-0.10.0_2' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'freetype2-2.3.9_1', but 'freetype2-2.3.7' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'fontconfig-2.6.0,1', but 'fontconfig-2.5.0,1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'xproto-7.0.15', but 'xproto-7.0.10_1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'mkfontscale-1.0.6', but 'mkfontscale-1.0.3' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'mkfontdir-1.0.4', but 'mkfontdir-1.0.3_1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'xorg-fonts-truetype-7.4', but 'xorg-fonts-truetype-7.3' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libSM-1.1.0_1,1', but 'libSM-1.0.3_1,1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libXau-1.0.4', but 'libXau-1.0.3_2' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'pcre-7.9', but 'pcre-7.8' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libvolume_id-0.81.1', but 'libvolume_id-0.81.0' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libdrm-2.4.7', but 'libdrm-2.3.1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libxcb-1.2_1', but 'libxcb-1.1.90.1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'xcb-util-0.3.3', but 'xcb-util-0.2.1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libX11-1.2.1,1', but 'libX11-1.1.3_1,1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libxkbfile-1.0.5', but 'libxkbfile-1.0.4' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libXext-1.0.5,1', but 'libXext-1.0.3,1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libXv-1.0.4,1', but 'libXv-1.0.3_1,1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libXxf86vm-1.0.2', but 'libXxf86vm-1.0.1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libXi-1.2.1,1', but 'libXi-1.1.3,1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libXinerama-1.0.3,1', but 'libXinerama-1.0.2,1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libGL-7.4_1', but 'libGL-7.0.3' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libGLU-7.4_1', but 'libGLU-7.0.3' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libXmu-1.0.4,1', but 'libXmu-1.0.3,1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libXaw-1.0.5_1,1', but 'libXaw-1.0.4_1,1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libXrandr-1.3.0', but 'libXrandr-1.2.2_1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'cairo-1.8.6_1,1', but 'cairo-1.6.4_3,1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'sdl-1.2.13_3,2', but 'sdl-1.2.13_2,2' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'samba-libsmbclient-3.0.34_1', but 'samba-libsmbclient-3.0.32_1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libxml2-2.7.3', but 'libxml2-2.6.32_2' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libxslt-1.1.24_2', but 'libxslt-1.1.24_1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'dbus-1.2.4.4', but 'dbus-1.2.1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libidn-1.13', but 'libidn-1.9' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libgpg-error-1.7', but 'libgpg-error-1.6_1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libgcrypt-1.4.4', but 'libgcrypt-1.4.1_1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'gnutls-2.6.4', but 'gnutls-2.4.2_1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'cups-base-1.3.9_3', but 'cups-base-1.3.9' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'glib-2.20.1', but 'glib-2.16.5' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'gamin-0.1.10_1', but 'gamin-0.1.9_2' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'gio-fam-backend-2.20.1', but 'gio-fam-backend-2.16.5' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'pango-1.24.0_2', but 'pango-1.20.5' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'shared-mime-info-0.60', but 'shared-mime-info-0.51' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'dbus-glib-0.80', but 'dbus-glib-0.76' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'policykit-0.9_4', but 'policykit-0.9_1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'consolekit-0.3.0_6', but 'consolekit-0.2.10_3' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'hal-0.5.11_23', but 'hal-0.5.11_1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'wavpack-4.50.1', but 'wavpack-4.41.0' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'nas-1.9.1_3', but 'nas-1.9.1_2' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'qt-3.3.8_9', but 'qt-copy-3.3.8_9' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libvorbis-1.2.0_3,3', but 'libvorbis-1.2.0_2,3' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libtheora-1.0', but 'libtheora-1.0.b2' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libofa-0.9.3_2', but 'libofa-0.9.3_1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libmtp-0.3.1_2', but 'libmtp-0.2.6.1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libsndfile-1.0.19', but 'libsndfile-1.0.17_2' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libsamplerate-0.1.7', but 'libsamplerate-0.1.4' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'jackit-0.116.2', but 'jackit-0.109.2_1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'libxine-1.1.16.2_1', but 'libxine-1.1.15_1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'arts-1.5.10_1,1', but 'arts-1.5.10,1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'kdebase-3.5.10_2', but 'kdebase-3.5.10_1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'atk-1.26.0', but 'atk-1.22.0_1' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'gtk-2.16.1', but 'gail-1.22.3' is installed
pkg_add: warning: package 'amarok-1.4.10_3' requires 'gtk-2.16.1', but 'gtk-2.12.11_1' is installed
Have I missed a point with the pkgdb?
Reply With Quote
Old 18th June 2009
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default



Trying to add it via the package again - was working on too many things at once there!
Reply With Quote
Old 23rd June 2009
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

I used portmanager and updated all my ports. However, I still get an error on startup:

Code:
max@~: amarok
Amarok: [Loader] Starting amarokapp..
Amarok: [Loader] Don't run gdb, valgrind, etc. against this binary! Use amarokapp.
/libexec/ld-elf.so.1: Shared object "libcurl.so.4" not found, required by "libtunepimp.so.5"
Reply With Quote
Old 23rd June 2009
Carpetsmoker's Avatar
Carpetsmoker Carpetsmoker is offline
Real Name: Martin
Old man from scene 24
 
Join Date: Apr 2008
Location: Eindhoven, Netherlands
Posts: 2,051
Thanked 198 Times in 156 Posts
Default

You should have libcurl.so.5, the bump from 4 to 5 happened on Jan 23rd 2009 -- Quite some time ago.

I don't know why this has happened, if you reinstalled all ports this should not have happened(tm).

Try rebuilding audio/libtunepimp, this port hasn't seen any updates since a year so this should not cause any problems.
# cd /usr/ports/audio/libtunepimp/ && make clean build deinstall install clean
__________________
UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things.
Reply With Quote
Old 23rd June 2009
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

That got it. Must have destroyed my libcurl instance somehow. Skill I imagine.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot update with CVS guitarscn OpenBSD Installation and Upgrading 3 7th September 2009 11:12 PM
amarok doesn't compile nico_h FreeBSD Ports and Packages 1 21st December 2008 03:38 AM
How do you update ports? disappearedng FreeBSD General 6 8th November 2008 05:59 AM
Eclipse can't update ? disappearedng FreeBSD General 1 7th November 2008 01:03 AM
Update from 6.1 to 6.3 did nothing? alanthing FreeBSD Installation and Upgrading 4 8th June 2008 02:28 PM


All times are GMT. The time now is 05:02 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick