DaemonForums  

Go Back   DaemonForums > NetBSD > NetBSD Installation and Upgrading

NetBSD Installation and Upgrading Have trouble getting NetBSD on your toaster?

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 25th May 2009
Mr-Biscuit Mr-Biscuit is offline
Banned
 
Join Date: May 2008
Posts: 272
Thanked 0 Times in 0 Posts
Default Startx executes as root, "startx:not found" as user

I am not even able to start the X server as root through su.

Using /usr/X11R7/bin/startx produces a repeat of "xauth: not found."

Directory /usr/X11R6/bin is empty.


How do I link $USER to xauth?

Copying .profile from root to user does not work.
Reply With Quote
  #2   (View Single Post)  
Old 25th May 2009
Mr-Biscuit Mr-Biscuit is offline
Banned
 
Join Date: May 2008
Posts: 272
Thanked 0 Times in 0 Posts
Default

Okay
I've changed the shell and now root's information comes up.
X tries to start but hangs due to permissions.
Reply With Quote
  #3   (View Single Post)  
Old 25th May 2009
Mr-Biscuit Mr-Biscuit is offline
Banned
 
Join Date: May 2008
Posts: 272
Thanked 0 Times in 0 Posts
Default

It starts after a delay.

Anyway, apologies and....
nevermind
Reply With Quote
  #4   (View Single Post)  
Old 25th May 2009
IdOp's Avatar
IdOp IdOp is offline
Too dumb for a smartphone
 
Join Date: May 2008
Location: twisting on the daemon's fork(2)
Posts: 563
Thanked 14 Times in 13 Posts
Default

Not sure I had the exact same problem, but similar. Part of the solution was to make sure X11R7 went into the appropriate PATH components rather than X11R6.

HTH
Reply With Quote
  #5   (View Single Post)  
Old 27th May 2009
Zmyrgel Zmyrgel is offline
Port Guard
 
Join Date: May 2008
Posts: 26
Thanked 0 Times in 0 Posts
Default

Yeah, I had similar issue and fixed it by copying the PATH contents from root user to my regular user.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fixed "xinit" after _7 _8, "how" here in case anyones' "X" breaks... using "nvidia" jb_daefo Guides 0 5th October 2009 09:31 PM
log in to console and startx in os x questionguy Other BSD and UNIX/UNIX-like 11 25th August 2009 05:27 AM
"Thanks" and "Edit Tags". diw Feedback and Suggestions 2 29th March 2009 12:06 AM
Startx fails disappearedng FreeBSD General 11 19th July 2008 09:32 AM
User startx error . bsdnewbie999 OpenBSD General 3 19th June 2008 02:08 AM


All times are GMT. The time now is 09:53 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick