DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 14th July 2009
gosha gosha is offline
Spam Deminer
 
Join Date: Jun 2008
Location: China
Posts: 256
Thanked 0 Times in 0 Posts
Default please help me understand wpa settings

I'm trying to set up wpa wireless, but I guess I'm missing some basics.
In Wisdows Vista, I simply pasted the 63 ascii char password into the wireless setting windows, and it works.
I know, unix is different.
Now, if I paste the password into hostname.if it does not work, if I try to convert it to hexadecimal with wpa-psk it does not do it, I guess because there are all sorts of characters in the password (but then, why are punctuation marks not allowed?). If I try to use a password with only letters it gives me the hexadecimal, but then it does not work either (of course I've put the new password into my router.

What am I doing wrong?
My actual hostname.iwn0 looks like this (this time with the password converted to hex:
Code:
inet 192.168.1.XXX nwid my-ssid wpa wpapsk my-ssid 0xalotofnumbers
Reply With Quote
  #2   (View Single Post)  
Old 14th July 2009
gosha gosha is offline
Spam Deminer
 
Join Date: Jun 2008
Location: China
Posts: 256
Thanked 0 Times in 0 Posts
Default


never mind, I've managed to make it work with the help of this discussion:
http://www.daemonforums.org/showthre...tname+wireless

I did not know you have to tell the script to bring up the network card, because you don't need that with ehternet.

And you need to put double quotes around the passphrase if you have extra characters
it is not specified in the manpages I guess because this should be some very basic unix knowledge...
stupid me
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Network settings guitarscn OpenBSD General 13 18th February 2009 01:45 AM
How understand someone connect to my BOX with VNC mfaridi OpenBSD Security 8 21st November 2008 12:24 AM
where are start up settings on KDE Never mind i found them whispersGhost Solaris 2 12th June 2008 09:30 PM


All times are GMT. The time now is 03:40 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick