DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 21st July 2009
clevershark clevershark is offline
Port Guard
 
Join Date: May 2008
Posts: 11
Thanked 0 Times in 0 Posts
Unhappy Problem with latest php5 from ports

So I decided to do a little maintenance on my system today and upgrade a few outdated ports... what a brilliant idea that wasn't.

I attempted to use portmaster to upgrade my php5 packages, and the whole thing went south on me with no hint of what's actually wrong. Basically the whole upgrade breaks when it gets to the part where it tries to install php-5.2.10 after building it. Here are the last lines before the dreaded "error code 1" messages:


--------------------
Installing PHP SAPI module: apache2handler
/usr/local/share/apache22/build/instdso.sh SH_LIBTOOL='/usr/local/build-1/libtool' libphp5.la /usr/local/libexec/apache22
/usr/local/build-1/libtool --mode=install cp libphp5.la /usr/local/libexec/apache22/
/usr/local/share/apache22/build/instdso.sh: /usr/local/build-1/libtool: not found
apxs:Error: Command failed with rc=8323072
--------------------

To give an extra level of difficulty, this appears to have occurred after the old php5 port was removed, so I can no longer use portversion to verify any of the other packages (due to missing dependencies for a bunch of packages). And it doesn't appear that there is a backup of the previous php version (5.2.8 I think). I've done a portupgrade on libtool already so I know it is in fact there. This box has been up and running for years now and has gone through all sorts of software upgrades without this sort of problem cropping up. And yes I did make sure that php5-pcre was not installed either as a package or a port.

Has anyone else been coming up against this issue? is it just a matter of apxs looking for libtool in the nonexistent /usr/local/build-1/ directory (?), and how do I steer it in the right direction (/usr/local/bin)?
Reply With Quote
  #2   (View Single Post)  
Old 22nd July 2009
clevershark clevershark is offline
Port Guard
 
Join Date: May 2008
Posts: 11
Thanked 0 Times in 0 Posts
Default A quick and easy fix

I ended up fixing this by adding a symlink, /usr/local/build-1, that points to /usr/local/bin. However it's still quite bizarre and there's no reason why this should even come up.
Reply With Quote
Reply

Tags
php5, portmaster, portupgrade

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with x11/gnome+libcaca in ports Kilo1 OpenBSD Packages and Ports 3 2nd August 2008 12:58 AM
PHP5 inst. from Ports jaymax FreeBSD Ports and Packages 1 23rd June 2008 01:52 AM
Problem with upgrading php5-pcre and php5-mysql KernelPanic FreeBSD Ports and Packages 6 16th June 2008 10:00 PM
openbsd4.3 - problem compile php5 blackyzero OpenBSD General 3 27th May 2008 06:24 PM
Problem installing PHP5 DrKrall OpenBSD Packages and Ports 8 23rd May 2008 12:10 AM


All times are GMT. The time now is 01:10 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick