DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Packages and Ports

OpenBSD Packages and Ports Installation and upgrading of packages and ports on OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 3rd September 2009
Mr-Biscuit Mr-Biscuit is offline
Banned
 
Join Date: May 2008
Posts: 272
Thanked 0 Times in 0 Posts
Default OpenBSD on qemu: opera install problems

i have an *G dedicated image to OpenBSD i386 4.5, desktop is installed, linux compat=1. I am trying to install opera and it breaks with desktop-file-utils, glib2 under the infrastructure of the bsd.mk file. The installation is searching for libglib2. In the beginning it makes a fake installation.
How do I resolve this?
errors 71, 1, and 2.
Reply With Quote
  #2   (View Single Post)  
Old 3rd September 2009
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,905
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by Mr-Biscuit View Post
I am trying to install opera and it breaks with desktop-file-utils, glib2 under the infrastructure of the bsd.mk file. The installation is searching for libglib2.
  • Is there a reason why you are compiling versus using pre-compiled packages? Unless you have modified the Makefile, there is no difference between the packages found on the mirrors when compared to what you will be creating through local compilation.
  • While I do not run qemu, wierd build errors are frequently the result of mismatching the version of the ports tree installed to the version of the installed operating system. eg. If you have OpenBSD 4.5-release installed, downloading the ports tree for -current may very well generate the odd messages described. More information can be found in Section 15.4.1 of the FAQ:

    http://openbsd.org/faq/faq15.html#NoFun
Reply With Quote
  #3   (View Single Post)  
Old 3rd September 2009
jggimi's Avatar
jggimi jggimi is online now
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,810
Thanked 214 Times in 189 Posts
Default

Opera is a port-only, due to licensing. It is also a "binary" port, so there is no compilation. That's because its a closed source product.

I agree with Ocicat's assumption of an out-of-sync ports tree. The version of Opera synced with 4.5 is 9.63. The version synced to -current (and 4.6 next month) is 9.64.
Reply With Quote
  #4   (View Single Post)  
Old 3rd September 2009
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,905
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by jggimi View Post
Opera is a port-only, due to licensing. It is also a "binary" port, so there is no compilation. That's because its a closed source product.
Ah, you are so right. This is even mentioned in Section 13.13:

http://openbsd.org/faq/faq13.html#flashplugin
Reply With Quote
  #5   (View Single Post)  
Old 6th September 2009
Mr-Biscuit Mr-Biscuit is offline
Banned
 
Join Date: May 2008
Posts: 272
Thanked 0 Times in 0 Posts
Default

I don't know if I did the right thing, but...
I went into the /usr/ports/infrastructure/mk/ folder and edited the bsd make file to have Yes where a few No defaults were. I noticed that PKG_ADD by ftp and PK_UPGRADE were disabled. The port currently building is kde4 and the common error is in the ports makefile. I didn't bother going through the entire make file to see if any other options were defaulted to No.
I'm looking at the problem again and it seems to be the configuration after fetching that goes awry. Any suggestions as to how I can make it work?
Reply With Quote
  #6   (View Single Post)  
Old 7th September 2009
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,905
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by Mr-Biscuit View Post
The port currently building is kde4...
  • KDE4 is present in the ports tree such that the developers can work on a common code base. It is a work in progress, & as such is not installable. See the following from the ports@ archives for similar information:

    http://marc.info/?l=openbsd-ports&m=124547836427512&w=2
  • It is still not clear from any information presented whether you have a compatible version of the ports tree installed. If you are running OpenBSD 4.5-release, you can only use the ports tree:
    • which is found on the official 4.5 CD set, or...
    • download pub/OpenBSD/4.5/ports.tar.gz found on all the official mirror sites.
    If you downloaded pub/OpenBSD/snapshots/ports.tar.gz, you downloaded an incompatible version of the ports tree for OpenBSD 4.5-release. This is a mismatch of versions & is not supported by the Project. See the previously provided link for more information.
Reply With Quote
  #7   (View Single Post)  
Old 7th September 2009
jggimi's Avatar
jggimi jggimi is online now
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,810
Thanked 214 Times in 189 Posts
Default

Quote:
Originally Posted by Mr-Biscuit View Post
I don't know if I did the right thing, but...
I went into the /usr/ports/infrastructure/mk/ folder and edited the bsd make file...
This is the "wrong" thing.

When you update your /usr/ports tree for 4.6, 4.7, or, perhaps -current, you will lose your changes.

The best practice for such local modifications is to create /etc/mk.conf and place your environment variable settings there.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Opera Port - conflicting pkgs in "make install" IronForge OpenBSD Packages and Ports 5 29th October 2009 05:10 AM
New User - Ports Install and GNOME Pkg problems IronForge OpenBSD Packages and Ports 9 14th July 2009 08:34 PM
Remote OpenBSD ssh-based install problems artix OpenBSD Installation and Upgrading 7 13th March 2009 08:52 PM
Can't install opera from ports erno FreeBSD Ports and Packages 2 25th June 2008 10:25 AM
OBSD 4.3 Customize site43 & install.site problems gamaliel OpenBSD Installation and Upgrading 7 3rd June 2008 03:25 PM


All times are GMT. The time now is 02:06 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick