DaemonForums  

Go Back   DaemonForums > NetBSD > NetBSD Installation and Upgrading

NetBSD Installation and Upgrading Have trouble getting NetBSD on your toaster?

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 13th September 2009
jaideep_jdof jaideep_jdof is offline
Port Guard
 
Join Date: Nov 2008
Posts: 45
Thanked 0 Times in 0 Posts
Default netbsd 5 xorg no mouse[Solved]

I have done a complete installation (all sets) of netbsd 5 64 bit on my laptop. I have installed gnome on my laptop using the pkgsrc gnome meta pkg. Then I installed modular xorg using this wiki http://wiki.netbsd.se/How_to_install_modular_Xorg. I then create a config file for X using the command.
Code:
X -configure
and moved the config file to /etc/X11/. I also added dbus, hal and gdm to rc.conf. When i rebooted gdm didn't start so I removed xorg.conf and reboot, this time gdm started but mouse wasn't working . So I edited the xorg.conf and changed the mouse device entry to /dev/wsmouse and protocol to wsmouse and rebooted but gdm didn't start this time. So please help me figure out how to set xorg conf properly. I am unable to add dumps of my config files as I am using fedora live cd to write this post.

When I added wsmoused to rc.conf, the mouse is working in the console but not in xorg.

Last edited by jaideep_jdof; 17th September 2009 at 03:48 PM.
Reply With Quote
  #2   (View Single Post)  
Old 13th September 2009
Tom Tom is offline
Port Guard
 
Join Date: Aug 2008
Location: Poland
Posts: 22
Thanked 0 Times in 0 Posts
Default

Since 5.0 release there is no need for installing Xorg from pkgsrc, becouse it's in base installation. If you really had installed ALL sets, you probably have parallel two version of xorg, first from installation and second from pkgsrc. Maybe this is the problem?

Try also running gnome without gdm. Add
Code:
exec gnome-session
to your .xinitrc file in home directory and try with [B[startx[/B]. If it works, maybe we will be able to resolve at least one problem, with working mouse.

Best Regards,
Tom
Reply With Quote
  #3   (View Single Post)  
Old 13th September 2009
IdOp's Avatar
IdOp IdOp is offline
Too dumb for a smartphone
 
Join Date: May 2008
Location: twisting on the daemon's fork(2)
Posts: 563
Thanked 14 Times in 13 Posts
Default

My suggestion to add on is to begin by not using wsmoused, for two reasons:

1) It's only used for the console, so if you want to boot into gdm or some such, it's not needed; but the main reason is:

2) If wsmoused is not configured just right it can cause big problems with X. With prior versions of NetBSD it would lock up my computer. (Related to this configuration you need to look at the xconsole parameter in wsmoused.conf(5).)

So I would not put "wsmoused=YES" in /etc/rc.conf at this stage. Once you have the GUI working, you could return to it and see if you can make it work compatibly.
Reply With Quote
  #4   (View Single Post)  
Old 14th September 2009
jaideep_jdof jaideep_jdof is offline
Port Guard
 
Join Date: Nov 2008
Posts: 45
Thanked 0 Times in 0 Posts
Default

I have disabled wsmoused from my rc.conf and added gnome-session to my .xinitrc, gnome desktop starts using startx but mouse is not working. Is there a way to uninstall the xset which i installed during system installation. Do I have to reinstall netbsd, I dont want to recompile gnome again. Is there a binary package for the gnome meta pkg for amd64. I searched on this ftp ftp://ftp.netbsd.org/pub/pkgsrc/pack...amd64/5.0/All/ but there is no such package, there is one for i386.
Reply With Quote
  #5   (View Single Post)  
Old 14th September 2009
Tom Tom is offline
Port Guard
 
Join Date: Aug 2008
Location: Poland
Posts: 22
Thanked 0 Times in 0 Posts
Default

I hope it will be helpful:

http://www.daemonforums.org/showthread.php?t=2999
Reply With Quote
  #6   (View Single Post)  
Old 14th September 2009
jaideep_jdof jaideep_jdof is offline
Port Guard
 
Join Date: Nov 2008
Posts: 45
Thanked 0 Times in 0 Posts
Default

So if I re install netbsd and unselect xset during installation, and then install xorg using http://wiki.netbsd.se/How_to_install_modular_Xorg, the mouse should work theme right?
Reply With Quote
  #7   (View Single Post)  
Old 14th September 2009
s0xxx's Avatar
s0xxx s0xxx is offline
Package Pilot
 
Join Date: May 2008
Posts: 194
Thanked 47 Times in 22 Posts
Default

First, you don't need to reinstall NetBSD. I would suggest removing Xorg you installed through pkgsrc by using pkg_delete. There is nothing wrong with the one that came with base OS. I say that because when you come to update the system leter it would be much easier to update Xorg that way.

Create simple xorg.conf and try starting Xorg. Then note down the errors (if any) it spits on screen, or look for errors in /var/log/Xorg.0.log or maybe /var/log/messages.

I would also suggest you copy the config files to a USB disk, then using Fedora you could give them here.
__________________
The best way to learn UNIX is to play with it, and the harder you play, the more you learn.
If you play hard enough, you'll break something for sure, and having to fix a badly broken system is arguably the fastest way of all to learn. -Michael Lucas, AbsoluteBSD
Reply With Quote
  #8   (View Single Post)  
Old 14th September 2009
jaideep_jdof jaideep_jdof is offline
Port Guard
 
Join Date: Nov 2008
Posts: 45
Thanked 0 Times in 0 Posts
Default

So if i do pkg_delete -R for modular-xorg-server, modular-xorg-apps, modular-xorg-fonts, xf86-input-keyboard, xf86-input-mouse, xf86-video-intel then the issue will be fixed. One more thing should i use -R or -r with pkg_delete.
Reply With Quote
  #9   (View Single Post)  
Old 14th September 2009
s0xxx's Avatar
s0xxx s0xxx is offline
Package Pilot
 
Join Date: May 2008
Posts: 194
Thanked 47 Times in 22 Posts
Default

You will be fine with pkg_delete without any options. In case you want to know what will have happened if you use one, run pkg_delete -nR package or pkg_delete -nr package and decide if you need those options. Option -n means it will display what would happen, but will not actually deinstall anything.

Also, see the following from pkgsrc guide: http://www.netbsd.org/docs/pkgsrc/us...ing.pkg_delete
__________________
The best way to learn UNIX is to play with it, and the harder you play, the more you learn.
If you play hard enough, you'll break something for sure, and having to fix a badly broken system is arguably the fastest way of all to learn. -Michael Lucas, AbsoluteBSD
Reply With Quote
Old 15th September 2009
jaideep_jdof jaideep_jdof is offline
Port Guard
 
Join Date: Nov 2008
Posts: 45
Thanked 0 Times in 0 Posts
Default

I removed all the xorg packages i installed from pkgsrc and added gnome-session to .xinitrc and used startx , the mouse works fine now but gdm still doesn't start, gdm starts if i remove the xorg.conf file which i generated using the command X -configure but then mouse doesn't work.
Reply With Quote
Old 15th September 2009
Tom Tom is offline
Port Guard
 
Join Date: Aug 2008
Location: Poland
Posts: 22
Thanked 0 Times in 0 Posts
Default

While you have properly configured mouse, try to run gdm command (instead of startx) and check if the mouse is working.

If it works, add gdm command to /etc/rc.local, maybe it will work.
Reply With Quote
Old 15th September 2009
jaideep_jdof jaideep_jdof is offline
Port Guard
 
Join Date: Nov 2008
Posts: 45
Thanked 0 Times in 0 Posts
Default

what is the difference between rc.conf and rc.local, and when I auto generate xorg.conf the mouse device is /dev/mouse which i change to /dev/wsmouse and mouse protocol is auto which i change to wsmouse are these correct entries.
Reply With Quote
Old 16th September 2009
jaideep_jdof jaideep_jdof is offline
Port Guard
 
Join Date: Nov 2008
Posts: 45
Thanked 0 Times in 0 Posts
Default

Seems like some of the reply got deleted some how. I want to thank every one for the help. I managed to fix all the issues, so thanks every one.
Reply With Quote
Old 16th September 2009
s0xxx's Avatar
s0xxx s0xxx is offline
Package Pilot
 
Join Date: May 2008
Posts: 194
Thanked 47 Times in 22 Posts
Default

Yes, some posts are missing, see this thread.

I'm glad it's working now. Could you tell us what you did to make it work? Later someone might be having the same issue as you did, he/she could run on this thread but there will be no solution.
__________________
The best way to learn UNIX is to play with it, and the harder you play, the more you learn.
If you play hard enough, you'll break something for sure, and having to fix a badly broken system is arguably the fastest way of all to learn. -Michael Lucas, AbsoluteBSD
Reply With Quote
Old 16th September 2009
jaideep_jdof jaideep_jdof is offline
Port Guard
 
Join Date: Nov 2008
Posts: 45
Thanked 0 Times in 0 Posts
Default

Solution:
1) Remove all the modular xorg package installed using pkgsrc.
2) Reboot your system with the netbsd installed cd and select upgrade option and select the xserver and related sets for installation.
3) Generate a new xorg.conf using X -configure and place it in /etc/X11/.
4) Then restart your gdm.
5) Enjoy NetBSD.
Reply With Quote
Old 19th October 2009
shep shep is offline
ISO Quartermaster
 
Join Date: May 2008
Location: Dry and Dusty
Posts: 592
Thanked 9 Times in 9 Posts
Default

Along the lines of this thread. I installed NetBSD 5.0.1to Via C3 cpu based Asus C3 Terminator barebones with sata drives. I installed the xsets during installation.

The onboard video driver needs either "via", or better yet the openchrome drivers which are in package source.

It was a PITA to install as I had to put the drive in another computer.

My Xorg.0.log indicated the openchrome driver is not available. Can I mix the pkgsrc xf86-video-openchrome drivers with the xsets or do I have do go back and reinstall without xsets and build a modular xorg?

Last edited by shep; 19th October 2009 at 11:56 PM. Reason: added more info
Reply With Quote
Old 20th October 2009
s0xxx's Avatar
s0xxx s0xxx is offline
Package Pilot
 
Join Date: May 2008
Posts: 194
Thanked 47 Times in 22 Posts
Default

Yes, offcourse. Just install the xf86-video-openchrome and change the entry in xorg.conf.
__________________
The best way to learn UNIX is to play with it, and the harder you play, the more you learn.
If you play hard enough, you'll break something for sure, and having to fix a badly broken system is arguably the fastest way of all to learn. -Michael Lucas, AbsoluteBSD
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
mouse freezes in X spiderpig OpenBSD Installation and Upgrading 0 20th April 2009 09:05 AM
Mouse works in console not Xorg shep FreeBSD General 6 13th February 2009 01:01 AM
Not nice PS/2 mouse :/ latorion FreeBSD General 21 11th October 2008 06:02 PM
help with usb mouse?? renej FreeBSD General 14 18th September 2008 01:25 PM
Mouse problems dctr FreeBSD General 3 16th May 2008 02:52 PM


All times are GMT. The time now is 08:12 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick