DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 20th September 2009
idefix idefix is offline
Port Guard
 
Join Date: May 2008
Location: Flanders-Belgium
Posts: 16
Thanked 1 Time in 1 Post
Default arrow keys in X

When I push my left arrow key and keep it pushed in, my cursor moves back only one place.
This is only in applications in X (more specifically in OpenBox).
When my laptop starts and I'm in command line mode, the cursor moves back as long as the arrow key is pushed.

What setting / property should I change?
Thanks in advance for an answer.

Edit: typo corrected

Last edited by idefix; 21st September 2009 at 06:08 PM.
Reply With Quote
  #2   (View Single Post)  
Old 24th September 2009
idefix idefix is offline
Port Guard
 
Join Date: May 2008
Location: Flanders-Belgium
Posts: 16
Thanked 1 Time in 1 Post
Default

Did I ask a stupid question? Or haven't I been clear enough?
Reply With Quote
  #3   (View Single Post)  
Old 24th September 2009
TerryP's Avatar
TerryP TerryP is offline
Arp Constable
 
Join Date: May 2008
Location: USofA
Posts: 1,547
Thanked 112 Times in 104 Posts
Default

Maybe most people hare are as vi-powered thinking as I am, and rarely use the raw arrow keys for anything.
__________________
My Journal

Thou shalt check the array bounds of all strings (indeed, all arrays), for surely where thou typest ``foo'' someone someday shall type ``supercalifragilisticexpialidocious''.
Reply With Quote
  #4   (View Single Post)  
Old 24th September 2009
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

Can you provide the output of the following? in [code][/code] blocks?

$ xset q | grep repeat
Reply With Quote
  #5   (View Single Post)  
Old 24th September 2009
idefix idefix is offline
Port Guard
 
Join Date: May 2008
Location: Flanders-Belgium
Posts: 16
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by BSDfan666 View Post
Can you provide the output of the following? in [code][/code] blocks?

$ xset q | grep repeat
Thank you for your answer. Here's the output:
Quote:
auto repeat: on key click percent: 0 LED mask: 00000000
auto repeat delay: 660 repeat rate: 25
auto repeating keys: 00ffffffdffffbbf
Reply With Quote
  #6   (View Single Post)  
Old 24th September 2009
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

I'm not sure what the issue is, perhaps your keyboard uses different keycodes for the arrow/cursor keys? are you able to confirm this using xev(1)?

Also, are you using a US keyboard? if not, then perhaps you need to configure your keyboard in X.
Reply With Quote
  #7   (View Single Post)  
Old 25th September 2009
idefix idefix is offline
Port Guard
 
Join Date: May 2008
Location: Flanders-Belgium
Posts: 16
Thanked 1 Time in 1 Post
Default

Hi, when I run xev a,d I push the "j" button, the output is:

Code:
KeyRelease event, serial 32, synthetic NO, window 0x1000001,
    root 0x67, subw 0x0, time 1041239, (383,-12), root:(936,13),
    state 0x0, keycode 44 (keysym 0x6a, j), same_screen YES,
    XLookupString gives 1 bytes: (6a) "j"
    XFilterEvent returns: False

When I push the left arrow key, the output is:

Code:
KeyPress event, serial 32, synthetic NO, window 0x1000001,
    root 0x67, subw 0x0, time 1042199, (383,-12), root:(936,13),
    state 0x0, keycode 100 (keysym 0xff51, Left), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False
I don't know if this informtion is useful. I'm just a computer user, who uses freeBSD for my working station.

I'm using a belgian keyboard. I've put in .xinitrc the following line:

Code:
setxkbmap be
EDIT: when I remove this line from .xinitrc, my cursor moves appropriqtely. But now I have a US keyboard instead of a Belgian. qwerty instead of azerty.

Last edited by idefix; 25th September 2009 at 05:28 AM.
Reply With Quote
  #8   (View Single Post)  
Old 25th September 2009
idefix idefix is offline
Port Guard
 
Join Date: May 2008
Location: Flanders-Belgium
Posts: 16
Thanked 1 Time in 1 Post
Default

Problem solved thanks to the clues that you gave!

I added

Code:
Option "XkbLayout" "be"
to /etc/xorg.conf I made. Then I deleted the

Code:
setxkbmap be
from .xinitrc

And now it works fine! (And I learned alot this morning)

Thanks for the help.

Edit: I don't see the thanks-button? Am I overlooking it?

Last edited by idefix; 25th September 2009 at 08:03 AM.
Reply With Quote
  #9   (View Single Post)  
Old 25th September 2009
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,834
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by idefix View Post
I don't see the thanks-button? Am I overlooking it?
The "Thanks!" button might return in a future forum update.

Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ncurses & function keys JimC OpenBSD General 1 24th October 2011 02:36 PM
change compiz-fusion shortcut keys cuongvt FreeBSD General 2 21st September 2008 11:29 AM


All times are GMT. The time now is 10:31 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick