DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 27th October 2009
phill phill is offline
Real Name: Philippe
Port Guard
 
Join Date: Oct 2009
Location: Belgium
Posts: 30
Thanked 0 Times in 0 Posts
Default no sound

Hello, new to OpenBSD.

I seem to have a problem with sound. I don't hear anything.
I am trying with a CD (cdio play) but can't hear anything.

dmesg:
auich0 at pci0 dev 31 function 5 "Intel 82801DB AC97" rev 0x01: apic 1 int 17 (irq 9), ICH4 AC97
ac97: codec id 0x41445374 (Analog Devices AD1981B)
ac97: codec features headphone, 20 bit DAC, No 3D Stereo
audio0 at auich0

Using mixerctl I put all the "mute" settings to "off" (like the FAQ suggests) but I still don't hear anything. Anyone an idea?
Reply With Quote
  #2   (View Single Post)  
Old 27th October 2009
phill phill is offline
Real Name: Philippe
Port Guard
 
Join Date: Oct 2009
Location: Belgium
Posts: 30
Thanked 0 Times in 0 Posts
Default

Ok my mistake... playing mp3's is working...
however audiocd and movies using VLC give no sound
Reply With Quote
  #3   (View Single Post)  
Old 27th October 2009
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

There are 2 methods of playing music CD's..

One is via a small 3 wire cable connected between your CD-ROM drive and your sound card, the other is "digital audio extraction" which does not require that small cable.

Considering MP3's play fine, you should be able to play CD's using the cdplay subcommand of cdio(1).
Reply With Quote
  #4   (View Single Post)  
Old 28th October 2009
phill phill is offline
Real Name: Philippe
Port Guard
 
Join Date: Oct 2009
Location: Belgium
Posts: 30
Thanked 0 Times in 0 Posts
Default

So if I understand correctly:

cdio cdplay: Does not use the special cable. I should hear the music.

cdio play: Uses the special cable. If I do not here music here perhaps the cable is missing or wrongly connected?
Reply With Quote
  #5   (View Single Post)  
Old 28th October 2009
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

Yes that's correct, many CD-ROM drives include the ability in their firmware.. without utilizing CPU time.

Laptop drives often include the ability in their firmware, but omit the connector.. oddly.



If you have this cable, check your mixerctl settings for inputs.cd.mute, it needs to be off.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound on FreeBSD corey_james Guides 19 13th August 2010 11:05 PM
Recording sound with external sound card backrow OpenBSD General 5 21st August 2009 08:17 PM
Sound problem renej FreeBSD General 18 12th September 2008 07:30 PM
Sound JimC FreeBSD General 9 15th August 2008 06:05 PM
USB Sound? FreeMan OpenBSD General 16 7th May 2008 06:09 AM


All times are GMT. The time now is 07:04 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick